Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No sound card recognized
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Vortigern
Guru
Guru


Joined: 25 Nov 2005
Posts: 341
Location: Italy

PostPosted: Wed Dec 27, 2006 10:00 am    Post subject: No sound card recognized Reply with quote

Hi there,
I have new problem, my soundcard is not recognized.
The chip is (according to lspci): 00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
I just built up my new system and compiled the kernel by myself and I built in this card in the kernel in
Device Drivers->Soud->Alsa->PCI devices->
<*> VIA 82C686A/B, 8233/8235 AC97 Controller

But, alsaconf doesn't seem to recognize it, and also alsamixer only shows SAA7134 (that is not a sound card, but my TV card).

What should I do?

Thanks in advance.
Back to top
View user's profile Send private message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Wed Dec 27, 2006 12:49 pm    Post subject: Reply with quote

I'm not sure about this, but it seems as though you might have 2 sound cards. The tv card probably has a sound chip on it. There is a method for configuring 2 or more sound cards, but I am unfamiliar with it. You could try disabling the tv card to test your setup for VIA.
Back to top
View user's profile Send private message
Vortigern
Guru
Guru


Joined: 25 Nov 2005
Posts: 341
Location: Italy

PostPosted: Wed Dec 27, 2006 1:37 pm    Post subject: Reply with quote

Well,
all worked good in the previous installation and I had the same hardware at that time: SAA7134 and VT8235. I use to set the card I wanted to reproduce the audio stream in alsamixer, but now I cannot chose.
I don't think that compiling a new kernel without SAA7134 modules will work, but if this is the only way I can give it a try.
If there isn't any other suggestions just tell me to compile again the kernel.
I should say that I built also the support for OSS, may this causes any problem?
Back to top
View user's profile Send private message
Flameeyes
Developer
Developer


Joined: 30 Mar 2005
Posts: 187
Location: Dublin, Ireland

PostPosted: Wed Dec 27, 2006 2:23 pm    Post subject: Reply with quote

Never build ALSA drivers statically in kernel, even if you use in-kernel drivers, use modules.
_________________
You want to know what I'm working on right now? Just follow my blog.

Flattr me!
Back to top
View user's profile Send private message
Vortigern
Guru
Guru


Joined: 25 Nov 2005
Posts: 341
Location: Italy

PostPosted: Sun Dec 31, 2006 7:30 am    Post subject: Reply with quote

Well,
you were right Flameeyes, I used modules for alsa and now the soundcard is recognized.
But now the problem is how to set the VT8235 as the primary card. All applications seems to look for SAA7134 and having problem since this is only capable of capturing sound. Please tell me how to set this one as primary card!
Thank you.
Back to top
View user's profile Send private message
arabis
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 195
Location: Québec, Canada

PostPosted: Sun Dec 31, 2006 1:02 pm    Post subject: Reply with quote

Vortigern wrote:
But now the problem is how to set the VT8235 as the primary card.

You can add these lines in your /etc/modules.d/alsa:
Code:
options snd-via82xx index=0
options snd-saa7134-alsa index=1
options snd cards_limit=2

As described here:
http://gentoo-wiki.com/HOWTO_ALSA_sound_mixer_aka_dmix#Post-Installation_Configuration
Note: I am not sure about the right name of modules "snd-via82xx" "saa7134-alsa".
_________________
Acer Ferrari 4002 WLMI fr
AMD64, Turion ML-30
ATI Mobility X700
DVDR double couche
Back to top
View user's profile Send private message
Vortigern
Guru
Guru


Joined: 25 Nov 2005
Posts: 341
Location: Italy

PostPosted: Sun Dec 31, 2006 4:50 pm    Post subject: Reply with quote

Well,
thanks for your answer arabis, but that didn't work. :(
This is my /etc/modules.d/alsa
Code:
# Alsa kernel modules' configuration file.

# ALSA portion
# OSS/Free portion

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `modules-update' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.13 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-via82xx
alias sound-slot-0 snd-via82xx
# --- END: Generated by ALSACONF, do not edit. ---

I've tried to add the lines you suggested and following the guide, but nothing worked!
Even alsamixer accept Saa7134 as the default card! (#alsamixer -c 0 show me the mixer of saa7134)
Any other ideas?
Back to top
View user's profile Send private message
arabis
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 195
Location: Québec, Canada

PostPosted: Sun Dec 31, 2006 9:42 pm    Post subject: Reply with quote

Maybe you should try this /etc/modules.d/alsa instead:
Code:
#Alsa kernel modules' configuration file.

alias char-major-116 snd
alias char-major-14 soundcore

alias snd-card-0 snd-via82xx
alias sound-slot-0 snd-card-0

alias /dev/dsp snd-pcm-oss

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

options snd-via82xx index=0

alias snd-card-1 snd-saa7134
alias sound-slot-1 snd-card-1

alias /dev/dsp1 snd-pcm-oss

alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss

options snd-saa7134-alsa index=1

options snd cards_limit=2


After the changes, don't forget to run:
Code:
# modules-update -f

_________________
Acer Ferrari 4002 WLMI fr
AMD64, Turion ML-30
ATI Mobility X700
DVDR double couche
Back to top
View user's profile Send private message
Vortigern
Guru
Guru


Joined: 25 Nov 2005
Posts: 341
Location: Italy

PostPosted: Mon Jan 01, 2007 12:12 pm    Post subject: Reply with quote

Bad news arabis,
I need to do a step back! The new configuration file didn't work.
I run
Code:
emerge alsa-utils alsa-oss
and now alsa doesn't recognize anymore the VIA card :(
I didn't modify the kernel, only merged again alsa-utils (and alsa-oss for the first time).
This is my kernel configuration:
Code:
   
Device Drivers  --->
    Character devices --->
        <*> Enhanced Real Time Clock Support
    Sound  --->
                           <*> Advanced Linux Sound Architecture
                           <*>   Sequencer support
                           < >     Sequencer dummy client
                           <*>   OSS Mixer API
                           <*>   OSS PCM (digital audio) API
                           [*]     OSS PCM (digital audio) API - Include plugin system
                           [*]   OSS Sequencer API
                           <*>   RTC Timer support
                           [*]     Use RTC as default sequencer timer
                           [ ]   Dynamic device file minor numbers
                           [ ]   Support old ALSA API
                           [*]   Verbose procfs contents
                           [ ]   Verbose printk
                           [ ]   Debug
                                 Generic devices  --->
                                 PCI devices  --->
                                           ....
                                           <M> VIA 82C686A/B, 8233/8235 AC97 Controller
                                           ....
                                 USB devices  --->

Why it worked only before re-emerging?
Why should I compile alsa as modules? (If I don't remember wrong, in the previous installation I built all in the kernel, and it worked!)
Am I missing something?

I read there was and issue with kernel 2.6.16, but I'm using: linux-2.6.18-gentoo-r4

Please help me!!!
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1500
Location: Switzerland (Romandie)

PostPosted: Mon Jan 01, 2007 3:53 pm    Post subject: Reply with quote

Please, select all the sound options in the kernel config as modules, they will not work included in the kernel. I am not sure about "Enhanced Real Time Clock Support", I have it as module too.

And you can select "Support old ALSA API" (some old programs still use it) and unselect "Verbose procfs contents" (normally not needed).
_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
arabis
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 195
Location: Québec, Canada

PostPosted: Mon Jan 01, 2007 5:06 pm    Post subject: Reply with quote

Dominique_71 wrote:
Please, select all the sound options in the kernel config as modules

I was about to suggest the same. In fact, simply follow the kernel config suggested there:
http://www.gentoo.org/doc/en/alsa-guide.xml
Code:
Device Drivers  --->
   Sound  --->
   
<M> Sound card support

Advanced Linux Sound Architecture  --->
   <M> Advanced Linux Sound Architecture
      <M> Sequencer support
      <M> OSS Mixer API
   <M> OSS PCM (digital audio) API


PCI devices   --->
   
   <M> VIA 82C686A/B, 8233/8235 AC97 Controller


Also make sure everything in your kernel about your saa7134 card is compiled as modules:
Code:
<M> Video For Linux
<M> Philips SAA7134 support
<M>   Philips SAA7134 DMA audio support

If you previously set this card statically in kernel, that's maybe why your system is taking it as its primary card.
Vortigern wrote:
Why should I compile alsa as modules?

One thing is to be able to configure modules loading to set your default sound card. Also, this way is recommended by the Gentoo documentation. It is less complicated to follow instructions already known to be working.
Quote:
I need to do a step back! The new configuration file didn't work.

alsaconf (curiously, and I don't know why) doesn't work for some cards. This was my case with my atiixp. I had to set my /etc/modules.d/alsa manually. After you change your kernel, I think you can try this simpler /etc/modules.d/alsa file:
Code:
#Alsa kernel modules' configuration file.

alias char-major-116 snd
alias char-major-14 soundcore

alias snd-card-0 snd-via82xx
alias sound-slot-0 snd-card-0

alias /dev/dsp snd-pcm-oss

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

options snd cards_limit=1


Once, you got this card working, it will be easier to concentrate on your second card.
_________________
Acer Ferrari 4002 WLMI fr
AMD64, Turion ML-30
ATI Mobility X700
DVDR double couche
Back to top
View user's profile Send private message
Vortigern
Guru
Guru


Joined: 25 Nov 2005
Posts: 341
Location: Italy

PostPosted: Wed Jan 03, 2007 12:21 pm    Post subject: Reply with quote

Well,
a good news and a bad one!
The good one is that now my VT8235 is working :D.
I compiled the modules in this way:
Code:
Device Drivers  --->
    Character devices --->
        <*> Enhanced Real Time Clock Support
    Sound  --->
        <M> Advanced Linux Sound Architecture
        <M>   Sequencer support
        < >     Sequencer dummy client
        <M>   OSS Mixer API
        <M>   OSS PCM (digital audio) API
        [*]     OSS PCM (digital audio) API - Include plugin system
        [*]   OSS Sequencer API
        <M>   RTC Timer support
        [*]     Use RTC as default sequencer timer
        [ ]   Dynamic device file minor numbers
        [ ]   Support old ALSA API
        [*]   Verbose procfs contents
        [ ]   Verbose printk
        [ ]   Debug
             Generic devices  --->
              PCI devices  --->
                    ....
                    <M> VIA 82C686A/B, 8233/8235 AC97 Controller
                    ....
              USB devices  --->
     Multimedia devices --->
        <*> Video For Linux
        [*]   Enable Video For Linux API 1 (DEPRECATED)
        ---   Enable Video For Linux API 1 compatible Layer
             Video Capture Adapters  --->
               <M> Philips SAA7134 support
               <M>   Philips SAA7134 DMA audio support
               <M>   DVB/ATSC Support for saa7134 based TV cards
               [*]     Build all supported frontends for saa7134 based TV cards



The bad news is that now my SAA7134 is recognized only as Analog Devices AD1980 (OSS Mixer) in alsamixer and i got this error when restarting alsa:
Code:
GeNToO linux # /etc/init.d/alsasound restart
 * Storing ALSA Mixer Levels ...                                               [ ok ]
 * Unloading ALSA ...                                                          [ ok ]
 * Unloading ALSA modules ...                                                  [ ok ]
 * Loading ALSA modules ...
 *   Loading: snd-card-0 ...                                                   [ ok ]
 *   Loading: snd-card-1 ...
FATAL: Module snd_saa7134 not found.                                           [ !! ]
 *   Loading: snd-pcm-oss ...                                                  [ ok ]
 *   Loading: snd-seq-oss ...                                                  [ ok ]
 * Restoring Mixer Levels ...


I checked the kernel and it says that the modules for saa7134 is called saa7134.

What should I do now?

Thanks for your help!
Back to top
View user's profile Send private message
arabis
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 195
Location: Québec, Canada

PostPosted: Wed Jan 03, 2007 2:55 pm    Post subject: Reply with quote

I think to run a saa7134 with alsa you need saa7134-alsa module. You can follow this guide:
http://gentoo-wiki.com/HARDWARE_saa7134
_________________
Acer Ferrari 4002 WLMI fr
AMD64, Turion ML-30
ATI Mobility X700
DVDR double couche
Back to top
View user's profile Send private message
marco007
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 99

PostPosted: Sun Mar 04, 2007 8:17 am    Post subject: Reply with quote

i cant get no sound with audigy2+kworld tv-terminator
everything works with 2.6.18-r6 kernel
but no 2.6.19-r5

# Video Capture Adapters
#
# CONFIG_VIDEO_ADV_DEBUG is not set
CONFIG_VIDEO_HELPER_CHIPS_AUTO=y
# CONFIG_VIDEO_VIVI is not set
# CONFIG_VIDEO_SAA5246A is not set
# CONFIG_VIDEO_SAA5249 is not set
CONFIG_VIDEO_SAA7134=m
# CONFIG_VIDEO_HEXIUM_ORION is not set
# CONFIG_VIDEO_HEXIUM_GEMINI is not set
# CONFIG_VIDEO_CX88 is not set

ps.mp3/dvd+divx works 100%
_________________
e6400@3.6Ghz,Gigabyte MB
6800GS+Zalman,Audigy2
Gentoo+2.6.18-r5
Back to top
View user's profile Send private message
Vortigern
Guru
Guru


Joined: 25 Nov 2005
Posts: 341
Location: Italy

PostPosted: Mon Mar 05, 2007 7:12 pm    Post subject: Reply with quote

Try with the newest 2.6.20 and be sure to have used the same configuration for the kernel.
Check that OSS is disabled.
Back to top
View user's profile Send private message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 874
Location: Hamburg, Germany

PostPosted: Mon Mar 05, 2007 8:12 pm    Post subject: Reply with quote

Multiple soundcards can be a pain in the ass: Newer udev versioens have coldplugging abilties, so udev loads the module when the device is detected by the kernel at boot time. You can't rely on any particular order. So you need normally to tell the modules which should be the first, second, and so on by adding an index=n option to the line in /etc/modules.d/alsa.

For some reasons I don't know this simply sometimes won't work. The order appears messed up, or sound cards seem to diassapear. That wouldn't be a big problem, udev should normally respect blacklisted moduls, which you define by a line "blacklist snd-yoursoundcard" in /etc/modules.d/blacklist. The alsa init scripts will then do do the job to load the modules (which normally works quite good and gives you the correct order, and that's one of the reasons why we have alsa init scripts).

The real fun begins that now, that this blacklisting method is broken since months between udev and modules-update. modules-update throws errors like "Can't generate modprobe.conf" when it tries to join in the /etc/modules.d/blacklist. So a workaround is to run "modules-update" and then append manually the "blacklist ..." lines to /etc/modprobe.conf. This will be overwritten the next time when you run modules-update.

I'm not sure if the situation is really f*cked up in gentoo like that in the moment, or if just my configuration is a bit special and there is a better way to solve these problems. But if you look at other distributions like SuSE they blacklist about over hundred modules (esp. all sound modules and some which are well known to cause problems when unintenionally autoloaded by udev) and have a working blacklisting mechanism (YaST respects blacklisting) when generating a new modprobe.conf.

If it's really like I see it, gentoo's modutils and udev versions need very much love ...
Back to top
View user's profile Send private message
marco007
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 99

PostPosted: Mon Mar 05, 2007 8:35 pm    Post subject: Reply with quote

Vortigern wrote:
Try with the newest 2.6.20 and be sure to have used the same configuration for the kernel.
Check that OSS is disabled.

only way how my tv-tuner sound works->kernel 2.6.18-r5 (or lower) +alsa 1.0.13
_________________
e6400@3.6Ghz,Gigabyte MB
6800GS+Zalman,Audigy2
Gentoo+2.6.18-r5
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1500
Location: Switzerland (Romandie)

PostPosted: Tue Mar 06, 2007 1:07 pm    Post subject: Reply with quote

furanku wrote:
Multiple soundcards can be a pain in the ass: Newer udev versioens have coldplugging abilties, so udev loads the module when the device is detected by the kernel at boot time. You can't rely on any particular order. So you need normally to tell the modules which should be the first, second, and so on by adding an index=n option to the line in /etc/modules.d/alsa.

Not true. The file ALSA-configuration.txt that is both in the kernel doc and in alsa-driver doc explain how to do it.

Quote:
For some reasons I don't know this simply sometimes won't work. The order appears messed up, or sound cards seem to diassapear. That wouldn't be a big problem, udev should normally respect blacklisted moduls, which you define by a line "blacklist snd-yoursoundcard" in /etc/modules.d/blacklist. The alsa init scripts will then do do the job to load the modules (which normally works quite good and gives you the correct order, and that's one of the reasons why we have alsa init scripts).
According to the alsa devs, the right way to do it will be by writing udev rules. Alsasound and its configuration script /etc/modules.d/alsa is a wrapper to udev

Quote:
The real fun begins that now, that this blacklisting method is broken since months between udev and modules-update. modules-update throws errors like "Can't generate modprobe.conf" when it tries to join in the /etc/modules.d/blacklist. So a workaround is to run "modules-update" and then append manually the "blacklist ..." lines to /etc/modprobe.conf. This will be overwritten the next time when you run modules-update.

I'm not sure if the situation is really f*cked up in gentoo like that in the moment, or if just my configuration is a bit special and there is a better way to solve these problems. But if you look at other distributions like SuSE they blacklist about over hundred modules (esp. all sound modules and some which are well known to cause problems when unintenionally autoloaded by udev) and have a working blacklisting mechanism (YaST respects blacklisting) when generating a new modprobe.conf.

If it's really like I see it, gentoo's modutils and udev versions need very much love ...

This bug is solved. But the fact remain at, if you have a correct alsa configuration, it must be no need to blacklist anything. If it is not the case, double check your configuration and report it as a bug. As example, here is my /etc/modules.d/alsa and it was working fine even when this udev bug was actual:
Code:
# Alsa 0.9.X kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
alias snd-card-0 snd-emu10k1
options snd-emu10k1 index=0
alias snd-card-1 snd-usb-audio
options snd-usb-audio index=1
alias snd-card-2 snd-virmidi
options snd-virmidi index=2
alias snd-card-3 snd-ens1370
options snd-ens1370 index=3

##  OSS/Free portion
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1
alias sound-slot-2 snd-card-2
alias sound-slot-3 snd-card-3
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss
##
alias sound-service-2-0 snd-mixer-oss
alias sound-service-2-3 snd-pcm-oss
alias sound-service-2-12 snd-pcm-oss
##
alias sound.service-3-0 snd-mixer-oss
alias sound-service-3-3 snd-pcm-oss
alias sound-service-3-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=4

# Set a big wavetable/pcm buffer in MB + more voices
options snd-emu10k1 max_buffer_size=256
# max_synth_voices=256

_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 874
Location: Hamburg, Germany

PostPosted: Tue Mar 06, 2007 4:57 pm    Post subject: Reply with quote

Dominique_71 wrote:
furanku wrote:
You can't rely on any particular order. So you need normally to tell the modules which should be the first, second, and so on by adding an index=n option to the line in /etc/modules.d/alsa.

Not true. The file ALSA-configuration.txt that is both in the kernel doc and in alsa-driver doc explain how to do it.

??? That file in /usr/src/linux/Documents/sound/alsa/ says exactly that:
Quote:
Common parameters for top sound card modules
--------------------------------------------

Each of top level sound card module takes the following options.

index - index (slot #) of sound card
- Values: 0 through 31 or negative
- If nonnegative, assign that index number
- if negative, interpret as a bitmask of permissible
indices; the first free permitted index is assigned
- Default: -1
and you use the index parameter in your alsa configuration file as well. So I don't understand what you mean with "Not true."

Also G-K Hartmann, the developer of udev writes:
"G-K Hartmann wrote:
If you rely on the specific loading order of modules, you were the crazy
one in the first place :)


Quote:
According to the alsa devs, the right way to do it will be by writing udev rules.

wich is ... um ... err ... "well" documentated, and even by the alsa dev's just considered mostly usefull for setups with two or more identical cards (or more pathological cases), which is not the case in my or your setup. For systems with different devices the "index=n" parameter is still the way to go. Believe me, I've tried a long time to get my setup up and running and have searched and read read a lot pages ...

Quote:

Quote:
For some reasons I don't know this simply sometimes won't work. ...

This bug is solved. But the fact remain at, if you have a correct alsa configuration, it must be no need to blacklist anything. If it is not the case, double check your configuration and report it as a bug.


OK. Here's my /etc/modules.d/alsa
Code:
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsa-modules.conf-rc,v 1.4 2004/11/16 01:31:22 eradicator Exp $

# ALSA portion
# OSS/Free portion

alias char-major-116 snd
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
#alias snd-card-2 snd_bt87x
##  OSS/Free portion
#alias sound-slot-2 snd-card-2
##

# OSS/Free portion - card #1

alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-card-0

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-12 snd-pcm-oss

options snd-intel8x0 index=0

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss

##  OSS/Free portion - card #2

alias snd-card-1 cx88-alsa
alias sound-slot-1 cx88-alsa

alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-8 snd-seq-os
alias sound-service-1-12 snd-pcm-oss

options cx88-alsa index=1

alias /dev/mixer1 snd-mixer-oss
alias /dev/dsp1 snd-pcm-oss
alias /dev/midi snd-seq-oss

##  OSS/Free portion - card #3

alias snd-card-2 snd-cmipci
alias sound-slot-2 snd-cmipci

alias sound-service-2-0 snd-mixer-oss
alias sound-service-2-3 snd-pcm-oss
alias sound-service-2-8 snd-seq-oss
alias sound-service-2-12 snd-pcm-oss

options snd-cmipci mpu_port=0x330 fm_port=0x388 index=2

alias /dev/mixer2 snd-mixer-oss
alias /dev/dsp2 snd-pcm-oss

options snd cards_limit=3

which gives with blacklisting all involved modules the desired order:
Code:
# cat /proc/asound/cards
 0 [CK804          ]: NFORCE - NVidia CK804
                      NVidia CK804 with ALC850 at 0xfe02d000, irq 22
 1 [CX8811         ]: CX88x - Conexant CX8811
                      Conexant CX8811 at 0xfa000000
 2 [CMI8738MC6     ]: CMI8738-MC6 - C-Media PCI CMI8738-MC6
                      C-Media PCI CMI8738-MC6 (model 55) at 0xac00, irq 17
but without blacklisting the onboard sound magically disapears:
Code:
# cat /proc/asound/cards
 1 [CX8811         ]: CX88x - Conexant CX8811
                      Conexant CX8811 at 0xfa000000
 2 [CMI8738MC6     ]: CMI8738-MC6 - C-Media PCI CMI8738-MC6
                      C-Media PCI CMI8738-MC6 (model 55) at 0xac00, irq 17

Changing it back, the onboard sound is back again. Really the only thing I changed was removing the "blacklist" lines in /etc/modprobe.conf and rebootet. Also configuring blacklisted modules in a standard way (wich would be in /etc/modules.d/blacklist) is still broken: Try it out:
Code:
# echo "blacklist snd-cmipci" >/etc/modules.d/blacklist
# modules-update
 * Updating /etc/modules.conf ...                                                                                   [ ok ]
 * Updating /etc/modprobe.conf ...
 * Warning: could not generate /etc/modprobe.conf!                                                                  [ !! ]
 * Updating /etc/modprobe.conf by hand ...                                                                          [ ok ]
 * Updating modules.dep ... 

and the blacklist entry did't make it into modprobe.conf
Code:

# grep snd-cmipci /etc/modprobe.conf
alias snd-card-2 snd-cmipci
alias sound-slot-2 snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388 index=2


What is fixed, that udev respects blackslist entries in /etc/modprobe.conf, but as you see, there is no standard compatible way to get them there, as modules-update still can't handle blacklisting correctly. That's why I said the error is between udev and modutils. udev is fixed but without fixing modules-update we still need a workaround.
Quote:
... and report it as a bug.

As far as I can see this topic is alread covered by the bug report I mentioned above, so I think the dev's are aware of the situation.

The alsa configuration is not the only thing where blacklisting a module from being autoloaded by udev would be usefull, there are for some network devices multiple drivers, some modules are known to cause problems (evbug) when loaded unitentionally, ... Take a look at other distributions. All of them really relay on a working blacklisting, as udev usually does a good job when coldplugging, but even it's developer wouldn't say that say that udevs coldplugging is unfailable and perfect. So a mechanism to prevent udev from coldplugging in these cases would be really useful.

So, if you see any obvious error in my configuration, please tell me.
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1500
Location: Switzerland (Romandie)

PostPosted: Wed Mar 07, 2007 1:14 pm    Post subject: Reply with quote

Furanku, not true was for the assertion at Multiple soundcards can be a pain in the ass. With a correct alsa configuration, it must work. And if you have to blacklist a module to get a given order, it is a bug. That say, I know at many distributions are blacklisting modules.

Where are you blaklisting your modules? I ask this because you are talking about /etc/modules.d/blacklist when udev use /etc/hotplug/blacklist at boot time.
_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
marco007
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 99

PostPosted: Sun Mar 11, 2007 11:30 am    Post subject: Reply with quote

wtf :evil: still no sound with my tv-card
kernel-2.6.20-gentoo-r2
alsa 1.0.14_rc2_p3234
seems that problem is with kernels 2.6.19 and up
2.6.18-gentoo-r5+alsa 1.0.14_rc2_p3234 and tv-card sound works (y)

maybe problem is there
# CONFIG_VIDEO_ZORAN is not set
CONFIG_VIDEO_SAA7134=m
"THERE IS NO ALSA STUFF 8O "
# CONFIG_VIDEO_MXB is not set
sorry ma bad english
_________________
e6400@3.6Ghz,Gigabyte MB
6800GS+Zalman,Audigy2
Gentoo+2.6.18-r5
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1500
Location: Switzerland (Romandie)

PostPosted: Sun Mar 11, 2007 3:28 pm    Post subject: Reply with quote

It is a new option in the kernel config for v4l. You have 2 possibilities and the drivers you will get are not the same. It is in Device Drivers-> Multimedia. It is 2 API, one deprecated, the other not. Not all the drivers are in the new one. Maybe at your problem is related to that.
_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
marco007
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 99

PostPosted: Thu Mar 15, 2007 2:28 pm    Post subject: Reply with quote

tryed both ways and no sound
wtf is going on with gentoo :evil:
i must use 2.18-r5 kernel life time :evil: ?
+2.6.18-5 not on x86 8O 8O
_________________
e6400@3.6Ghz,Gigabyte MB
6800GS+Zalman,Audigy2
Gentoo+2.6.18-r5
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1500
Location: Switzerland (Romandie)

PostPosted: Thu Mar 15, 2007 3:34 pm    Post subject: Reply with quote

@marco007

It is no more problems with gentoo as with any other good linux distribution.

Most tv card have a connector, and the best way to get sound is to put a small audio cable between the tv card and the audio card. If it is not possible, it is a saa7134-alsa module that you can select with "Philips SAA7134 DMA audio support" in the kernel configuration dialog. And this option is in both 2.6.19 and 2.6.20 kernels.
_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
marco007
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 99

PostPosted: Thu Mar 15, 2007 3:47 pm    Post subject: Reply with quote

http://img389.imageshack.us/img389/798/saa7134gk7.png
there is no Philips SAA7134 DMA audio support" option :(
.config
# CONFIG_VIDEO_ADV_DEBUG is not set
CONFIG_VIDEO_HELPER_CHIPS_AUTO=y
# CONFIG_VIDEO_VIVI is not set
# CONFIG_VIDEO_SAA5246A is not set
# CONFIG_VIDEO_SAA5249 is not set
CONFIG_VIDEO_SAA7134=m
# CONFIG_VIDEO_HEXIUM_ORION is not set
# CONFIG_VIDEO_HEXIUM_GEMINI is not set
# CONFIG_VIDEO_CX88 is not set
# CONFIG_VIDEO_CAFE_CCIC is not set
_________________
e6400@3.6Ghz,Gigabyte MB
6800GS+Zalman,Audigy2
Gentoo+2.6.18-r5
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum