Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mono refuses to compile [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Kaste
Guru
Guru


Joined: 21 Dec 2005
Posts: 536
Location: /home Sweet /home

PostPosted: Sat Jan 06, 2007 11:39 pm    Post subject: mono refuses to compile [solved] Reply with quote

well refusing is a little to weak actually.

I still have 1.1.13.6 installed because every version since then fails in one way or the other.
I tried emerge -e system && emerge -e world and it would compile eveything except mono. At the moment I'm trying to install the latest stable version 1.2.2.1 and i get this error
Code:

MONO_PATH="../../class/lib/net_2_0_bootstrap:$MONO_PATH" /var/tmp/portage/dev-la 
ng/mono-1.2.2.1/work/mono-1.2.2.1/runtime/mono-wrapper  ../../class/lib/net_2_0_ 
bootstrap/mcs.exe /codepage:65001   -d:NET_1_1 -d:BOOTSTRAP_NET_2_0 -debug /noco 
nfig -r:System.dll -unsafe -target:library -out:Mono.Security.dll  @Mono.Securit 
y.dll.sources

** (../../class/lib/net_2_0_bootstrap/mcs.exe:19272): WARNING **: Missing method 
 .ctor in assembly /usr/lib/mono/gac/I18N/2.0.0.0__0738eb9f132ed756/I18N.dll, ty 
pe System.Runtime.CompilerServices.RuntimeCompatibilityAttribute

** ERROR **: Can't find custom attr constructor image: /usr/lib/mono/gac/I18N/2. 
0.0.0__0738eb9f132ed756/I18N.dll mtoken: 0x0a00003f
aborting...
Stacktrace:

  at (wrapper managed-to-native) System.AppDomain.LoadAssembly (string,System.Se 
curity.Policy.Evidence,bool) <0x00004>
  at (wrapper managed-to-native) System.AppDomain.LoadAssembly (string,System.Se 
curity.Policy.Evidence,bool) <0xffffffff>
  at System.AppDomain.Load (string) <0x00018>
  at (wrapper remoting-invoke-with-check) System.AppDomain.Load (string) <0xffff 
ffff>
  at System.Reflection.Assembly.Load (string) <0x0001b>
  at System.Text.Encoding.InvokeI18N (string,object[]) <0x0007c>
  at System.Text.Encoding.GetEncoding (string) <0x0015d>
  at System.Text.Encoding.get_Default () <0x0006b>
  at System.Console..cctor () <0x000e0>
  at (wrapper runtime-invoke) System.Object.runtime_invoke_void (object,intptr,i 
ntptr,intptr) <0xffffffff>
  at Mono.CSharp.Report..cctor () <0xffffffff>
  at Mono.CSharp.Report..cctor () <0x0000a>
  at (wrapper runtime-invoke) System.Object.runtime_invoke_void (object,intptr,i 
ntptr,intptr) <0xffffffff>

Native stacktrace:

        /var/tmp/portage/dev-lang/mono-1.2.2.1/work/mono-1.2.2.1/mono/mini/mono   
[0x814fb92]
        [0x4001b440]
        /lib/libc.so.6(abort+0x103) [0x40146b33]
        /usr/lib/libglib-2.0.so.0(g_logv+0x3eb) [0x40080e6b]

Debug info from gdb:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1076060320 (LWP 19272)]
[New Thread 1085332384 (LWP 19340)]
[New Thread 1078557600 (LWP 19339)]
0x4001b410 in ?? ()
  3 Thread 1078557600 (LWP 19339)  0x4001b410 in ?? ()
  2 Thread 1085332384 (LWP 19340)  0x4001b410 in ?? ()
  1 Thread 1076060320 (LWP 19272)  0x4001b410 in ?? ()

Thread 3 (Thread 1078557600 (LWP 19339)):
#0  0x4001b410 in ?? ()
#1  0x40497458 in ?? ()
#2  0x081e6520 in ?? ()
#3  0x00000000 in ?? ()

Thread 2 (Thread 1085332384 (LWP 19340)):
#0  0x4001b410 in ?? ()
#1  0x40b0d258 in ?? ()
#2  0x00000001 in ?? ()
#3  0x00000000 in ?? ()

Thread 1 (Thread 1076060320 (LWP 19272)):
#0  0x4001b410 in ?? ()
#1  0xbffe86b4 in ?? ()
#2  0x00000000 in ?? ()
#0  0x4001b410 in ?? ()


=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================


Any help greatly appreciated.
_________________
I'm a membar of Mesnar and me scull contains wakky secrets!


Last edited by Kaste on Sun Jan 07, 2007 3:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
santaclaws
Apprentice
Apprentice


Joined: 05 Jan 2007
Posts: 161
Location: Deeper Underground

PostPosted: Sun Jan 07, 2007 10:58 am    Post subject: Reply with quote

I am emerging mono-1.2.2.1 at the moment - lets see what happens. :wink:
_________________
Software is like sex. It is better when ist is free.
Back to top
View user's profile Send private message
santaclaws
Apprentice
Apprentice


Joined: 05 Jan 2007
Posts: 161
Location: Deeper Underground

PostPosted: Sun Jan 07, 2007 11:39 am    Post subject: Reply with quote

Ok. same problem :cry:

Code:
make[8]: Entering directory `/var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1/mcs/class/Mono.Security'
MONO_PATH="../../class/lib/net_2_0_bootstrap:$MONO_PATH" /var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1/runtime/mono-wrapper  ../../class/lib/net_2_0_bootstrap/mcs.exe /codepage:65001   -d:NET_1_1 -d:BOOTSTRAP_NET_2_0 -debug /noconfig -r:System.dll -unsafe -target:library -out:Mono.Security.dll  @Mono.Security.dll.sources

** (../../class/lib/net_2_0_bootstrap/mcs.exe:5288): WARNING **: Missing method .ctor in assembly /usr/lib/mono/gac/I18N/2.0.0.0__0738eb9f132ed756/I18N.dll, type System.Runtime.CompilerServices.RuntimeCompatibilityAttribute

** ERROR **: Can't find custom attr constructor image: /usr/lib/mono/gac/I18N/2.0.0.0__0738eb9f132ed756/I18N.dll mtoken: 0x0a00003f
aborting...
Stacktrace:

  at (wrapper managed-to-native) System.AppDomain.LoadAssembly (string,System.Security.Policy.Evidence,bool) <0x00004>
  at (wrapper managed-to-native) System.AppDomain.LoadAssembly (string,System.Security.Policy.Evidence,bool) <0xffffffff>
  at System.AppDomain.Load (string) <0x00018>
  at (wrapper remoting-invoke-with-check) System.AppDomain.Load (string) <0xffffffff>
  at System.Reflection.Assembly.Load (string) <0x0001b>
  at System.Text.Encoding.InvokeI18N (string,object[]) <0x0007c>
  at System.Text.Encoding.GetEncoding (string) <0x0015d>
  at System.Text.Encoding.get_Default () <0x0006b>
  at System.Console..cctor () <0x000e0>
  at (wrapper runtime-invoke) System.Object.runtime_invoke_void (object,intptr,intptr,intptr) <0xffffffff>
  at Mono.CSharp.Report..cctor () <0xffffffff>
  at Mono.CSharp.Report..cctor () <0x0000a>
  at (wrapper runtime-invoke) System.Object.runtime_invoke_void (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

        /var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1/mono/mini/mono [0x8157ffb]
        [0x4001c440]
        /lib/libc.so.6(abort+0x108) [0x4014bea8]
        /usr/lib/libglib-2.0.so.0(g_logv+0x3c9) [0x4007dfb9]

Debug info from gdb:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1076149088 (LWP 5288)]
[New Thread 1085270928 (LWP 5356)]
[New Thread 1078516624 (LWP 5355)]
0x4001c410 in ?? ()
  3 Thread 1078516624 (LWP 5355)  0x4001c410 in ?? ()
  2 Thread 1085270928 (LWP 5356)  0x4001c410 in ?? ()
  1 Thread 1076149088 (LWP 5288)  0x4001c410 in ?? ()
0x4001c410 in ?? ()

Thread 3 (Thread 1078516624 (LWP 5355)):
#0  0x4001c410 in ?? ()
#1  0x4048d3b8 in ?? ()
#2  0x081f02e0 in ?? ()
#3  0x00000000 in ?? ()

Thread 2 (Thread 1085270928 (LWP 5356)):
#0  0x4001c410 in ?? ()
#1  0x40afe1b8 in ?? ()
#2  0x00000001 in ?? ()
#3  0x00000000 in ?? ()

Thread 1 (Thread 1076149088 (LWP 5288)):
#0  0x4001c410 in ?? ()
#0  0x4001c410 in ?? ()


=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

make[8]: *** [../../class/lib/net_2_0_bootstrap/Mono.Security.dll] Aborted
make[8]: Leaving directory `/var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1/mcs/class/Mono.Security'
make[7]: *** [do-all] Error 2
make[7]: Leaving directory `/var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1/mcs/class/Mono.Security'
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory `/var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1/mcs/class'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1/mcs'
make[4]: *** [profile-do--net_2_0_bootstrap--all] Error 2
make[4]: Leaving directory `/var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1/mcs'
make[3]: *** [profiles-do--all] Error 2
make[3]: Leaving directory `/var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1/mcs'
make[2]: *** [all-local] Error 2
make[2]: Leaving directory `/var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1/runtime'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/mono-1.2.2.1/work/mono-1.2.2.1'
make: *** [all] Error 2

!!! ERROR: dev-lang/mono-1.2.2.1 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  mono-1.2.2.1.ebuild, line 90:   Called die

!!! compile failed
!!! If you need support, post the topmost build error, and the call stack if relevant.



Anybody an idea?
_________________
Software is like sex. It is better when ist is free.
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Jan 07, 2007 12:32 pm    Post subject: Reply with quote

http://bugs.gentoo.org/show_bug.cgi?id=146424
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Kaste
Guru
Guru


Joined: 21 Dec 2005
Posts: 536
Location: /home Sweet /home

PostPosted: Sun Jan 07, 2007 3:48 pm    Post subject: Reply with quote

OK thanks really solved it.
I don't see the need though. Why does it hinder the compilation if the old version of it is still on the system?

Anyway thanks for the fix. Greatly appreciated
_________________
I'm a membar of Mesnar and me scull contains wakky secrets!
Back to top
View user's profile Send private message
santaclaws
Apprentice
Apprentice


Joined: 05 Jan 2007
Posts: 161
Location: Deeper Underground

PostPosted: Mon Jan 08, 2007 9:34 am    Post subject: Reply with quote

I solved it either. :D

Code:
emerge -Ca mono && emerge mono

_________________
Software is like sex. It is better when ist is free.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum