Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200612-16 ] Links: Arbitrary Samba command execution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Thu Dec 14, 2006 2:26 pm    Post subject: [ GLSA 200612-16 ] Links: Arbitrary Samba command execution Reply with quote

Gentoo Linux Security Advisory

Title: Links: Arbitrary Samba command execution (GLSA 200612-16)
Severity: normal
Exploitable: remote
Date: December 14, 2006
Bug(s): #157028
ID: 200612-16

Synopsis

Links does not properly validate "smb://" URLs, making it vulnerable to the execution of arbitrary Samba commands.

Background

Links is a web browser running in both graphics and text modes.

Affected Packages

Package: www-client/links
Vulnerable: < 2.1_pre26
Unaffected: >= 2.1_pre26
Architectures: All supported architectures


Description

Teemu Salmela discovered that Links does not properly validate "smb://" URLs when it runs smbclient commands.

Impact

A remote attacker could entice a user to browse to a specially crafted "smb://" URL and execute arbitrary Samba commands, which would allow the overwriting of arbitrary local files or the upload or the download of arbitrary files. This vulnerability can be exploited only if "smbclient" is installed on the victim's computer, which is provided by the "samba" Gentoo package.

Workaround

There is no known workaround at this time.

Resolution

All Links users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/links-2.1_pre26"


References

CVE-2006-5925
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum