Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200612-14 ] Trac: Cross-site request forgery
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Tue Dec 12, 2006 11:26 pm    Post subject: [ GLSA 200612-14 ] Trac: Cross-site request forgery Reply with quote

Gentoo Linux Security Advisory

Title: Trac: Cross-site request forgery (GLSA 200612-14)
Severity: low
Exploitable: remote
Date: December 12, 2006
Bug(s): #154574
ID: 200612-14

Synopsis

Trac allows remote attackers to execute unauthorized actions as other users.

Background

Trac is a wiki and issue tracking system for software development projects.

Affected Packages

Package: www-apps/trac
Vulnerable: < 0.10.1
Unaffected: >= 0.10.1
Architectures: All supported architectures


Description

Trac allows users to perform certain tasks via HTTP requests without performing correct validation on those requests.

Impact

An attacker could entice an authenticated user to browse to a specially crafted URL, allowing the attacker to execute actions in the Trac instance as if they were the user.

Workaround

There is no known workaround at this time.

Resolution

All Trac users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/trac-0.10.1"


References

CVE-2006-5848
CVE-2006-5878
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum