Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200612-07 ] Mozilla Firefox: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1582

PostPosted: Sun Dec 10, 2006 7:26 pm    Post subject: [ GLSA 200612-07 ] Mozilla Firefox: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Mozilla Firefox: Multiple vulnerabilities (GLSA 200612-07)
Severity: normal
Exploitable: remote
Date: December 10, 2006
Bug(s): #154434
ID: 200612-07

Synopsis

Multiple vulnerabilities have been reported in Mozilla Firefox.

Background

Mozilla Firefox is a popular open-source web browser from the Mozilla Project.

Affected Packages

Package: www-client/mozilla-firefox
Vulnerable: < 1.5.0.8
Unaffected: >= 1.5.0.8
Architectures: All supported architectures

Package: www-client/mozilla-firefox-bin
Vulnerable: < 1.5.0.8
Unaffected: >= 1.5.0.8
Architectures: All supported architectures


Description

Mozilla Firefox improperly handles Script objects while they are being executed. Mozilla Firefox has also been found to be vulnerable to various possible buffer overflows. Lastly, the binary release of Mozilla Firefox is vulnerable to a low exponent RSA signature forgery issue because it is bundled with a vulnerable version of NSS.

Impact

An attacker could entice a user to view specially crafted JavaScript and execute arbitrary code with the rights of the user running Mozilla Firefox. An attacker could also entice a user to view a specially crafted web page that causes a buffer overflow and again executes arbitrary code. It is also possible for an attacker to make up SSL/TLS certificates that would not be detected as invalid by the binary release of Mozilla Firefox, raising the possibility for Man-in-the-Middle attacks.

Workaround

There is no known workaround at this time.

Resolution

All Mozilla Firefox users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-1.5.0.8"
All Mozilla Firefox binary release users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-bin-1.5.0.8"


References

CVE-2006-5462
CVE-2006-5463
CVE-2006-5464
CVE-2006-5747
CVE-2006-5748
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum