Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200612-03 ] GnuPG: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1582

PostPosted: Sun Dec 10, 2006 2:26 pm    Post subject: [ GLSA 200612-03 ] GnuPG: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: GnuPG: Multiple vulnerabilities (GLSA 200612-03)
Severity: normal
Exploitable: remote
Date: December 10, 2006
Bug(s): #156476, #156947
ID: 200612-03

Synopsis

GnuPG is vulnerable to a buffer overflow and an erroneous function pointer dereference that can result in the execution of arbitrary code.

Background

The GNU Privacy Guard, GnuPG, is a free replacement for the PGP suite of cryptographic software.

Affected Packages

Package: app-crypt/gnupg
Vulnerable: < 1.4.6
Unaffected: >= 1.4.6
Architectures: All supported architectures


Description

Hugh Warrington has reported a boundary error in GnuPG, in the "ask_outfile_name()" function from openfile.c: the make_printable_string() function could return a string longer than expected. Additionally, Tavis Ormandy of the Gentoo Security Team reported a design error in which a function pointer can be incorrectly dereferenced.

Impact

A remote attacker could entice a user to interactively use GnuPG on a crafted file and trigger the boundary error, which will result in a buffer overflow. They could also entice a user to process a signed or encrypted file with gpg or gpgv, possibly called through another application like a mail client, to trigger the dereference error. Both of these vulnerabilities would result in the execution of arbitrary code with the permissions of the user running GnuPG. gpg-agent, gpgsm and other tools are not affected.

Workaround

There is no known workaround at this time.

Resolution

All GnuPG users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose "=app-crypt/gnupg-1.4*"


References

CVE-2006-6169
CVE-2006-6235


Last edited by GLSA on Mon Dec 11, 2006 4:18 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum