Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Want to get rid of eth1_rename [SOLVED] (udev103 and network
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
dhave
Apprentice
Apprentice


Joined: 28 Oct 2005
Posts: 298
Location: Still outside the Matrix ...

PostPosted: Mon Dec 04, 2006 1:38 pm    Post subject: Want to get rid of eth1_rename [SOLVED] (udev103 and network Reply with quote

I've suddenly lost my eth1 device, which is used for my wireless connection. It's been replaced by eth1_rename. I understand from other posts that udev is causing this, but I haven't yet gotten clear on just how to straighten things out.

I'd like to get eth1 back rather than change my wireless utilities to eth1_rename.

I haven't added new devices, so this must be due to a udev upgrade.

[edit - stuck by NeddySeagoon 091206 22:45 ]

_________________
This space available!


Last edited by dhave on Mon Dec 04, 2006 6:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
dhave
Apprentice
Apprentice


Joined: 28 Oct 2005
Posts: 298
Location: Still outside the Matrix ...

PostPosted: Mon Dec 04, 2006 1:55 pm    Post subject: Reply with quote

Mod: If you think this post fits better in Networking and Security, please move it. I wasn't sure where to post it, since it's really a udev question. Thanks.
_________________
This space available!
Back to top
View user's profile Send private message
richfish
Apprentice
Apprentice


Joined: 03 Mar 2006
Posts: 202
Location: Phoenix, AZ

PostPosted: Mon Dec 04, 2006 5:43 pm    Post subject: Reply with quote

If you have udev-103, the easiest thing to do is run "/lib/udev/write_net_rules all_interfaces". Then change the eth0/eth1 naming in /etc/udev/rules.d/70-persistent-net.rules as necessary.
Back to top
View user's profile Send private message
dhave
Apprentice
Apprentice


Joined: 28 Oct 2005
Posts: 298
Location: Still outside the Matrix ...

PostPosted: Mon Dec 04, 2006 6:04 pm    Post subject: Reply with quote

richfish wrote:
If you have udev-103, the easiest thing to do is run "/lib/udev/write_net_rules all_interfaces". Then change the eth0/eth1 naming in /etc/udev/rules.d/70-persistent-net.rules as necessary.

Thank you, richfish. That worked perfectly.
_________________
This space available!
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3200

PostPosted: Wed Dec 20, 2006 4:27 pm    Post subject: Reply with quote

Will this eventually be a part of the udev ebuild, or will this need to be run seperately from now on?
Back to top
View user's profile Send private message
irondog
l33t
l33t


Joined: 07 Jul 2003
Posts: 715
Location: Voor mijn TV. Achter mijn pc.

PostPosted: Sun Dec 24, 2006 11:59 am    Post subject: Reply with quote

This is just a work-around for a bug in UDEV.
I've written a patch to fix the issue:
http://bugs.gentoo.org/show_bug.cgi?id=158531

I have been ignored with this bug, but the proper way to fix the bug is to fix the C code, not to alter the configuration.
_________________
Alle dingen moeten onzin zijn.
Back to top
View user's profile Send private message
broken_chaos
Guru
Guru


Joined: 18 Jan 2006
Posts: 370
Location: Ontario, Canada

PostPosted: Sun Dec 24, 2006 5:21 pm    Post subject: Reply with quote

irondog wrote:
I have been ignored with this bug, but the proper way to fix the bug is to fix the C code, not to alter the configuration.

You might get more attention when you say you've actually tested it and it works, instead of implying that you haven't actually used your own fix yet, letalone that it works properly.
Back to top
View user's profile Send private message
ferg
Guru
Guru


Joined: 15 Nov 2002
Posts: 434
Location: Cambridge, UK

PostPosted: Sun Apr 29, 2007 7:29 pm    Post subject: Reply with quote

I got bitten with this whilst adding a new Gigabit NIC to my Mythtv Gentoo box. I wondered why my NIC was not getting recognised as eth0 even though the onboard NIC was disabled in BIOS.

Switching the two lines for each card worked in

Code:
/etc/udev/rules.d/70-persistent-net.rules


Ta!

Cheers
Ferg
_________________
Climb up it, kayak down it + make sure it runs on GNU/Linux
"cease to exist, giving my goodbye, drive my car into the ocean,
you think I'm dead, but i sail away, on a wave of mutilation!"
Back to top
View user's profile Send private message
irondog
l33t
l33t


Joined: 07 Jul 2003
Posts: 715
Location: Voor mijn TV. Achter mijn pc.

PostPosted: Sun Apr 29, 2007 8:21 pm    Post subject: Reply with quote

With a non-buggy udev you'll not need to do that. :)
_________________
Alle dingen moeten onzin zijn.
Back to top
View user's profile Send private message
ferg
Guru
Guru


Joined: 15 Nov 2002
Posts: 434
Location: Cambridge, UK

PostPosted: Tue Jun 26, 2007 12:36 pm    Post subject: Reply with quote

Arrrggggghhh!!!!!

Why cannot I learn from past mistakes. I just switched motherboards, and got bitten by this once again. Wondering why my new NIC was not being recognised as ETH0!!

Doh!!

Cheers
Ferg
_________________
Climb up it, kayak down it + make sure it runs on GNU/Linux
"cease to exist, giving my goodbye, drive my car into the ocean,
you think I'm dead, but i sail away, on a wave of mutilation!"
Back to top
View user's profile Send private message
Acidphase
n00b
n00b


Joined: 15 Jul 2011
Posts: 21

PostPosted: Thu Feb 02, 2012 4:09 pm    Post subject: Nice Reply with quote

I just went through this myself few weeks ago when I switched out my whole rig, luckily I was able to figure it out on my own. I was going
to just delete:
Code:
/etc/udev/rules.d/70-persistent-net.rules


As udev would just make a new one next time you reboot(or restart udev) instead I just opened the file up saw that it was only two lines first line being the interface from my old interface and second line being from the new one.
So at that point said simple enough just delete the first line and change the eth1 to eth0 done. :)
_________________
-Acidphase
Back to top
View user's profile Send private message
BrandonKByrne
n00b
n00b


Joined: 05 Oct 2012
Posts: 2

PostPosted: Fri Oct 05, 2012 11:24 am    Post subject: new user Reply with quote

I am a new user on the forum and look forward to using this forum in the future. I am very new to and am in need of some help.
What "user" and "host" show up in the for that statement? Does that help any? Can you change the password on that user? That would prevent them, and might get the guy in the next cubicle complaining. You could turn on the "general log"; it might give you some extra clues
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum