Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[open xchange] openldap problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
blh
n00b
n00b


Joined: 13 Nov 2006
Posts: 10

PostPosted: Mon Nov 13, 2006 1:41 pm    Post subject: [open xchange] openldap problem Reply with quote

Hi,

I've read previous articles about this and not been able to resolve the issue. As the previous questions was in the middle of a 60 page thread, I decided to make a new 8) .

I'm trying to create a user using adduser_ox and the following error message gets generated in the messages log.

Quote:
Nov 13 14:30:58 planner slapd[10954]: conn=56 op=0 BIND dn="cn=Manager,dc=corp,dc=se" method=128
Nov 13 14:30:58 planner slapd[10954]: conn=56 op=0 BIND dn="cn=Manager,dc=corp,dc=se" mech=SIMPLE ssf=0
Nov 13 14:30:58 planner slapd[10954]: conn=56 op=0 RESULT tag=97 err=0 text=
Nov 13 14:30:58 planner slapd[10954]: conn=56 op=1 ADD dn="uid=blh,ou=Users,ou=OxObjects,dc=corp,dc=se"
Nov 13 14:30:58 planner slapd[10954]: bdb_db_cache: db_open(objectClass) failed: Permission denied (13)
Nov 13 14:30:58 planner slapd[10954]: bdb_index_read: Could not open DB objectClass
Nov 13 14:30:58 planner slapd[10954]: conn=56 op=1 RESULT tag=105 err=80 text=index generation failed
Nov 13 14:30:58 planner slapd[10954]: conn=56 op=1 RESULT tag=105 err=80 text=index generation failed


I've set the ownership of the database files to ldap:ldap as it should be. I've also removed all permissions suggested for slapd.conf to not run into any problems there.

The BASE vareable in ldap.conf is also fixed and the space removed (as suggested in a different thread).

Anyone got any suggestions for where else my problem could be?

Thanks. blh.
Back to top
View user's profile Send private message
Janne Pikkarainen
Veteran
Veteran


Joined: 29 Jul 2003
Posts: 1143
Location: Helsinki, Finland

PostPosted: Mon Nov 13, 2006 2:08 pm    Post subject: Reply with quote

BDB likes to create it's own files in addition to those actual .bdb data files - are you sure that in addition to database files also the data directory has ldap:ldap owner & write permission?
_________________
Yes, I'm the man. Now it's your turn to decide if I meant "Yes, I'm the male." or "Yes, I am the Unix Manual Page.".
Back to top
View user's profile Send private message
blh
n00b
n00b


Joined: 13 Nov 2006
Posts: 10

PostPosted: Mon Nov 13, 2006 2:23 pm    Post subject: Reply with quote

My bad. I failed to check permissions for objectClass.bdb. It's now owned by ldap and works.
Back to top
View user's profile Send private message
newtonian
Guru
Guru


Joined: 19 Jan 2005
Posts: 456
Location: Hokkaido Japan

PostPosted: Fri Aug 10, 2012 8:18 am    Post subject: Reply with quote

I think slapadd when run as root creates objectClass.bdb with root owner, group privileges.
This fixed it for me:

Code:
chown ldap:ldap /var/lib/openldap-data/objectClass.bdb


Setting loglevel to 296 in /etc/openldap/slap.conf also helps.

Code:
loglevel 296


Cheers,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum