Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200610-15 ] Asterisk: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Mon Oct 30, 2006 7:26 pm    Post subject: [ GLSA 200610-15 ] Asterisk: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Asterisk: Multiple vulnerabilities (GLSA 200610-15)
Severity: high
Exploitable: remote
Date: October 30, 2006
Updated: January 30, 2007
Bug(s): #144941, #151881
ID: 200610-15

Synopsis

Asterisk is vulnerable to the remote execution of arbitrary code or a Denial of Service.

Background

Asterisk is an open source implementation of a telephone private branch exchange (PBX).

Affected Packages

Package: net-misc/asterisk
Vulnerable: < 1.2.13
Vulnerable: < 1.0.12
Unaffected: >= 1.2.13
Unaffected: >= 1.0.12 < 1.0.13
Architectures: All supported architectures


Description

Asterisk contains buffer overflows in channels/chan_mgcp.c from the MGCP driver and in channels/chan_skinny.c from the Skinny channel driver for Cisco SCCP phones. It also dangerously handles client-controlled variables to determine filenames in the Record() function. Finally, the SIP channel driver in channels/chan_sip.c could use more resources than necessary under unspecified circumstances.

Impact

A remote attacker could execute arbitrary code by sending a crafted audit endpoint (AUEP) response, by sending an overly large Skinny packet even before authentication, or by making use of format strings specifiers through the client-controlled variables. An attacker could also cause a Denial of Service by resource consumption through the SIP channel driver.

Workaround

There is no known workaround for the format strings vulnerability at this time. You can comment the lines in /etc/asterisk/mgcp.conf, /etc/asterisk/skinny.conf and /etc/asterisk/sip.conf to deactivate the three vulnerable channel drivers. Please note that the MGCP channel driver is disabled by default.

Resolution

All Asterisk users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.2.13"


References

CVE-2006-4345
CVE-2006-4346
CVE-2006-5444
CVE-2006-5445


Last edited by GLSA on Wed Jan 31, 2007 4:17 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum