Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[berkano-overlay] bleeding-edge multimedia, desktop & extras
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 35, 36, 37  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Tue Oct 17, 2006 2:58 pm    Post subject: [berkano-overlay] bleeding-edge multimedia, desktop & ex Reply with quote

Berkano overlay
This overlay has bleeding-edge multimedia and desktop ebuilds, handy system administration tools and a few other things. To get this overlay, you can use:

layman
If you haven't, emerge layman and configure it. Then do
Code:
layman -f && layman -a berkano
and you should be all set to use this overlay!

direct subversion access
If you don't want to use layman, you can get a direct checkout from our subversion repository with
Code:
svn checkout http://svn.liveforge.org/berkano/trunk berkano


You can also browse the repository through your web browser at http://websvn.liveforge.org/wsvn/berkano/trunk/. This now offers tarball downloads and RSS feeds.

Issues like bugs and requests can be reported on IRC in our #berkano channel on irc.freenode.org.

The overlay currently contains the following packages:
Code:
app-editors/yzis
            A vi-compatible editor that is composed of a generic vi engine and
            independent GUI
app-emulation/emul-linux-x86-gtk-engines-qtcurve
            Provides precompiled 32bit libraries for the QtCurve GTK2 widgets
app-misc/screen
            Screen is a full-screen window manager that multiplexes a physical
            terminal between several processes
app-portage/fquery
            A fast replacement for equery
games-emulation/sdlmess
            Multiple Emulator Super System for SDL
kde-base/kde-lite
            A lighter meta ebuild to pull in KDE packages from split ebuilds
kde-base/nsplugins32
            32-bit Netscape plugins support for 64-bit Konqueror
kde-misc/kio_p7zip
            A kioslave to handle 7zip archives
kde-misc/kvkbd
            A virtual keyboard for KDE
media-libs/libvorbis
            the Ogg Vorbis sound file format library
media-libs/x264
            A free library for encoding H264/AVC video streams
media-libs/mac
            Unix port of Monkey's Audio codec
media-sound/flake
            An alternative to the FLAC reference encoder, with the goal of
            increasing encoding speed and implementing experimental features.
            Standalone version of the ffmpeg flac encoder.
media-sound/mpc
            A commandline client for Music Player Daemon (media-sound/mpd)
media-sound/mpd
            The Music Player Daemon (mpd)
media-sound/ncmpc
            A ncurses client for the Music Player Daemon (MPD)
media-sound/lossless2lossy
            A conversion script for mass converting your music collection from
one format to another
media-sound/ncmpc-tradiaz
            A branch for fixes and enhancements to ncmpc, a client for the Music
            Player Daemon (MPD)
media-video/avidemux
            Great Video editing/encoding tool
media-video/ffmpeg
            Complete solution to record, convert and stream audio and video
            (source from SVN)
media-video/mplayer
            A very versatile media player
media-video/projectx
            Converts, splits and demuxes DVB and other MPEG recordings
media-video/smplayer
            Great front-end for mplayer written in Qt4
media-video/encode2mpeg
            A frontend to MPlayer/MEncoder and mjpegtools
net-misc/puf
            A command line web client, similar to GNU wget, but with the ability
            to do many downloads in parallel
net-misc/weatherget
            A command line weather reporting tool
sys-apps/hwinfo
            Hardware detection tool used in SuSE Linux
sys-kernel/hitchhiker-sources
            Full linux-2.6 kernel sources including the Gentoo, Reiser4 and
            UDF-2.50 patches
x11-libs/libqxt
            The Qt eXTension library provides cross-platform utility classes to
            add functionality ontop of the Qt toolkit
x11-misc/nao
            A powerful and flexible file manager, using the FOX toolkit



edit 20061119: updated package list
edit 20061227: updated package list
edit 20070222: updated instructions
edit 20070224: updated package list
edit 20070225: updated package list
edit 20070311: updated instructions + package list
edit 20070407: updated package list
edit 20070423: updated package list
edit 20070510: updated package list + URL of repository
edit 20070612: updated package list
edit 20070703: updated layman instructions
edit 20070913: updated irc channel location and package list
edit 20070923: updated package list
edit 20080307: updated package list and websvn
edit 20080516: updated package list

_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF


Last edited by yngwin on Thu May 15, 2008 11:37 pm; edited 19 times in total
Back to top
View user's profile Send private message
Lepaca Kliffoth
l33t
l33t


Joined: 28 Apr 2004
Posts: 737
Location: Florence, Italy

PostPosted: Tue Oct 17, 2006 7:35 pm    Post subject: Reply with quote

I'm trying it (azureus and mplayer), I'll let you know how it goes.
_________________
It isn't enough to win - everyone else must lose, and you also have to rub it in their face (maybe chop off an arm too for good measure).
Animebox!
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Wed Oct 18, 2006 12:41 pm    Post subject: Reply with quote

Code:

In file included from h261.c:32:
h261data.h:157: warning: missing initializer
h261data.h:157: warning: (near initialization for ‘h261_rl_tcoeff.index_run’)
h261.c:1045: warning: missing initializer
h261.c:1045: warning: (near initialization for ‘h261_decoder.next’)
h261.c:1054: warning: missing initializer
h261.c:1054: warning: (near initialization for ‘h261_parser.split’)
In file included from h264.c:36:
cabac.h:364: warning: ‘inline’ is not at beginning of declaration
h264.c: In function ‘hl_decode_mb’:
h264.c:3661: warning: suggest parentheses around arithmetic in operand of ^
h264.c:3667: warning: suggest parentheses around arithmetic in operand of ^
h264.c: In function ‘print_short_term’:
h264.c:4326: warning: comparison between signed and unsigned
h264.c: At top level:
h264.c:6010: warning: ‘inline’ is not at beginning of declaration
h264.c:6218: warning: ‘inline’ is not at beginning of declaration
h264.c: In function ‘filter_mb_fast’:
h264.c:7101: warning: dereferencing type-punned pointer will break strict-aliasing rules
h264.c: In function ‘decode_unregistered_user_data’:
h264.c:7593: warning: comparison between signed and unsigned
h264.c:7598: warning: pointer targets in passing argument 1 of ‘sscanf’ differ in signedness
h264.c: At top level:
h264.c:8652: warning: missing initializer
h264.c:8652: warning: (near initialization for ‘h264_parser.next’)
In file included from h264.c:8655:
svq3.c: In function ‘svq3_decode_block’:
svq3.c:224: warning: comparison between signed and unsigned
svq3.c: In function ‘svq3_mc_dir’:
svq3.c:374: warning: comparison between signed and unsigned
svq3.c:374: warning: comparison between signed and unsigned
svq3.c: In function ‘svq3_decode_mb’:
svq3.c:450: warning: comparison between signed and unsigned
svq3.c: In function ‘svq3_decode_slice_header’:
svq3.c:741: warning: comparison between signed and unsigned
svq3.c: At top level:
svq3.c:1014: warning: missing initializer
svq3.c:1014: warning: (near initialization for ‘svq3_decoder.next’)
cabac.h:107: warning: ‘put_cabac_static’ defined but not used
cabac.h:153: warning: ‘put_cabac_terminate’ defined but not used
cabac.h:181: warning: ‘put_cabac_u’ defined but not used
cabac.h:216: warning: ‘put_cabac_ueg’ defined but not used
cabac.h:268: warning: ‘refill2’ defined but not used
cabac.h:775: warning: ‘get_cabac_u’ defined but not used
cabac.h:791: warning: ‘get_cabac_ueg’ defined but not used
cabac.h: In function ‘get_cabac_noinline’:
cabac.h:455: error: can't find a register in class ‘GENERAL_REGS’ while reloading ‘asm’
make[1]: *** [h264.o] B³±d 1
make: *** [libavcodec/libavcodec.a] B³±d 2

!!! ERROR: media-video/mplayer-9999-r8 failed.
Call stack:
  ebuild.sh, line 1568:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  mplayer-9999-r8.ebuild, line 492:   Called die

!!! make failed!
!!! If you need support, post the topmost build error, and the call stack if relevant.

!!! This ebuild is from an overlay: '/usr/local/overlays/berkano-overlay'

I can't compile mplayer :/
Code:

[ebuild     U ] media-video/mplayer-9999-r8 [1.0_pre8-r1] USE="3dnow 3dnowext X aac aalib alsa bidi bl cdparanoia cpudetection custom-cflags debug dga dts dv dvb dvd dvdread encode esd fbcon gif gtk jack joystick jpeg libcaca live lzo mad mmx mmxext musepack nls%* nvidia%* opengl oss png real rtc sdl sse sse2 tga theora truetype v4l v4l2 vorbis win32codecs x264 xanim xv xvid xvmc -3dfx (-altivec) -arts -ass% -directfb -doc -dvdnav% -ggi -i8x0% -ipv6 -lirc -matrox -nas -samba -svga -xinerama -xmms (-amr%*) (-bindist%) (-enca%*) (-iconv%*) (-livecd%*) (-openal%*) (-speex%*) (-unicode%*)" LINGUAS="(-en%)" 0 kB [11]
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Wed Oct 18, 2006 1:50 pm    Post subject: Reply with quote

I just successfully compiled gpac-cvs, x264-svn and mplayer from my overlay. Can you give us the output of emerge --info please?
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Wed Oct 18, 2006 3:16 pm    Post subject: Reply with quote

Code:

Portage 2.1.2_pre3-r4 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo i686)
=================================================================
System uname: 2.6.18-gentoo i686 AMD Athlon(tm) 64 Processor 2800+
Gentoo Base System version 1.12.5
Last Sync: Wed, 18 Oct 2006 03:00:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="${NXDIR}/etc ${NXDIR}/home /etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=athlon64 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig digest distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="pl_PL.UTF-8"
LC_ALL="pl_PL.UTF-8"
LINGUAS="pl"
MAKEOPTS="-j2 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/xgl-coffee /usr/local/overlays/nelchael /usr/portage/local/layman/sunrise /usr/portage/local/layman/nx /usr/portage/local/layman/halcy0n /usr/portage/local/layman/gentopia /usr/portage/local/layman/zugaina /usr/local/custom_kernels /usr/local/nvidia-open /usr/local/overlays/berkano-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aac alsa avi berkdb bitmap-fonts cairo cdr cdrom cli cracklib crypt cups divx4linux dlloader dri dvd dvdr dvdread elibc_glibc encode esd flash fortran gif glitz gpm gtk hal imagemegick imlib input_devices_joystick input_devices_keyboard input_devices_mouse input_devices_vmmouse isdnlog jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kernel_linux libg++ linguas_pl mmx motif mp3 mpeg ncurses nls nptl nptlonly nvidia ogg oggvorbis opengl oss pam pcre perl pertty pic png ppds pppd python qt3 qt4 readline reflection risky sdl session slang spell spl sse sse2 ssl tcpd tga tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU v4l video_cards_nv video_cards_nvidia video_cards_vmware vorbis wmf xcomposite xml xml2 xorg xpm xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Here you go :) I like mplayer-svn and compile it manually but ebuild is great thing :)
There is 1.0 rc1 anyway :)

BTW - could you sync your xorg-server ebuild with the one from portage (i.e. aiglx use flag or sth more)
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Thu Oct 19, 2006 9:11 am    Post subject: Reply with quote

I don't see anything obviously wrong. I never set custom-cflags USE flag myself, so you might try disabling that, even though your cflags look fine. Rebuild x264-svn first, maybe if you pull the latest code fixes it may help.

kfiaciarka wrote:
BTW - could you sync your xorg-server ebuild with the one from portage (i.e. aiglx use flag or sth more)

I have deleted it from my overlay as it is no longer necessary, the portage version should be fine.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Thu Oct 19, 2006 9:38 am    Post subject: Reply with quote

yngwin wrote:
I don't see anything obviously wrong. I never set custom-cflags USE flag myself, so you might try disabling that, even though your cflags look fine. Rebuild x264-svn first, maybe if you pull the latest code fixes it may help.

kfiaciarka wrote:
BTW - could you sync your xorg-server ebuild with the one from portage (i.e. aiglx use flag or sth more)

I have deleted it from my overlay as it is no longer necessary, the portage version should be fine.

Thx :) I'll try to build without this flag. My x264-svn was dated 20069999-r6 as I recall ;)

Another thing:
mplayer-svn support flag --charset= (does your ebuild support unicode?)
I'm just asking ;) Don't get me wrong then ;) (I'm not complaining)

EDIT: same error :/ maybe show me your emerge -pv mplayer, please :)


Last edited by kfiaciarka on Thu Oct 19, 2006 12:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
Lepaca Kliffoth
l33t
l33t


Joined: 28 Apr 2004
Posts: 737
Location: Florence, Italy

PostPosted: Thu Oct 19, 2006 12:44 pm    Post subject: Reply with quote

On AMD64 nvidia compilation dies crapping something about x264 on the screen (from the inside)
_________________
It isn't enough to win - everyone else must lose, and you also have to rub it in their face (maybe chop off an arm too for good measure).
Animebox!
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Thu Oct 19, 2006 5:53 pm    Post subject: Reply with quote

It works for me in this ~amd64 configuration:
Code:
chinkara ~ # emerge -pv x264-svn mplayer

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/x264-svn-20069999-r6  USE="X gtk mp4 threads -debug (-multilib)" 0 kB [4]
[ebuild   R   ] media-video/mplayer-9999-r8  USE="X aac aalib alsa arts ass cdparanoia doc dts dv dvb dvd dvdread encode fbcon gif gtk jack jpeg libcaca lzo mad musepack nas nls nvidia opengl png rtc sdl theora truetype vorbis x264 xv xvid xvmc (-3dfx) (-3dnow) (-3dnowext) (-altivec) -bidi -bl -cpudetection -custom-cflags -debug -dga -directfb -dvdnav -esd -ggi -i8x0 -ipv6 -joystick -lirc -live -matrox (-mmx) (-mmxext) -oss (-real) -samba (-sse) (-sse2) (-svga) -tga -v4l -v4l2 (-win32codecs) -xanim -xinerama -xmms" 0 kB [4]

Total size of downloads: 0 kB
Portage overlays:
 [1] /usr/local/overlays/flameeyes-overlay
 [2] /usr/local/overlays/sunrise
 [3] /usr/local/overlays/kpex-media
 [4] /usr/local/overlays/berkano
 [5] /usr/local/overlays/custom-kernels
chinkara ~ # emerge --info
Portage 2.1.2_pre3-r5 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.4.90.20060716-r0, 2.6.17-beyond4 x86_64)
=================================================================
System uname: 2.6.17-beyond4 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Gentoo Base System version 1.12.5
Last Sync: Thu, 19 Oct 2006 07:50:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1, 2.17, 2.17.50.0.3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -msse3 -O3 -pipe -freorder-blocks-and-partition"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=athlon64 -msse3 -O3 -pipe -freorder-blocks-and-partition"
DISTDIR="/home/distfiles"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk/ http://distfiles.gentoo.org"
LC_ALL="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=both -Wl,--as-needed"
LINGUAS="en_GB"
MAKEOPTS="-j3"
PKGDIR="/home/distfiles/quickpkg"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/home/portage"
PORTDIR_OVERLAY="/usr/local/overlays/flameeyes-overlay /usr/local/overlays/sunrise /usr/local/overlays/kpex-media /usr/local/overlays/berkano /usr/local/overlays/custom-kernels"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 X a52 aac aalib acpi alsa aotuv apache2 arts artswrappersuid asf audiofile avi bash-completion berkdb bitmap-fonts browserplugin bzip2 cairo caps cdda cddb cdr cli cracklib crypt curl dbus divx dlloader dri dts dv dvb dvd dvdr elibc_glibc emboss encode examples exif expat fam fastcgi fbcon ffmpeg firefox flac fortran ftp fuse gcc64 gd gdbm gif glep glitz glut gmedia gnutls gphoto2 gpm gtk gtk2 hal iconv icq id3 image imagemagick imlib innodb input_devices_keyboard input_devices_mouse input_devices_vmmouse isdnlog jabber jack javascript jpeg kde kdeenablefinal kdehiddenvisibility kernel_linux ladspa lame lash lcms ldap libcaca libg++ libwww linguas_en_GB lm_sensors lua mad maildir matroska mhash mikmod mime mixer mng mono mozdevelop mozilla moznocompose moznoirc moznomail mozsvg mp3 mp4 mp4live mpeg mpeg2 mplayer musepack musicbrainz mysql nas ncurses nls no-old-linux nptl nptlonly nsplugin nvidia odbc offensive ogg oggvorbis openal opengl pam pcre pdflib perl pertty php pic pie png portaudio posix pppd python qt qt3 quicktime rdesktop readline reflection ruby sdl session simplexml sndfile soap speex spell spl sql sqlite ssl subtitles subversion svg tabs tcpd theora threads tidy tiff transcode truetype truetype-fonts type1-fonts udev unicode usb userland_GNU userlocales utf8 vcd vhosts video_cards_fbdev video_cards_nvidia video_cards_vesa video_cards_vmware vorbis webdav wifi wmf wmp x264 xcomposite xgetdefault xine xml xml2 xmlrpc xorg xpm xsl xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, PORTAGE_RSYNC_EXTRA_OPTS


Quote:
Another thing:
mplayer-svn support flag --charset= (does your ebuild support unicode?)

I have a unicode system, and it works fine for me (meaning I haven't come across any problems yet). But I'll look into it. The ebuild does have a nls useflag for internationalization.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Thu Oct 19, 2006 7:34 pm    Post subject: Reply with quote

Code:

>>> media-video/mplayer-9999-r8 merged.

 media-video/mplayer
    selected: 1.0_pre8-r1
   protected: 9999-r8
     omitted: none

Thanks to your use flags :)

There is sth to take closer look at:
Code:

mplayer
MPlayer dev-SVN-rUNKNOWN-4.1.1 (C) 2000-2006 MPlayer Team

If I run the one form ebuild
Code:

mplayer-svn
MPlayer dev-SVN-r20295-4.1.1 (C) 2000-2006 MPlayer Team

Directly form source. Is the because of portage? It is not first svn ebuild that don't show svn revision.
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Thu Oct 19, 2006 9:52 pm    Post subject: Reply with quote

kfiaciarka wrote:
Is the because of portage? It is not first svn ebuild that don't show svn revision.

I guess so. Glad it compiled now tho'.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Fri Oct 20, 2006 6:29 am    Post subject: Reply with quote

It's me again ;)
As you probably know there are some packages depaending on x264-svn, mine are:
Code:
media-gfx/blender-2.42a
media-libs/libquicktime-0.9.9
media-video/mplayer-9999-r8
media-video/ffmpeg-0.4.9_p20060530

But only player works with latest x264 version :/
Any solution?
maybe i should unmask your ffmpeg ?

EDIT : unmasked ffmpeg and libquicktime compiled fine ;)

Can I have a request?
1) http://www.transcoding.org/cgi-bin/transcode?Download (CVS version)
In portage there is release from nov 2005 but this code is still changing ;)
2) faad2 update ;) http://bugs.gentoo.org/show_bug.cgi?id=146485
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Fri Oct 20, 2006 11:50 am    Post subject: Reply with quote

kfiaciarka wrote:
It's me again ;)
As you probably know there are some packages depaending on x264-svn, mine are:
Code:
media-gfx/blender-2.42a
media-libs/libquicktime-0.9.9
media-video/mplayer-9999-r8
media-video/ffmpeg-0.4.9_p20060530

But only player works with latest x264 version :/
Any solution?
maybe i should unmask your ffmpeg ?

Either that or unmask the latest hardmasked ffmpeg snapshot in portage - it's hardmasked because of the incompatibilities with the older x264 version in portage (its newer version is also hardmasked).

kfiaciarka wrote:
EDIT : unmasked ffmpeg and libquicktime compiled fine ;)

Good. So the only thing that doesn't work now is blender? I'm not using blender, so I'm afraid I can't help you there. But if you find a solution (or I come across one) I'd be happy to include it in my overlay.

kfiaciarka wrote:
Can I have a request?
1) http://www.transcoding.org/cgi-bin/transcode?Download (CVS version)
In portage there is release from nov 2005 but this code is still changing ;)
2) faad2 update ;) http://bugs.gentoo.org/show_bug.cgi?id=146485

You can always request, but there's no guarantees. :wink:
I'm not using transcode (mplayer/mencoder does the work for me), but I may have a look. I'll definitely look at the faad2 update.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Fri Oct 20, 2006 12:11 pm    Post subject: Reply with quote

Blender works fine also, I had to recompile ffmpeg after faad2 update:)
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Fri Oct 20, 2006 12:58 pm    Post subject: Reply with quote

You will have to recompile ffmpeg again when I get the faac and faad2 updates in ;) as they are dependencies of ffmpeg. The faac update looks easy, but faad2 needs some work, as the patches need to be updated as well. But I'm looking at those.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Fri Oct 20, 2006 1:54 pm    Post subject: Reply with quote

:) nice :)

Strange:
Code:

mocp
Can't load plugin libffmpeg_decoder: libx264.so.47: cannot open shared object file: No such file or directory
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sun Oct 22, 2006 12:22 pm    Post subject: Reply with quote

kfiaciarka wrote:
Strange

Have you emerged x264 again since you did ffmpeg? It looks that way. Then just re-emerge ffmpeg, it should pick up the newer x264.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sun Oct 22, 2006 12:25 pm    Post subject: Reply with quote

I've been too lazy to work on the faad2 patches, but it's still on my todo list.

I have added kde-base/nsplugins32, which enables 32-bit plugins (such as Flash) for 64-bit Konqueror (on AMD64).
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Wed Oct 25, 2006 6:47 pm    Post subject: Reply with quote

I just added an improved mplayer subversion ebuild. A number of useflags have changed, so you are encouraged to review those. I would recommend to use the unicode and enca flags, to prevent font rendering problems. (I have not added an iconv useflag, as it does nothing separate from the unicode one.) Note that xvmc now replaces the nvidia and i8x0 specific useflags as well, just as in the 1.0-rc1.ebuild in portage. But I differ from the portage ebuild in using the mp3 useflag to support that codec for both encoding (with lame) en decoding (with libmad).

MPlayer subversion currently doesn't compile for me with aac, jack, openal and quicktime, but without those useflags it's fine. Note that the aac useflag is only for encoding AAC, mplayer will still decode AAC fine with the internal faad2 decoder.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
_pF_
Apprentice
Apprentice


Joined: 22 Apr 2004
Posts: 195
Location: Central London

PostPosted: Sat Oct 28, 2006 7:16 am    Post subject: Reply with quote

I am encountering this error with the latest overlay, rev 23.
Code:
>>> Emerging (1 of 4) media-video/ffmpeg-20101010 to /
 * checking ebuild checksums ;-) ...                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                       [ ok ]
>>> Unpacking source...
 * subversion update start -->
 *      repository: svn://svn.mplayerhq.hu/ffmpeg/trunk

Fetching external item into 'libswscale'
External at revision 20477.

At revision 6817.
 *    working copy: /usr/portage/distfiles/svn-src/ffmpeg/trunk

 * Applying ffmpeg-unknown-options.patch ...                                                 [ ok ]
 * Applying disable-version-rebranding.patch ...

 * Failed Patch: disable-version-rebranding.patch !
 *  ( /usr/portage/local/layman/berkano/media-video/ffmpeg/files/disable-version-rebranding.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/media-video/ffmpeg-20101010/temp/disable-version-rebranding.patch-1892
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sat Oct 28, 2006 11:46 am    Post subject: Reply with quote

You're right. I actually fixed this for myself, but forgot to upload the new patch. :oops: It's in there now. I also upped the minimum required version for x264-svn.

And a version bump for QtCurve is next.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Specter64
n00b
n00b


Joined: 12 Feb 2006
Posts: 24

PostPosted: Sun Oct 29, 2006 1:59 am    Post subject: Reply with quote

I get this error when I try to emerge avidemux I get this error
Code:
* checking miscfile checksums ;-) ...                                    [ ok ]
/usr/portage/eclass/eutils.eclass: line 1609: //var/db/pkg/dev-lang/spidermonkey-1.5-r1/IUSE: No such file or directory

!!! ERROR: media-video/avidemux-23000 failed.
Call stack:
  ebuild.sh, line 1584:   Called dyn_setup
  ebuild.sh, line 665:   Called pkg_setup
  avidemux-23000.ebuild, line 58:   Called built_with_use 'dev-lang/spidermonkey' 'threadsafe'
  eutils.eclass, line 1619:   Called die

!!! dev-lang/spidermonkey-1.5-r1 does not actually support the threadsafe USE flag!


Edit: Ignore this I thought spidermonkey was in your overlay but its in portage and all I needed to was update to 1.5-r2
_________________
Specter
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sun Oct 29, 2006 2:18 am    Post subject: Reply with quote

I deleted the spidermonkey ebuild from the overlay as portage's spidermonkey-1.5-r2 has the threadsafe use flag. I will up the requirement in the avidemux ebuild.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Specter64
n00b
n00b


Joined: 12 Feb 2006
Posts: 24

PostPosted: Sun Oct 29, 2006 2:25 am    Post subject: Reply with quote

Ok now I have legit error. I get this when compiling avidemux
Code:
cpu done
Generating prefs if needed...(srcdir: <.> pwd:</var/tmp/portage/media-video/avidemux-23000/work/avidemux-23000>)
configure: error: conditional "HAVE_FREETYPE" was never defined.
Usually this means the macro was only invoked conditionally.


there is a log file that the ebuild wants attached but its very long (~2000 lines) and I have no way to host it.

Edit: Ok that wasnt a major problem either..
I just needed to add truetype to my use flags
_________________
Specter
Back to top
View user's profile Send private message
_pF_
Apprentice
Apprentice


Joined: 22 Apr 2004
Posts: 195
Location: Central London

PostPosted: Sun Oct 29, 2006 4:53 am    Post subject: Reply with quote

The initial error with ffmpeg has gone, but it won't compile (or assemble). The program seems to be very sensitive to optimization flags.

An example error is:
Code:

i686-pc-linux-gnu-gcc -O2 -march=pentium2 -pipe -fomit-frame-pointer -fomit-frame-pointer -fomit-frame-pointer -Wdeclaration-after-statement -Wall -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Winline -I/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared -I/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared -I/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared/libavutil -I/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared/libavcodec -I/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared/libavformat -I/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared/libswscale -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared/libswscale   -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared -I/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared -I/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared/libavutil -O2 -march=pentium2 -pipe -fomit-frame-pointer -fomit-frame-pointer -fomit-frame-pointer -Wdeclaration-after-statement -Wall -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Winline -fPIC -DPIC -c -o parser.o parser.c
distcc[27560] ERROR: compile /var/tmp/ccache/cabac.tmp.valli.27552.i on localhost failed
In file included from cabac.c:33:
cabac.h: In function 'decode_significance_x86':
cabac.h:698: error: expected ':' or ')' before 'BRANCHLESS_GET_CABAC'
cabac.h:690: warning: unused variable 'minusindex'
cabac.h:689: warning: unused variable 'minusstart'
cabac.h:688: warning: unused variable 'end'
cabac.h: In function 'decode_significance_8x8_x86':
cabac.h:752: error: expected ':' or ')' before 'BRANCHLESS_GET_CABAC'
cabac.h:740: warning: unused variable 'last'
cabac.h:738: warning: unused variable 'minusindex'
make[1]: *** [cabac.o] Error 1
make[1]: *** Waiting for unfinished jobs....
parser.c: In function 'mpegaudio_parse':
parser.c:770: warning: assignment discards qualifiers from pointer target type
motion_est.c: In function 'h263_mv4_search':
motion_est.c:732: warning: 'P[2][0]' may be used uninitialized in this function
motion_est.c:732: warning: 'P[2][1]' may be used uninitialized in this function
motion_est.c:732: warning: 'P[3][0]' may be used uninitialized in this function
motion_est.c:732: warning: 'P[3][1]' may be used uninitialized in this function
motion_est.c:732: warning: 'P[4][0]' may be used uninitialized in this function
motion_est.c:732: warning: 'P[4][1]' may be used uninitialized in this function
motion_est.c: In function 'interlaced_search':
motion_est.c:882: warning: 'P[2][0]' may be used uninitialized in this function
motion_est.c:882: warning: 'P[2][1]' may be used uninitialized in this function
motion_est.c:882: warning: 'P[3][0]' may be used uninitialized in this function
motion_est.c:882: warning: 'P[3][1]' may be used uninitialized in this function
motion_est.c:882: warning: 'P[4][0]' may be used uninitialized in this function
motion_est.c:882: warning: 'P[4][1]' may be used uninitialized in this function
motion_est.c: In function 'ff_estimate_motion_b':
motion_est_template.c:971: warning: inlining failed in call to 'ff_epzs_motion_search': --param max-inline-insns-single limit reached
motion_est.c:1540: warning: called from here
motion_est_template.c:238: warning: inlining failed in call to 'ff_get_mb_score': --param max-inline-insns-single limit reached
motion_est.c:1548: warning: called from here
motion_est.c: In function 'ff_pre_estimate_p_frame_motion':
motion_est_template.c:971: warning: inlining failed in call to 'ff_epzs_motion_search': --param max-inline-insns-single limit reached
motion_est.c:1457: warning: called from here

<<similar warnings excised...>>

motion_est.c:1564: warning: inlining failed in call to 'check_bidir_mv': --param large-function-growth limit reached
motion_est.c:1705: warning: called from here
make[1]: Leaving directory `/var/tmp/portage/media-video/ffmpeg-20101010-r1/work/ffmpeg-20101010-shared/libavcodec'
make: *** [lib] Error 2

!!! ERROR: media-video/ffmpeg-20101010-r1 failed.
Call stack:
  ebuild.sh, line 1568:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  ffmpeg-20101010-r1.ebuild, line 195:   Called die

!!! shared failed
!!! If you need support, post the topmost build error, and the call stack if relevant.

!!! This ebuild is from an overlay: '/usr/portage/local/layman/berkano'
valli ~ #                                             
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3 ... 35, 36, 37  Next
Page 1 of 37

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum