Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[pdf] evince et update-mime-database (non résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
_tebra_
Guru
Guru


Joined: 12 Nov 2004
Posts: 304
Location: Brussels - Belgium

PostPosted: Sun Mar 15, 2009 4:17 pm    Post subject: [pdf] evince et update-mime-database (non résolu) Reply with quote

Bonjour,
je suis passé à la dernière version stable de evince (la 2.24.2) et depuis il me dit "Le type de fichier document PDF (application/pdf) n'est pas pris en charge". En cherchant dans les bug j'ai compris que devais suivre les instruction suivante:
Quote:
* Messages for package x11-misc/shared-mime-info-0.51:

*
* The database format has changed between 0.30 and 0.40.
* You may need to update all your local databases and caches.
* To do so, please run the following commands:
* (for each user) $ update-mime-database ~/.local/share/mime/
* (as root) # update-mime-database /usr/local/share/mime/

Mon problème est que je ne sais exécuté ces 2 commandes vu que les répertoires en question n'existent pas sur mon système.
J'utilise gnome comme desktop.

Quelqu'un sais m'aider?


Last edited by _tebra_ on Mon Mar 16, 2009 6:24 am; edited 1 time in total
Back to top
View user's profile Send private message
NEOxAKIRA
Guru
Guru


Joined: 20 May 2007
Posts: 302
Location: France

PostPosted: Sun Mar 15, 2009 5:18 pm    Post subject: Reply with quote

pour root ça serait pas plutôt :
Code:
# update-mime-database /usr/share/mime

?
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3756
Location: Lyon, France

PostPosted: Sun Mar 15, 2009 8:31 pm    Post subject: Reply with quote

Salut, peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)

Et +1 pour la réponse de NEOxAKIRA. C'est peut- être une erreur dans l'ebuild, il faudra reporter ça sur le bugzilla dans ce cas. :)
_________________
Google+ | Twitter
Back to top
View user's profile Send private message
_tebra_
Guru
Guru


Joined: 12 Nov 2004
Posts: 304
Location: Brussels - Belgium

PostPosted: Mon Mar 16, 2009 6:29 am    Post subject: Reply with quote

NEOxAKIRA wrote:
pour root ça serait pas plutôt :
Code:
# update-mime-database /usr/share/mime

?

Le commande s'exécute sans erreur mais cela ne change rien au problème.
2 précisions:
- je suis en arch AMD64
- quand j'essaie d'ouvrir un pdf depuis evince il ne me propose pas les fichiers .pdf dans la liste. Il propose uniquement les .ps
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4910

PostPosted: Mon Mar 16, 2009 6:38 am    Post subject: Reply with quote

un petit revdep-rebuilt? la lib poppler est peut-être cassée derrière.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
NEOxAKIRA
Guru
Guru


Joined: 20 May 2007
Posts: 302
Location: France

PostPosted: Mon Mar 16, 2009 9:33 am    Post subject: Reply with quote

à moi non plus evince ne propose pas les fichiers pdf dans sa liste de fichier a ouvrir, d'ailleurs la seule option qui affiche des fichiers c'est : "tout les fichiers"

et j'ai ce soucis là : (tu dois surement l'avoir)
Unknown media type in type 'all/all'--message repeats http://forums.gentoo.org/viewtopic.php?p=5538515
Code:
# update-mime-database /usr/share/mime
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'
Back to top
View user's profile Send private message
_tebra_
Guru
Guru


Joined: 12 Nov 2004
Posts: 304
Location: Brussels - Belgium

PostPosted: Mon Mar 16, 2009 5:38 pm    Post subject: Reply with quote

kwenspc wrote:
un petit revdep-rebuilt? la lib poppler est peut-être cassée derrière.

la commande revdep-rebuilt m'a re-emerger inkscape et gimp.
Ce n'a bien sûr rien arrangé au problème...
Back to top
View user's profile Send private message
_tebra_
Guru
Guru


Joined: 12 Nov 2004
Posts: 304
Location: Brussels - Belgium

PostPosted: Mon Mar 16, 2009 5:40 pm    Post subject: Reply with quote

NEOxAKIRA wrote:
à moi non plus evince ne propose pas les fichiers pdf dans sa liste de fichier a ouvrir, d'ailleurs la seule option qui affiche des fichiers c'est : "tout les fichiers"

et j'ai ce soucis là : (tu dois surement l'avoir)
Unknown media type in type 'all/all'--message repeats http://forums.gentoo.org/viewtopic.php?p=5538515
Code:
# update-mime-database /usr/share/mime
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

Non visiblement ce n'est pas le même problème que moi car la commande update-mime-database /usr/share/mime c'est exécuté sans le moindre message d'erreur sur mon système
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Mar 18, 2009 7:59 am    Post subject: Reply with quote

SAlut dans la partie anglophone du forum, il préconise de créer le(s) répertoire(s) /home/username/.local/share/mime/ si il n'existe pas dans le répertoire home. C'est ici : Super strange file association (gnome).

Normalement la commande en root, que tu as testée au début de ce thread aurais dû régler ton problème. Quelle est ta version de shared-mime-info ? --recompile-le--

EDIT : il manque encore un répertoire dans mime c'est /application/ (au singulier)

EDIT 2 : @NEOxAKIRA, tes unknowns ne sont pas inquiétants, juste une commande un peu trop bavarde.

EDIT 3 :
puisque tu es sous gnome il peut également y avoir un problème avec gnome nautilus et les mimes types : nautilus mime types problem. Donc:
kimmie wrote:
Weird. I don't know what would have caused it, or if this will fix it, but I'd be trying this myself:
  1. emerge -1 mime-types shared-mime-info gnome-mime-data
  2. revdep-rebuild
  3. Remove ~/.local/share/applications/mimeinfo.cache. That's where nautilus keeps it's mime-type to program mappings... it will be rebuilt if you remove it.

normalement il n'y a pas de s....
et puis voilà! ça fonctionnera.

EDIT 4 : et enlève le non résolu, stp, un problème est résolu ou ne l'est pas, dans ce dernier cas inutile de le dire. :wink:
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum