Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dropbox install problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Ryuzaki
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2010
Posts: 96
Location: N/A

PostPosted: Wed Sep 01, 2010 7:07 pm    Post subject: Dropbox install problems Reply with quote

I just got installed the .tar.bz2 file of Dropbox (from here: https://www.dropbox.com/downloading?os=lnx ). Then I read the README file after doing tar xvjf nautilus-dropbox-0.6.3.tar.bz2
.
The README instructions said
Quote:

You will need the following packages (or equivalent):

libnautilus-extension-dev

In the nautilus-dropbox dir just do:
$ ./configure
$ make
$ sudo make install

After installing the package you must restart Nautilus. You can do that by issuing the following command (note: if you're running compiz, doing so may lock up your computer - log out and log back in instead):

$killall nautilus

I did all of that, I restarted nautilus. I even logged out and back into my computer, and, nothing.
When I did makeI got make: *** No targets specified and no makefile found. Stop.
Same with sudo make install --> make: *** No rule to make target `install'. Stop.
What do I do to get Dropbox running/ working in general?
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Wed Sep 01, 2010 8:16 pm    Post subject: Reply with quote

Why install by hand?
If i'm not mistaken i thought it was in the sunrise-overlay. You can check out this bug report also http://bugs.gentoo.org/237433

By the way, you might have to wait a little while to check out sunrise overlay as right now i believe overlays.gentoo.org is still down.
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Wed Sep 01, 2010 8:18 pm    Post subject: Reply with quote

How thoughtless of me. In case your unfamilar with overlays, you can take a look here http://www.gentoo.org/proj/en/overlays/userguide.xml
Back to top
View user's profile Send private message
Ryuzaki
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2010
Posts: 96
Location: N/A

PostPosted: Thu Oct 14, 2010 9:13 pm    Post subject: Reply with quote

I'd just rather do this in the command line.
How do I get past the problem of #make install?
I've looked on other pages, and appearantly that command is supposed to work, but in this case all I'm getting is
Quote:
make: *** No rule to make target `install'. Stop.
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Fri Oct 15, 2010 2:06 pm    Post subject: Reply with quote

Your problem started before make install:
Quote:
When I did makeI got make: *** No targets specified and no makefile found. Stop.

If make can't find a makefile, that'll stop it in it's tracks.
Are you in the right directory when your trying this? Did "./configure" complete sucessfully?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3211

PostPosted: Fri Oct 15, 2010 4:05 pm    Post subject: Re: Dropbox install problems Reply with quote

Ryuzaki wrote:
What do I do to get Dropbox running/ working in general?
If you don't care about integration with nautilus, then you can use this text based install. Essentially there is nothing to "install". You just copy it to a directory and run dropboxd.
http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
Ryuzaki
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2010
Posts: 96
Location: N/A

PostPosted: Fri Oct 15, 2010 9:55 pm    Post subject: Reply with quote

rh1 wrote:
Your problem started before make install:
Quote:
When I did makeI got make: *** No targets specified and no makefile found. Stop.

If make can't find a makefile, that'll stop it in it's tracks.
Are you in the right directory when your trying this? Did "./configure" complete sucessfully?

Yes I'm in the right directory. Umm, the ./configure did end with this:
Quote:
checking for docutils... no
configure: error: couldn't find docutils

Big problem? and how do I fix that, if I can that is?
Back to top
View user's profile Send private message
Raptor85
Apprentice
Apprentice


Joined: 29 Dec 2007
Posts: 208

PostPosted: Fri Oct 15, 2010 11:31 pm    Post subject: Reply with quote

That means your configure didn't complete sucessfully and you dont have a valid makefile, you're missing a required dependency (in this case, docutils)

It's available via dev-python/docutils in portage.

Also, this is in the sunrise overlay, I highly recommend you install from there, or if you want to do it "manually" write (or copy) your own ebuild locally.
Back to top
View user's profile Send private message
Ryuzaki
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2010
Posts: 96
Location: N/A

PostPosted: Sat Oct 16, 2010 5:09 am    Post subject: Reply with quote

Raptor85 wrote:
That means your configure didn't complete sucessfully and you dont have a valid makefile, you're missing a required dependency (in this case, docutils)

It's available via dev-python/docutils in portage.

Also, this is in the sunrise overlay, I highly recommend you install from there, or if you want to do it "manually" write (or copy) your own ebuild locally.


Thank you so much. That did just the trick. I followed through with the rest of the README and everything finished without a problem. Thanks for all the wonderful help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum