Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge openldap-2.3.27 fails
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
paul555
l33t
l33t


Joined: 22 Nov 2004
Posts: 612
Location: Greece

PostPosted: Wed Sep 27, 2006 8:59 am    Post subject: emerge openldap-2.3.27 fails Reply with quote

Hi all today i wanted to upgrade to openldap-2.3.27 in x86 and during the emerge it gave me that error :
Code:
 * Building contributed dsaschema
dsaschema.c: In function ¡dsaschema_read_config¢:
dsaschema.c:247: warning: ¡savelineno¢ is used uninitialized in this function
dsaschema.c: In function ¡init_module¢:
dsaschema.c:265: warning: ¡rc¢ may be used uninitialized in this function
 * Building contributed pw-kerberos
 * Building contributed pw-netscape
 * Building contributed smbk5pwd
../../../libtool --mode=compile gcc -march=athlon-xp -O2 -pipe -DDO_SAMBA -DDO_KRB5 -I../../../include -I../../../servers/slapd   -c smbk5pwd.c
mkdir .libs
 gcc -march=athlon-xp -O2 -pipe -DDO_SAMBA -DDO_KRB5 -I../../../include -I../../../servers/slapd -c smbk5pwd.c  -fPIC -DPIC -o .libs/smbk5pwd.o
smbk5pwd.c:45:25: error: kadm5/admin.h: No such file or directory
smbk5pwd.c:46:17: error: hdb.h: No such file or directory
smbk5pwd.c:56: error: expected ¡=¢, ¡,¢, ¡;¢, ¡asm¢ or ¡__attribute__¢ before ¡conf¢
smbk5pwd.c:57: error: expected ¡=¢, ¡,¢, ¡;¢, ¡asm¢ or ¡__attribute__¢ before ¡*¢ token
smbk5pwd.c: In function ¡k5key_chk¢:
smbk5pwd.c:275: error: ¡krb5_salt¢ undeclared (first use in this function)
smbk5pwd.c:275: error: (Each undeclared identifier is reported only once
smbk5pwd.c:275: error: for each function it appears in.)
smbk5pwd.c:275: error: expected ¡;¢ before ¡salt¢
smbk5pwd.c:276: error: ¡hdb_entry¢ undeclared (first use in this function)
smbk5pwd.c:276: error: expected ¡;¢ before ¡ent¢
smbk5pwd.c:291: error: ¡Key¢ undeclared (first use in this function)
smbk5pwd.c:291: error: expected ¡;¢ before ¡ekey¢
smbk5pwd.c:296: error: ¡ent¢ undeclared (first use in this function)
smbk5pwd.c:299: error: ¡salt¢ undeclared (first use in this function)
smbk5pwd.c:306: error: ¡ekey¢ undeclared (first use in this function)
smbk5pwd.c:309: error: ¡db¢ undeclared (first use in this function)
smbk5pwd.c:317: error: ¡krb5_keyblock¢ has no member named ¡keyvalue¢
smbk5pwd.c:318: error: ¡krb5_keyblock¢ has no member named ¡keyvalue¢
smbk5pwd.c: In function ¡smbk5pwd_exop_passwd¢:
smbk5pwd.c:363: error: ¡hdb_entry¢ undeclared (first use in this function)
smbk5pwd.c:363: error: expected ¡;¢ before ¡ent¢
smbk5pwd.c:375: error: ¡ent¢ undeclared (first use in this function)
smbk5pwd.c:396: error: ¡db¢ undeclared (first use in this function)
smbk5pwd.c:405: error: ¡Key¢ undeclared (first use in this function)
smbk5pwd.c: In function ¡smbk5pwd_modules_init¢:
smbk5pwd.c:789: error: expected ¡=¢, ¡,¢, ¡;¢, ¡asm¢ or ¡__attribute__¢ before ¡*¢ token
smbk5pwd.c:789: error: invalid type argument of ¡unary *¢
smbk5pwd.c:829: error: ¡KADM5_ADMIN_SERVICE¢ undeclared (first use in this function)
smbk5pwd.c:832: error: ¡conf¢ undeclared (first use in this function)
smbk5pwd.c:835: error: ¡db¢ undeclared (first use in this function)
make: *** [smbk5pwd.lo] Error 1


Any suggestions?
_________________
"LINUX, MS-DOS, Windows : known as the Good, the Bad and the Ugly." :)
http://www.gnome.gr


Last edited by paul555 on Thu Sep 28, 2006 8:56 am; edited 2 times in total
Back to top
View user's profile Send private message
Martin LORANG
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2003
Posts: 92
Location: Moselle / France

PostPosted: Wed Sep 27, 2006 11:20 am    Post subject: Reply with quote

Same error here
my emerge --info
Code:
Portage 2.1.1 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r8 i686)
=================================================================
System uname: 2.6.17-gentoo-r8 i686 Intel(R) Xeon(TM) CPU 2.80GHz
Gentoo Base System version 1.12.5
Last Sync: Wed, 27 Sep 2006 09:50:01 +0000
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -mtune=pentium4 -pipe -fomit-frame-pointer -mfpmath=sse"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/fax /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -mtune=pentium4 -pipe -fomit-frame-pointer -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo ftp://sunsite.cnlab-switch.ch/mirror/gentoo   ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror http://www.ibiblio.org/gentoo   ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LC_ALL="fr_FR.UTF-8"
LINGUAS="fr fr_FR de de_DE"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 7zip apache2 berkdb bitmap-fonts bzip2 calendar cgi cli crypt cups dlloader dri elibc_glibc expat fbcon fortran ftp gdbm gpm imagemagick imap innodb input_devices_keyboard input_devices_mouse ipv6 isdnlog jbig jpeg jpeg2k kerberos kernel_linux latin1 ldap libg++ linguas_de linguas_de_DE linguas_fr linguas_fr_FR mailwrapper math mmx modperl mpeg mysql mysqli ncurses nls nptl nptlonly odbc pam pcre perl png ppds pppd python readline reflection samba session slp snmp spl sqlite sse sse2 ssl symlink tcpd tiff truetype truetype-fonts type1-fonts udev unicode userland_GNU userlocales vhosts video_cards_apm video_cards_ark video_cards_ati video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_imstt video_cards_mga video_cards_neomagic video_cards_nsc video_cards_nv video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo wmf xml xml2 xorg zip zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
Martin LORANG
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2003
Posts: 92
Location: Moselle / France

PostPosted: Wed Sep 27, 2006 12:56 pm    Post subject: Reply with quote

Solution is here http://bugs.gentoo.org/show_bug.cgi?id=135238
Code:
emerge -Ca mit-krb5
USE="-ldap" emerge -av heimdal
emerge -av openldap
emerge -av heimdal
worked for me
Back to top
View user's profile Send private message
paul555
l33t
l33t


Joined: 22 Nov 2004
Posts: 612
Location: Greece

PostPosted: Wed Sep 27, 2006 4:21 pm    Post subject: Reply with quote

Confirm that the above solution is working.
(Martin LORANG you emerge heimdal with krb4 useflag?)
_________________
"LINUX, MS-DOS, Windows : known as the Good, the Bad and the Ugly." :)
http://www.gnome.gr
Back to top
View user's profile Send private message
Raffi
l33t
l33t


Joined: 17 Mar 2003
Posts: 711
Location: Moscow, Id.

PostPosted: Wed Sep 27, 2006 4:36 pm    Post subject: Reply with quote

So does anyone know if there is a reason to (or not to) use heimdal over mit-krb5? I have mit-krb5 setup and working, and I would hate to have to start all over.
Back to top
View user's profile Send private message
Seppel
Tux's lil' helper
Tux's lil' helper


Joined: 10 Nov 2002
Posts: 113

PostPosted: Wed Sep 27, 2006 10:14 pm    Post subject: Reply with quote

What kind of solution is this? I have to remove krb? Why? Is heimdal a replacement of krb?

Why isn't this "resolved" by portage (the openldap should block krb or vice versa)?
Back to top
View user's profile Send private message
Martin LORANG
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2003
Posts: 92
Location: Moselle / France

PostPosted: Thu Sep 28, 2006 7:41 am    Post subject: Reply with quote

I emerged it without useflag krb4

I also forgot to mention :
Code:
revdep-rebuild -X -vv
is necessary for openssh, php, samba, and all the packages using krb5.
Back to top
View user's profile Send private message
Doron
n00b
n00b


Joined: 28 Sep 2006
Posts: 37

PostPosted: Thu Sep 28, 2006 8:20 am    Post subject: Unacceptable Solution Reply with quote

Martin LORANG wrote:
Solution is here http://bugs.gentoo.org/show_bug.cgi?id=135238
Code:
emerge -Ca mit-krb5
USE="-ldap" emerge -av heimdal
emerge -av openldap
emerge -av heimdal
worked for me


Martin,
First of all thanks for the technical solution. However, I do not think
it's acceptable, since many people may use krb5 for several packages.
How do we know krb5 can saefly be replaced be heimdal ?
In my case I checked the dependencies, and this is what I get-
Code:

x1laptopdoron ~ # equery depends mit-krb5
[ Searching for packages depending on mit-krb5... ]
net-misc/curl-7.15.1-r1
x1laptopdoron ~ # equery depends net-misc/curl
[ Searching for packages depending on net-misc/curl... ]
sys-auth/pam_pkcs11-0.5.3-r2
net-firewall/firehol-1.226-r1
app-crypt/gnupg-1.4.5
net-dialup/ppp-2.4.3-r16
app-office/openoffice-2.0.3
net-print/foomatic-db-engine-3.0.2
app-antivirus/clamav-0.88.4

Now can you tell me to remove krb5 ? :(

10X again,
Doron.
Back to top
View user's profile Send private message
Ooblick
n00b
n00b


Joined: 07 Feb 2004
Posts: 34

PostPosted: Thu Sep 28, 2006 8:46 am    Post subject: Reply with quote

An alternative, but probably just as awkward solution is to use -samba

USE="-samba" emerge openldap

Has just worked nicely for me, avoiding the nastiness of removing mit-krb5. But then I don't use samba.
Back to top
View user's profile Send private message
dannypoo
n00b
n00b


Joined: 24 Nov 2002
Posts: 25
Location: london

PostPosted: Thu Sep 28, 2006 8:48 am    Post subject: breaks loads of stuff Reply with quote

Yesterday I removed mit-krb5 and emerged heimdal - only to find I had to rebuild evolution-exchange and evolution-data-server. guess what. they didn't compile against heimdal. so this morning i'm recompiling everything else (except for openldap of course) against mit-krb5.

now waiting to see if anything which depends on openldap will work (i'm guessing not...). i hope i will be able to downgrade back to an older version of openldap (which compiled against mit-krb5 with no problems).

i noticed in the bug above there was a method to insert various libs from heimdal just to facilitate the build of openldap. not ideal though but i might be forced to try it...

cheers

danny
Back to top
View user's profile Send private message
Martin LORANG
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2003
Posts: 92
Location: Moselle / France

PostPosted: Thu Sep 28, 2006 8:57 am    Post subject: Reply with quote

I know : some packages work only with mit-krb5 and others only with heimbal.
so until the developpers find an acceptable solution, you have to choose one :( and/or emerge the packages without the kerberos useflag or do not upgrade openldap.
Back to top
View user's profile Send private message
Doron
n00b
n00b


Joined: 28 Sep 2006
Posts: 37

PostPosted: Thu Sep 28, 2006 9:20 am    Post subject: Change the title Reply with quote

Due the problems I suggest to remove the Solved from the solution,
or add some sort of warning.

I hate to see someone using Martin's solution and needs to spend a few
hours to fix the damages.

Who can change the title ?
Doron.
Back to top
View user's profile Send private message
paul555
l33t
l33t


Joined: 22 Nov 2004
Posts: 612
Location: Greece

PostPosted: Thu Sep 28, 2006 9:36 am    Post subject: Reply with quote

dannypoo what version of evolution-data-server did you emerged against heimdal and with what useflags?For me heimdal-0.7.2-r3 and evolution-data-server-1.8.0 compiles ok.The SOLVED is removed
_________________
"LINUX, MS-DOS, Windows : known as the Good, the Bad and the Ugly." :)
http://www.gnome.gr
Back to top
View user's profile Send private message
dannypoo
n00b
n00b


Joined: 24 Nov 2002
Posts: 25
Location: london

PostPosted: Thu Sep 28, 2006 9:58 am    Post subject: Reply with quote

i'm still on evolution-data-server 1.6.2...

here's my emerge --info:

Code:
Portage 2.1.1 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.16-gentoo-r13 i686)
=================================================================
System uname: 2.6.16-gentoo-r13 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.12.5
Last Sync: Thu, 28 Sep 2006 09:30:01 +0000
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.2.11-r1
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=prescott -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk ftp://mirrors.blueyonder.co.uk/mirrors/gentoo http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/ "
LANG="en_GB.utf8"
LC_ALL="en_GB.utf8"
LINGUAS=""
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local /usr/portage/local/layman/portage-xgl"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac alsa amr apache2 apm arts audiofile berkdb bitmap-fonts bootsplash bzip2 cdr cli crypt ctype cups curl dba dbus dga dlloader dri dvd dvdread eds elibc_glibc emboss encode esd ethereal evolution exif expat fam fastbuild firefox foomaticdb force-cgi-redirect fortran ftp gd gdbm gif glitz glut gmp gnome gpm gstreamer gtk gtk2 gtkhtml guile idn imap imlib input_devices_keyboard input_devices_mouse ipv6 isdnlog java jpeg kde kerberos kernel_linux lcms ldap libg++ libwww lm_sensors mad memlimit mikmod mmx mng mono motif mozilla mp3 mpeg mysql ncurses nls nptl nptlonly nsplugin ogg opengl oss pam pcre pdf perl png posix pppd python qt qt3 qt4 quicktime readline reflection samba sdl session simplexml slang snmp soap sockets spell spl sse sse2 ssl svg tcpd tiff tokenizer truetype truetype-fonts type1-fonts udev unicode usb userland_GNU userlocales video_cards_fbdev video_cards_radeon video_cards_vesa vorbis x86 xinerama xml xml2 xmms xorg xscreensaver xsl xv zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS


i also have

Code:
gnome-extra/evolution-exchange ~x86


in /etc/package.keywords, and i apologise - the error was with compiling evolution-exchange and not evolution-data-server...

i don't really feel like doing all that compiling again though - although ccache should speed it slightly i need to get some work done!!!

OT: how stable and happy is evolution 2.8? do i need to use an overlay or can I unmask the packages in portage?
Back to top
View user's profile Send private message
gregw
Tux's lil' helper
Tux's lil' helper


Joined: 20 Nov 2004
Posts: 106
Location: Warrington, Cheshire, England

PostPosted: Thu Sep 28, 2006 11:22 am    Post subject: Reply with quote

Quote:
First of all thanks for the technical solution. However, I do not think
it's acceptable, since many people may use krb5 for several packages.


I fully agree! This is only a point increment, its not a totally new innovative or groundbreaking version of openldap; OK not groundbreakign but gentoobreaking! yet there is a dep change and no warning! quite incredible. I've enough problems with samba apps at the moment withiout having to remove mit-krb5 and all the hassle of revdep-rebuilds just after I've changed to 2006.1 profile and gcc 4 followed by a rebuild world that took 3 days!

Enough messing I'm package.masking 2.3.24-r1

OT: there is a great article in Linux Format about concern within GNU/Linux projects that they are starting to look more cathederal than bazzar now. Maybe devs should listen to what people want once in a while

Good luck to everyone else with this issue!!!
GregW
Back to top
View user's profile Send private message
djbeenie
Apprentice
Apprentice


Joined: 09 Nov 2005
Posts: 207

PostPosted: Thu Sep 28, 2006 12:26 pm    Post subject: Reply with quote

I am getting this error :

Code:


 * Building contributed dsaschema
dsaschema.c: In function 'dsaschema_read_config':
dsaschema.c:247: warning: 'savelineno' is used uninitialized in this function
dsaschema.c: In function 'init_module':
dsaschema.c:265: warning: 'rc' may be used uninitialized in this function
 * Building contributed pw-kerberos
 * Building contributed pw-netscape
 * Building contributed smbk5pwd
../../../libtool --mode=compile gcc -O2 -march=pentium-m -fomit-frame-pointer -pipe -DDO_SAMBA -DDO_KRB5 -I../../../in5pwd.c
mkdir .libs
 gcc -O2 -march=pentium-m -fomit-frame-pointer -pipe -DDO_SAMBA -DDO_KRB5 -I../../../include -I../../../servers/slapd 5pwd.o
smbk5pwd.c:45:25: error: kadm5/admin.h: No such file or directory
smbk5pwd.c:46:17: error: hdb.h: No such file or directory
smbk5pwd.c:56: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'conf'
smbk5pwd.c:57: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
smbk5pwd.c: In function 'k5key_chk':
smbk5pwd.c:275: error: 'krb5_salt' undeclared (first use in this function)
smbk5pwd.c:275: error: (Each undeclared identifier is reported only once
smbk5pwd.c:275: error: for each function it appears in.)
smbk5pwd.c:275: error: expected ';' before 'salt'
smbk5pwd.c:276: error: 'hdb_entry' undeclared (first use in this function)
smbk5pwd.c:276: error: expected ';' before 'ent'
smbk5pwd.c:291: error: 'Key' undeclared (first use in this function)
smbk5pwd.c:291: error: expected ';' before 'ekey'
smbk5pwd.c:296: error: 'ent' undeclared (first use in this function)
smbk5pwd.c:299: error: 'salt' undeclared (first use in this function)
smbk5pwd.c:306: error: 'ekey' undeclared (first use in this function)
smbk5pwd.c:309: error: 'db' undeclared (first use in this function)
smbk5pwd.c:317: error: 'krb5_keyblock' has no member named 'keyvalue'
smbk5pwd.c:318: error: 'krb5_keyblock' has no member named 'keyvalue'
smbk5pwd.c: In function 'smbk5pwd_exop_passwd':
smbk5pwd.c:363: error: 'hdb_entry' undeclared (first use in this function)
smbk5pwd.c:363: error: expected ';' before 'ent'
smbk5pwd.c:375: error: 'ent' undeclared (first use in this function)
smbk5pwd.c:396: error: 'db' undeclared (first use in this function)
smbk5pwd.c:405: error: 'Key' undeclared (first use in this function)
smbk5pwd.c: In function 'smbk5pwd_modules_init':
smbk5pwd.c:789: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
smbk5pwd.c:789: error: invalid type argument of 'unary *'
smbk5pwd.c:829: error: 'KADM5_ADMIN_SERVICE' undeclared (first use in this function)
smbk5pwd.c:832: error: 'conf' undeclared (first use in this function)
smbk5pwd.c:835: error: 'db' undeclared (first use in this function)
make: *** [smbk5pwd.lo] Error 1

!!! ERROR: net-nds/openldap-2.3.27 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  openldap-2.3.27.ebuild, line 320:   Called die

!!! failed to compile smbk5pwd module
!!! If you need support, post the topmost build error, and the call stack if relevant.

_________________
Linux Newbie
Back to top
View user's profile Send private message
dannypoo
n00b
n00b


Joined: 24 Nov 2002
Posts: 25
Location: london

PostPosted: Thu Sep 28, 2006 12:41 pm    Post subject: Reply with quote

so to sort this problem out, do this (as root):

Code:
mygentoobox ~ # echo >=net-nds/openldap-2.3.27 >> /etc/portage/package.mask


for now that allows you to not update openldap...
Back to top
View user's profile Send private message
djbeenie
Apprentice
Apprentice


Joined: 09 Nov 2005
Posts: 207

PostPosted: Thu Sep 28, 2006 12:46 pm    Post subject: Reply with quote

dannypoo wrote:
so to sort this problem out, do this (as root):

Code:
mygentoobox ~ # echo >=net-nds/openldap-2.3.27 >> /etc/portage/package.mask


for now that allows you to not update openldap...


That works for me. :)
_________________
Linux Newbie
Back to top
View user's profile Send private message
Doron
n00b
n00b


Joined: 28 Sep 2006
Posts: 37

PostPosted: Thu Sep 28, 2006 1:27 pm    Post subject: Reply with quote

OK,
Current status is masking out the new openldap version- openldap-2.3.27.
I posted a message for the openldap dev guys in the bugzilla. See- http://bugs.gentoo.org/show_bug.cgi?id=135238#c34

Now we need to wait and see what they can come up with.
Doron.
_________________
Common sense is not so common. (Voltaire)
Back to top
View user's profile Send private message
UberPinguin
Guru
Guru


Joined: 20 Nov 2005
Posts: 510
Location: 2416.94 Miles From Home

PostPosted: Thu Sep 28, 2006 1:38 pm    Post subject: Reply with quote

I've been participating in the bugzilla for this for several months. Still no progress. Can everyone who's posted tell me what version of mit-krb5 you are using?
_________________
aidanjt wrote:
You see, instead of arguing from ignorance, and fear, there is only one way to verify a theory. And that's not by clutching a black book and begging the sky fairy for deliverance from the mad scientists and their big machines.
Back to top
View user's profile Send private message
Raffi
l33t
l33t


Joined: 17 Mar 2003
Posts: 711
Location: Moscow, Id.

PostPosted: Thu Sep 28, 2006 1:58 pm    Post subject: Reply with quote

app-crypt/mit-krb5-1.4.3-r3
Back to top
View user's profile Send private message
Doron
n00b
n00b


Joined: 28 Sep 2006
Posts: 37

PostPosted: Thu Sep 28, 2006 2:00 pm    Post subject: Reply with quote

My krb version:
Code:

x1laptopdoron ~ # emerge -s mit-krb5
Searching...
[ Results for search key : mit-krb5 ]
[ Applications found : 1 ]

*  app-crypt/mit-krb5
      Latest version available: 1.4.3-r3
      Latest version installed: 1.4.3-r3
      Size of files: 7,120 kB
      Homepage:      http://web.mit.edu/kerberos/www/
      Description:   MIT Kerberos V
      License:       as-is

_________________
Common sense is not so common. (Voltaire)
Back to top
View user's profile Send private message
Doron
n00b
n00b


Joined: 28 Sep 2006
Posts: 37

PostPosted: Thu Sep 28, 2006 2:12 pm    Post subject: Temporary solution to avoid masking Reply with quote

Guys,
There's a way to remove kerberos support only from openldap.
Here I need to warn you to do this only if you know you don't need kerberos support
for openldap. Otherwise masking is still the way to prevent re-building your portage tree....

So, do the following iff (if and only if) you know you don't need kerberos support for openldap:
Code:

echo net-nds/openldap -kerberos >> /etc/portage/package.use
emerge --newuse --update openldap


Thanks to Alon Bar-Lev (alon.barlev@gmail.com) for his help with this one.
Doron.
_________________
Common sense is not so common. (Voltaire)
Back to top
View user's profile Send private message
UberPinguin
Guru
Guru


Joined: 20 Nov 2005
Posts: 510
Location: 2416.94 Miles From Home

PostPosted: Thu Sep 28, 2006 2:33 pm    Post subject: Reply with quote

OK. So it doesn't look like upgrading mit-krb5 will help right now...
This has been a problem since openldap-2.3.24-r2. It looks like some new features were added at that point that depend on things not yet included in mit-krb5. So, last actually stable version would be 2.3.24-r1, I think.
I don't know why .27 was marked stable for x86. Thus far, it doesn't look like any of the maintainers (openldap/heimdal/mit-krb5) actually care to take the time to fix this, and I really don't have the expertise.
On the plus side, mit-krb5-1.5.1 is in testing. If I'm reading the changelog correctly, it looks like this problem was resolved at 1.5.0, but it hasn't been added to portage yet.
_________________
aidanjt wrote:
You see, instead of arguing from ignorance, and fear, there is only one way to verify a theory. And that's not by clutching a black book and begging the sky fairy for deliverance from the mad scientists and their big machines.
Back to top
View user's profile Send private message
farmorg
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2003
Posts: 76
Location: Leicester (UK)

PostPosted: Fri Sep 29, 2006 11:50 am    Post subject: Reply with quote

Hi all

I ran into this today while upgrading to gcc 4.1.1 & doing an emerge -e world.

I tried adding
Code:
>=net-nds/openldap-2.3.27
to /etc/portage/package.mask but emerge --resume still insists on installing 2.3.27
So, I tried changing package.mask to read
Code:
>net-nds/openldap-2.3.24-r1
but it STILL insists on installing 2.3.27

Any ideas as to why this should be? It's like portage just isn't reading the package.mask file :?
I did an emerge --resume --skip-first which got the upgrade going again but I know this will crop up again soon!

farmorg
_________________
Master farmorg

May the source be with you
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum