Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kernel panic na install nieuwe hd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
Johny the Ripper
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2004
Posts: 135
Location: EU - Belgium

PostPosted: Sun Sep 24, 2006 11:09 am    Post subject: kernel panic na install nieuwe hd Reply with quote

originele thread (pc-active forum)

Bij het laden van de kernel krijg ik een kernel panic... Hier zijn de laatste regels die op het scherm komen:
Code:
ReiserFS: hda3: found reiserfs format "3.6" with standard journal
ReiserFS: hda3: using ordered data mode
ReiserFS: hda3: warning: sh-461: journal_init: wrong transaction max size (19723). Changed to 256
ReiserFS: hda3: journal params: device hda3, size 0, journal first block 18, max trans len 256, mx batch 225, max commit age 536870912, max trans age 30
ReiserFS: hda3: warning: journal-2004: Journal cnode memory allocation failed (0 bytes). Journal is too large for available memory. Usually this is due to a journal that is too large.
UDF-fs: No partition found (1)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,3)


Wat er gebeurde:
Ik heb een extra HD aan het moederbord gehangen, geconfigureerd in het BIOS en geboot. Ik logde in als root en voerde eerst een emerge --sync uit en schakelde dan over naar een andere console om te spelen met de nieuwe HD. fdisk leek alle partities te herkennen, dus probeerde ik er een te mounten. Bij het mounten van een Linux partitie (code 83 ;) ik denk dat het reiserfs was) kreeg ik gezaag over write permissions van /etc/mtab. Bij het mounten van een NTFS partitie net hetzelfde, ik kon de partities niet mounten. Toen kreeg ik plots een kernel panic op het scherm. Ik herstarte de computer, maar nu geraakt hij dus zelfs niet meer voorbij het uitpakken van de kernel...
Ik heb de CPU terug geclockt en de nieuwe HD ontkoppelt, maar de kernel panic blijft bestaan. Uit wat de kernel uitspuwt kan ik opmaken dat mijn systeempartitie beschadigd is... :/

Wat er mee te maken kan hebben:
* Ik had net de CPU overclockt... Een Celeron 266 Mhz op 75 Mhz FSB gezet => 300 Mhz.
* De HD is 160 GB groot, maar ik weet niet of het oude bios dit ondersteunt... Waarschijnlijk niet... Kan de kernel daar last mee krijgen? Ik heb eerst /dev/hdc1 proberen mounten en daarna /dev/hdc6 (de laaste partitie).

Over het systeem:
/dev/hda is 4 GB groot, hda1 is ext2 met de kernel er op, hda2 is swap en hda3 reiserfs met de rest van de linuxinstallatie.

[update]
Ik heb het tooltje reiserfsck (oa) de tree laten herstellen en nu krijg ik enkel maar een kernel panic omdat de kernel init niet kan vinden :/ Dat klinkt niet zo goed... Ik ga meteen even kijken in knoppix of ik data kwijt ben op de systeempartitie...

Ik heb de systeempartitie gemount onder knoppix. Een vlugge blik met df -h en ls -lah stelde me gerust: op het eerste zicht lijkt alles er nog op te staan... Maar als ik nu wil chrooten dan krijg ik de foutmelding "Cannot execute /bin/bash: No such file or directory"... /bin/bash bestaat gewoon op die partitie, ik kan het zelfs uitvoeren vanop de knoppix-console. De kernel vindt opeens init niet meer terug... Wat gebeurt er?!
_________________
De omnis Belgae bravissimi ... erant
Back to top
View user's profile Send private message
Maitreya
Apprentice
Apprentice


Joined: 11 Jan 2006
Posts: 220

PostPosted: Sun Jan 21, 2007 4:00 pm    Post subject: Reply with quote

Quote:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,3)


(3,3)

Heb je een /dev/hdd4 ?
Back to top
View user's profile Send private message
Johny the Ripper
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2004
Posts: 135
Location: EU - Belgium

PostPosted: Sun Jan 21, 2007 4:16 pm    Post subject: Reply with quote

hmm dit is een erg oude post, maar ja, ik had een hdd4 denk ik. Op de hdd die ik had toegevoegd en opnieuw verwijderd heb toen de kernel panics kwamen.

Ondertussen heb ik de systeem hd gewoon geformateerd (zie ook de link naar het pca forum voor wat ik nog allemaal geprobeerd heb) en gewoon opnieuw begonnen met de installatie. Dan het geheel wat op de lange baan geschoven, uiteindelijk terug uit de frigo gehaald en ssh er op geïnstalleerd (nu hoef ik geen grafische kaart meer :)) en nu terug even in de frigo gestoken. Als m'n examens gedaan zijn ga ik nog even proberen de HD van 160 GB er in te stoppen en dan al die rotzooi ergens in een donker hoekje aan een utp kabel hangen.

[edit] Ik zal waarschijnlijk de volgende opstelling gehad hebben:
    hda: systeem HD
    hdc: cd-rom drive
    hdd: /home HD
[/edit]
_________________
De omnis Belgae bravissimi ... erant
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum