Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gthumb] plantages reproductibles: bug connu. (fini)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
TTK
Guru
Guru


Joined: 02 Mar 2004
Posts: 523

PostPosted: Mon Sep 11, 2006 7:52 pm    Post subject: [gthumb] plantages reproductibles: bug connu. (fini) Reply with quote

Salut

Gthumb plante régulièrement ces jours-ci. J'ai des erreurs de free sur des mauvais pointeurs relevées par la glibc. Un coup de google me montre que je suis pas le seul, mais pas de solution. Cela pourrait-il venir d'UTF8 ? Je suis passé à UTF il n'y a pas longtemps, sans que je puisse affirmer que ça vient de là.

Où alors une version plus tatillonne de glibc ?

J'ai re-emergé gthumb, mais g la flemme de recompiler une glibc inférieure ...


Last edited by TTK on Tue Sep 19, 2006 3:32 pm; edited 3 times in total
Back to top
View user's profile Send private message
Trapamoosch
Apprentice
Apprentice


Joined: 08 May 2004
Posts: 203

PostPosted: Tue Sep 12, 2006 8:05 am    Post subject: Reply with quote

Je suis en UTF8 avec media-gfx/gthumb-2.6.9 et sys-libs/glibc-2.4-r3 et ça fonctionne très bien sans plantage.
Back to top
View user's profile Send private message
TTK
Guru
Guru


Joined: 02 Mar 2004
Posts: 523

PostPosted: Sun Sep 17, 2006 9:12 pm    Post subject: Reply with quote

Le bug se produit quand je clicke sur la flèche de retour au dossier précédent ..

En vue "dossiers", je double clicke sur un sous répertoire, puis flèche "précédent", puis double clicke sur un autre répertoire: boum: *** glibc detected *** gthumb: free(): invalid pointer: 0x0835ef70 ***

Je tente la version ~x86 de gthumb, même problème !

Le pb doit venir d'une des libs de gnome ... Une idée ?
Back to top
View user's profile Send private message
TTK
Guru
Guru


Joined: 02 Mar 2004
Posts: 523

PostPosted: Tue Sep 19, 2006 5:50 am    Post subject: Reply with quote

SVP, qqun pourrait faire le test décrit ci dessus chez lui ? Je l'ai fait sur une amd64 toute fraichement installée et j'ai eu exactement le même plantage !
Merci
Back to top
View user's profile Send private message
blasserre
Veteran
Veteran


Joined: 10 Feb 2004
Posts: 1362
Location: Lille, Vlaanderen

PostPosted: Tue Sep 19, 2006 6:14 am    Post subject: Reply with quote

autant pour moi :( sur la stable et la testing
sur x86 gcc-4.1.1 tout frais
CFLAGS="-march=prescott -O3 -pipe -fomit-frame-pointer"
_________________
benj

technicien professionnel, ascendant winner
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1591
Location: 127.0.0.1

PostPosted: Tue Sep 19, 2006 8:06 am    Post subject: Reply with quote

Salut,

Exactement même problème en effectuant la manip décrite ci-dessus.

Quote:

*** glibc detected *** gthumb: double free or corruption (out): 0x085ed850 ***
======= Backtrace: =========
/lib/libc.so.6[0xb717eb9b]
...


Quote:

$ eix gthumb
[I] media-gfx/gthumb
Available versions: 2.6.3 2.6.5 2.6.7 2.6.8 2.6.8-r1 2.6.8-r2 2.6.9
Installed: 2.6.9
Homepage: http://gthumb.sourceforge.net/
Description: Image viewer and browser for Gnome


Full ~x86, glibc recompilée il y a quelques jours, et CFLAGS vraiment légers.
Back to top
View user's profile Send private message
guitoo
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2004
Posts: 132

PostPosted: Tue Sep 19, 2006 8:31 am    Post subject: Reply with quote

meme chose
gthumb-2.6.5
glibc-2.4-r3
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1591
Location: 127.0.0.1

PostPosted: Tue Sep 19, 2006 8:32 am    Post subject: Reply with quote

http://bugzilla.gnome.org/show_bug.cgi?id=308965
http://bugzilla.gnome.org/show_bug.cgi?id=353258
Back to top
View user's profile Send private message
TTK
Guru
Guru


Joined: 02 Mar 2004
Posts: 523

PostPosted: Tue Sep 19, 2006 3:32 pm    Post subject: Reply with quote

Ah bah j'me sens moins seul, merci les gars.

Donc les devs sont au courant, tout va bien.
Je reste avec mon bug et je fais gaffe à pas clicker sur le bouton de la mort.

Tshaw
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1591
Location: 127.0.0.1

PostPosted: Tue Sep 19, 2006 5:27 pm    Post subject: Reply with quote

Bug corrigé dans la version CVS.

Pour la version 2.6.9, si vous ne voulez pas attendre la prochaine version pour corriger le bug :
- sauvez ce patch dans /tmp/fix-crash-bookmarks.patch
- sauvez ce patch dans /tmp/gthumb-ebuild.patch

Puis exécutez les commandes suivantes, sachant que :
- /usr/local/portage est mon overlay
- /var/portage est mon arbre officiel
Quote:

cd /usr/local/portage/
mkdir -p media-gfx/gthumb/files

cp /var/portage/media-gfx/gthumb/gthumb-2.6.9.ebuild media-gfx/gthumb/
cp /var/portage/media-gfx/gthumb/files/gthumb-2.6.8-Makefile.patch media-gfx/gthumb/files/
cp /var/portage/media-gfx/gthumb/files/gthumb-2.6.8-options.patch media-gfx/gthumb/files/
cp /var/portage/media-gfx/gthumb/files/gthumb-2.6.9-as-needed.patch media-gfx/gthumb/files/

cp /tmp/fix-crash-bookmarks.patch media-gfx/gthumb/files/

patch media-gfx/gthumb/gthumb-2.6.9.ebuild < /tmp/gthumb-ebuild.patch

ebuild media-gfx/gthumb/gthumb-2.6.9.ebuild digest

emerge --ask gthumb
Back to top
View user's profile Send private message
TTK
Guru
Guru


Joined: 02 Mar 2004
Posts: 523

PostPosted: Tue Sep 19, 2006 8:13 pm    Post subject: Reply with quote

Ca roule NetFab !
Merci.
Back to top
View user's profile Send private message
blasserre
Veteran
Veteran


Joined: 10 Feb 2004
Posts: 1362
Location: Lille, Vlaanderen

PostPosted: Tue Sep 19, 2006 8:41 pm    Post subject: Reply with quote

perso je suis passé à f-spot (ok y'a des dépendances de dingue)
mais franchement ça n'a rien à voir avec gthumb j'avais même oublié la tête qu'il avait jusqu'à ce matin ^^
_________________
benj

technicien professionnel, ascendant winner
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum