Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub Error Collection [Part 6]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 11, 12, 13  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Fri Sep 08, 2006 3:33 am    Post subject: Reply with quote

Hi Gooserider.

Actually, from your error, I would review again how you installed GRUB in the MBR and what device the BIOS is booting from.
From your grub.conf, you should have used:
Code:
# grub
grub> root (hd0,1)
grub> setup (hd0)
grub> quit
#

_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32441
Location: 56N 3W

PostPosted: Fri Sep 08, 2006 11:02 am    Post subject: Reply with quote

Gooserider,

DOS 5.0 predates drives bigger than 8GB and the need for Logical Block Addressing. Thus it will have written correct Cylinder/Head/Sector partition information. It may have written the LBA too, its been a while since I used that fdisk. However, it will have set the partition type to FAT16, which is incorrect for a Linux boot partiton. grub can work from a FAT partiton but you have to be very careful because FAT does not support symbolic links. That means menu.lst must be a real file, not a link to grub.conf.

If you choose to use a Linux filesystem on your /boot that issue goes away, the partiton type byte is largely ignored by Linux, so having that set to FAT16 but using ext2 will not cause problems.

As you say, if the kernel loads and the root filesystem mounts, grub has done its stuff and your remaining issues are elsewhere.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
MrBill
n00b
n00b


Joined: 08 Sep 2006
Posts: 1

PostPosted: Fri Sep 08, 2006 7:00 pm    Post subject: Problem Reply with quote

I have a problem with when i extract the portage image i after a while get an error message saying no more space and file doesent exist has this been adreesd before and what should i do?
Back to top
View user's profile Send private message
Gooserider
Apprentice
Apprentice


Joined: 30 Dec 2005
Posts: 165
Location: Universe, Milky Way Galaxy, Solar System, Earth, North America, USA, MA, North Billerica

PostPosted: Fri Sep 08, 2006 8:05 pm    Post subject: Reply with quote

Thanks for the responses, however so far they haven't helped me get very far :cry:

Quote:
NeddySeagoon
DOS 5.0 predates drives bigger than 8GB and the need for Logical Block Addressing. Thus it will have written correct Cylinder/Head/Sector partition information. It may have written the LBA too, its been a while since I used that fdisk. However, it will have set the partition type to FAT16, which is incorrect for a Linux boot partiton. grub can work from a FAT partiton but you have to be very careful because FAT does not support symbolic links. That means menu.lst must be a real file, not a link to grub.conf.

Hmmm.... I think you misread a bit of what I posted initially Neddy. My FIRST partition (hda1) ONLY was created wtih DOS fdisk, and as expected it is FAT16 type. My /BOOT partition is hda2, which was made w/ linux fdisk, as a linux partition, and formatted ext2. Hda3 is swap, and the rest of the drive is chopped up into multiple reiserfs partitions for the rest of the file system.

Quote:
If you choose to use a Linux filesystem on your /boot that issue goes away, the partiton type byte is largely ignored by Linux, so having that set to FAT16 but using ext2 will not cause problems.

Possibly true, but not relevant to my situation, as (linux) fdisk -l says that my partition #1 (/dos) is type 6 (FAT16) but /boot, and all the other filesystem partitions on the drive are type 83 - linux. (swap is type 82, and the extended partition is type 5, both as they should be)

Quote:
As you say, if the kernel loads and the root filesystem mounts, grub has done its stuff and your remaining issues are elsewhere.

Well, I won't say "good!" as I'd rather not have the problems elsewhere :lol: but I'm glad to know I have that part right... 8)

-------------------------
Quote:
jmbsvicetto
Actually, from your error, I would review again how you installed GRUB in the MBR and what device the BIOS is booting from.


Not a bad thought, but I have looked at that several times already. I just looked at it again in fact, using the commands you suggested (which I agree look like the right ones) The commands went in w/o any errors, "root (hd0,1)" properly recognized my /boot partition as ext2, and the "setup (hd0)" gave back what I think are correct responses, at least it said it found everything it was looking for, and didn't give any errors.

I feel quite sure based on the hardware I have, the screen display, watching the different drive LED's when booting and so forth, that when I get the hard disk error that the box is indeed looking at the hard drive and trying to boot off it.

That was this morning after I had tried some other stuff, described below, that looked promising, but which thus far has not helped.
-----------------------------------

I have also been doing some other experimenting. According to Neddy, back in part 5 of this collection:
Quote:
NeddySeagoon
Posted: Sun May 14, 2006 4:29 pm
barrymac,
Like this:
Code:

Hard Disk Error
     The stage2 or stage1.5 is being read from a hard disk, and the
     attempt to determine the size and geometry of the hard disk failed.


Go into your BIOS and make sure you do not set the hard drive parameter detecton to auto. LBA is correct, then run the detection once to record the information in the BIOS.

When auto is used, booting breaks when grub queries the BIOS for the drive parameters and the BIOS doesn't know.


I went into my Bios, and found that my hard drive section had two options relating to parameter detection. I had left them both set on the default "auto" as I didn't think there was any harm in doing so, and I generally leave BIOS settings at the defaults unless I have reason to change them.

The choices were "auto", "manual" or "disabled" under IDE Primary Master (the other drives would offer the same choices) and then there was a choice for "Access Mode" of "CHS", "LBA", "Large" or "auto" There is also an "IDE HDD Auto Detection" option that seems to do a one-shot effort to ID the drive and fill in it's parameters. (AFAIK it does so correctly)

(BTW, if I set my DVD burner @ IDE2 Master to anything other than auto/auto it didn't detect properly in the BIOS / POST screens)

I found that the drive parameters listed changed depending on what combination of settings I used. Auto/auto gave the same numbers as auto or manual/CHS. Manual/LBA and Manual/large each gave a different set of values.

If I try setting to manual/LBA, or manual/Large I get the same "Hard Disk Error" that I got on auto/auto. I can boot off a DOS floppy and access the DOS partition, and I can boot the system with a grub floppy as I described in an earlier post.

If I try manual/CHS I get a "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER" error at boot, and while I can boot the DOS floppy, it gives me "invalid drive specification" when I tell it to go to the C: drive. When I boot off the grub floppy, it says "partition table invalid or corrupt" when I tell it root (hd0,0)

Given the earlier comments, I'm going to be setting to manual / LBA unless someone can tell me a good reason not to... It doesn't solve the problem however.

At this point, I could probably just go with a floppy that has a complete grub setup on it, including menu.lst / grub.conf, which would work but strikes me as a real hack. This thing SHOULD be able to boot off the hard drive!!!

Gooserider
_________________
Box 1: P2 Celeron 400, 320mb RAM, 80GB HD, Cirrus Logic 4614/22/24 sound card, ATI 3D RAGE PRO AGP 1X/2X (sound & video onboard)
Box 2: AMD Athlon 2500+ 512mb RAM, 80GB HD, Gigabyte K7 Triton (Nvidia) mobo, GeForce2 video
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Fri Sep 08, 2006 10:24 pm    Post subject: Reply with quote

Gooserider wrote:

The choices were "auto", "manual" or "disabled" under IDE Primary Master (the other drives would offer the same choices) and then there was a choice for "Access Mode" of "CHS", "LBA", "Large" or "auto" There is also an "IDE HDD Auto Detection" option that seems to do a one-shot effort to ID the drive and fill in it's parameters. (AFAIK it does so correctly)
I found that the drive parameters listed changed depending on what combination of settings I used. Auto/auto gave the same numbers as auto or manual/CHS. Manual/LBA and Manual/large each gave a different set of values.

Well, if you set Manual/LBA can you mount your partitions? If so, chroot and install GRUB into the MBR. Can you boot now?
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
96140
Retired Dev
Retired Dev


Joined: 23 Jan 2005
Posts: 1324

PostPosted: Fri Sep 08, 2006 11:41 pm    Post subject: Reply with quote

@Gooserider:

Did you remember to watch out for the symlinks problem? Remember that any sort of FAT filesystem doesn't allow symlinks.
Back to top
View user's profile Send private message
Gooserider
Apprentice
Apprentice


Joined: 30 Dec 2005
Posts: 165
Location: Universe, Milky Way Galaxy, Solar System, Earth, North America, USA, MA, North Billerica

PostPosted: Sat Sep 09, 2006 3:31 am    Post subject: Reply with quote

jmbsvicetto;
When I'm set to manual/LBA, I can boot either the installed linux system from the minimal grub floppy, or the CD version from the CD. In EITHER case, I can mount the linux partitions w/o problem or they are mounted as part of bootup. I have run grub "setup (hd0)" from a chroot off the CD (per the manual procedure), from the installed and booted hard-drive install, and directly from the grub minimal floppy.

In all three cases, setup runs w/o any visible errors. It properly finds and mounts (hd0,1) (aka /dev/hda2) as an EXT2 filesystem, which it is formatted as, then procedes to find my kernel (I know that it's mine because of the name I gave it when creating it) and all the associated grub files (stage 1, stage1.5ext, stage2, menu.lst, etc) without complaint of ANY sort.

I then reboot w/o the floppy or CD, and get the exact same Hard Disk Error message I've been getting from the beginning :!: :x

The only thing I've noticed where there is any complaint, is that when I've booted my kernel (using the grub floppy) it doesn't want to mount my /dos partition (hda1) I get the error message "wrong fs type, bad option, bad superblock on /dev/hda1, missing codepage, or other error" ALL other hard drive partitions are mounted or mount w/o problems. I tried changing the fstype in /etc/fstab from "msdos" to "auto" but that didn't help.

nightmorph: Please don't feel offended, but did you READ my earlier post? :roll: I went into great detail to explain to Neddy (and presumably everyone else) that I am ONLY using a FAT16 partition on /DEV/HDA1 :!: My BOOT partition is on /dev/hda2 and is formatted ext2 :!: Therefore it is a type 82 Linux partition, and is perfectly capable of working with symlinks! I am not trying in any way to work with symlinks on a FAT fs, I don't quite understand why people seem to think I am. (I'm not mad at anyone, but it gets frustrating after a while...)

Actually, I did just notice that I have /dev/hda2 labeled as an ext3 partition in /etc/fstab, it is grub that labels it as ext2 - however my understanding is that ext3 is really just ext2 with journalling, and that it isn't unusual or a problem if something sees an ext3 fs as ext2.

Gooserider
_________________
Box 1: P2 Celeron 400, 320mb RAM, 80GB HD, Cirrus Logic 4614/22/24 sound card, ATI 3D RAGE PRO AGP 1X/2X (sound & video onboard)
Box 2: AMD Athlon 2500+ 512mb RAM, 80GB HD, Gigabyte K7 Triton (Nvidia) mobo, GeForce2 video
Back to top
View user's profile Send private message
Gooserider
Apprentice
Apprentice


Joined: 30 Dec 2005
Posts: 165
Location: Universe, Milky Way Galaxy, Solar System, Earth, North America, USA, MA, North Billerica

PostPosted: Sat Sep 09, 2006 5:13 am    Post subject: Reply with quote

Oh yes, latest experiments... I had speculated earlier that when I created (ONLY) /dev/hda1 as a DOS partition using DOS 5.0 fdisk, which doesn't recognize big drives, then created the rest of the partitions w/ Linux fdisk, there might have been some wierd interaction between the two different fdisks, and they might have put something strange on the disk.

In light of this, I went in with Linux FDISK and removed only the /dev/hda1 (fat16, DOS, created w/ DOS fdisk) partition, then recreated the same size and type partition with Linux FDISK, saved the partition table, and rebooted. This should have fixed any possible problems if I understand the way fdisk works.

SAME PROBLEM! :cry: I can boot the hard disk off the grub floppy, but get Grub Hard Disk Error when I try to boot off the hard drive directly.


As a separate issue, I did fix the problem with mounting /dos however. I had the options "defaults,notail,noatime" in /etc/fstab, apparently dos doesn't like one of them. When I changed the fstype back to msdos from where I had tried it as auto, and changed the options to just "defaults" then it mounted just fine. 8)

FWIW, I also tried making /dev/hda2 the active (boot flag) partition in fdisk, that doesn't seem to help either.

I'm starting to wonder - is there any chance that my grub is corrupted or a bad version? I didn't get any errors when I emerged it a couple of weeks ago, and it seems to be installing properly, but could there be some other issue?

Is there any possibility that I may be having a problem due to grub thinking the fs is an ext2 fs, while /etc/fstab thinks its ext3? (FWIW, I'm 99.9% certain that I created it as an ext3 when I was installing the system)

Gooserider
_________________
Box 1: P2 Celeron 400, 320mb RAM, 80GB HD, Cirrus Logic 4614/22/24 sound card, ATI 3D RAGE PRO AGP 1X/2X (sound & video onboard)
Box 2: AMD Athlon 2500+ 512mb RAM, 80GB HD, Gigabyte K7 Triton (Nvidia) mobo, GeForce2 video
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32441
Location: 56N 3W

PostPosted: Sat Sep 09, 2006 8:49 am    Post subject: Reply with quote

Gooserider,

Remaking the partition table entry for /dev/hda1 does nothing to the data on the partition.
You need to continue buy saving the data from /dev/hda1, making a filesystem (ext2 is good) and copying the kernel, initrd and grub.conf back.
You need to
Code:
emerge grub
again so it can make its symlinks and reinstall grub to the MBR because you have changed the filesystem on /boot.

Grub won't mind anout the boot filesystem being ext2 or ext3 but the mount command will. If /etc/fstab is not correct and you use a lazy form of mount, you will get an error.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
cyrillic
Watchman
Watchman


Joined: 19 Feb 2003
Posts: 7301
Location: Groton, Massachusetts USA

PostPosted: Sat Sep 09, 2006 11:22 pm    Post subject: Reply with quote

Gooserider wrote:
As a separate issue, I did fix the problem with mounting /dos however. I had the options "defaults,notail,noatime" in /etc/fstab, apparently dos doesn't like one of them.

Just so you know, the "notail" option is specific to reiser3.x and does not apply to any other filesystem type.
Back to top
View user's profile Send private message
aeklant
n00b
n00b


Joined: 26 Aug 2006
Posts: 4

PostPosted: Sun Sep 10, 2006 12:14 am    Post subject: problem with GRUB Reply with quote

hi everyone

so, i´m a noob at this gentoo stuff n i was at the install grub part of gentoo installation so i did the following:

Code:
#emerge grub


n as it was doing so this message appeared:

Code:
>>>Merging sys-boot/grub-0.97-r2 to /

*
*Cannot automatically mount your /boot partition
*Youy boot partition has to be mounted rw before the installation
*can continue. grub needs to install important files there.
*

!!!ERROR: sys-boot/grub-0.97-r2 failed


so aparently i have to mount rw the boot partition, but i have no idea how to do that, it doesn´t say anything about it in the guide n i haven´t been able to find it online, please if someone knows give me a hand.
Back to top
View user's profile Send private message
ter_roshak
Apprentice
Apprentice


Joined: 31 Jan 2004
Posts: 171
Location: Everett, WA

PostPosted: Sun Sep 10, 2006 12:36 am    Post subject: Reply with quote

Try mounting your /boot partition by executing the following command:

Code:

mount /boot


Then attempt to install/emerge grub again. You may have to verify that you have an appropriate entry in your /etc/fstab for your /boot mount point:

Code:

/dev/hda1                       /boot                           ext3           noauto,noatime   1 2


Replace values with appropriate values for your system.

** If this does not work, I would recommend going through the manual again to learn more about the process.
_________________
Josh Miller -- RHCE, VCP
Ditree Consulting
http://ditree.com/
Registered Linux User #318200
Back to top
View user's profile Send private message
cyrillic
Watchman
Watchman


Joined: 19 Feb 2003
Posts: 7301
Location: Groton, Massachusetts USA

PostPosted: Sun Sep 10, 2006 12:45 am    Post subject: Reply with quote

... and if your /boot is not on a separate partition, then make sure you remove the /boot line from /etc/fstab so that the GRUB installation does not get confused.
Back to top
View user's profile Send private message
aeklant
n00b
n00b


Joined: 26 Aug 2006
Posts: 4

PostPosted: Sun Sep 10, 2006 1:02 am    Post subject: Reply with quote

ok so i checked fstab n its right, n also boot is on a separate partition, tried the
mount /boot command n it didn´t work, could someone explain what "mounting rw" means n the difference between "mounting" n "mounting rw" so i can have an idea of what is happening, i would really appreciate it.
Back to top
View user's profile Send private message
Nick C
Guru
Guru


Joined: 18 Mar 2005
Posts: 526
Location: Portsmouth, England

PostPosted: Sun Sep 10, 2006 1:40 am    Post subject: Reply with quote

should just be a case of mount /dev/hdax /boot (or sda if your drive is sata or scsi and where the number of your boot partition). Assuming you formatted /boot as ext2, if its ext3 then use mount -t ext3 /dev/hdax /boot
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved.
www.monkeydust.net
Back to top
View user's profile Send private message
jamesdick628
Apprentice
Apprentice


Joined: 14 Oct 2004
Posts: 158
Location: Worcester, MA

PostPosted: Sun Sep 10, 2006 1:42 am    Post subject: Reply with quote

I don't remember ever having to mount /boot to emerge grub. Is this new?
Back to top
View user's profile Send private message
Nick C
Guru
Guru


Joined: 18 Mar 2005
Posts: 526
Location: Portsmouth, England

PostPosted: Sun Sep 10, 2006 2:05 am    Post subject: Reply with quote

i believe its only recently that the error message has been added to grub but yes, while it might not strictly be necessary for the grub binary, it is needed (or at least very useful) so that the right folders can be created and sample files added.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved.
www.monkeydust.net
Back to top
View user's profile Send private message
jstead1
Guru
Guru


Joined: 01 Aug 2003
Posts: 427
Location: Oswego, NY where the snow is deep

PostPosted: Sun Sep 10, 2006 3:10 am    Post subject: Reply with quote

You will probably need to be root to mount /boot (you need to be root to emerge so I assume you know how to do it).
The default for mounting a drive is read/write (rw).
So as root, you should be able to mount /boot by just:
Code:
mount /boot


This assumes your fstab is correct.

It should have something in it like:
Code:

/dev/hdb1      /boot      ext2      noauto,noatime         1 2


Your device (in my case hdb1) will probably be different.
Your mount point (/boot) must be the same
The filesystem (in my case ext2) may be different, but must be supported in your kernel
The options (noauto,noatime) may be different, but shouldn't contain ro (read only)
The last two numbers are for dump and pass. If you don't know what dump is don't worry about, pass should be 2 for /boot.
For more info on mount,dump and pass:
Code:
man fstab
man dump
man mount


If you were root when you tried to mount /boot, then there is probably something wrong with fstab.
This seems likely since the error message implies that the ebuild attempted to mount /boot, but it could not.
_________________
jim
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Sun Sep 10, 2006 3:24 am    Post subject: Reply with quote

[mod]Merged above 8 posts here.[/mod]

Hi.
Are you sure that you're inside the chroot?
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32441
Location: 56N 3W

PostPosted: Sun Sep 10, 2006 11:52 am    Post subject: Reply with quote

aeklant,

You should mount things from outside the chroot
The command would be
Code:
mount /dev/... /mnt/gentoo/boot
You fill in the dots.

The other issue is that inside the chroot /etc/mtab does not exist, so grub cannot tell if boot is mounted or not.
Did you miss the steo that fakes a /etc/mtab for grub ?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Gooserider
Apprentice
Apprentice


Joined: 30 Dec 2005
Posts: 165
Location: Universe, Milky Way Galaxy, Solar System, Earth, North America, USA, MA, North Billerica

PostPosted: Sun Sep 10, 2006 1:09 pm    Post subject: Reply with quote

Quote:
cyrillic:
Just so you know, the "notail" option is specific to reiser3.x and does not apply to any other filesystem type.

Thanks, it is good to know that. Solved my question about why I was having that minor problem.

---------------
Quote:

NeddySeagoon:
Gooserider,
Remaking the partition table entry for /dev/hda1 does nothing to the data on the partition.
You need to continue buy saving the data from /dev/hda1, making a filesystem (ext2 is good) and copying the kernel, initrd and grub.conf back.
You need to Code:
emerge grub
again so it can make its symlinks and reinstall grub to the MBR because you have changed the filesystem on /boot.
Grub won't mind anout the boot filesystem being ext2 or ext3 but the mount command will. If /etc/fstab is not correct and you use a lazy form of mount, you will get an error.

I don't quite see why we are seemingly having a failure to communicate or something...

I keep saying that my desired /boot partition is /dev/hdaTWO and you keep talking about what I need to do to fix /dev/hdaONE :!: :? Are you saying that having /dev/hda1 as a DOS partition is not OK? I know that I have done it several times in the past with LILO setups. I like having a DOS partition somewheres on the system, though I don't insist on it being /dev/hda1. (and I don't insist that /dev/hda2 be my /boot partition either) If there is a fundamental problem with my setup say so, and I can just do a re-install, possibly w/ a 2006.1 disk now that I've heard the updated installer is out. (it would save the hassle of doing the separate gcc upgrade)

Alternatively, I can try blowing away partitions /dev/hda1 and /dev/hda2 and then remaking both of them in reverse order so that I can at least get /boot onto /hda1. Would this do what you think I should have?

Gooserider
_________________
Box 1: P2 Celeron 400, 320mb RAM, 80GB HD, Cirrus Logic 4614/22/24 sound card, ATI 3D RAGE PRO AGP 1X/2X (sound & video onboard)
Box 2: AMD Athlon 2500+ 512mb RAM, 80GB HD, Gigabyte K7 Triton (Nvidia) mobo, GeForce2 video
Back to top
View user's profile Send private message
Bob Leny
Apprentice
Apprentice


Joined: 18 Aug 2006
Posts: 189

PostPosted: Tue Sep 12, 2006 12:06 am    Post subject: Reply with quote

I need some help here if at all possible. I installed grub on hdb,5 and stupid me, doesnt load from hdb, it loads from hda. So I switched out the hard drives. You can the issue... (If not, now grub is looking in hdb,5, which doesn't exist...)

I either want to redo grub from the live cd or boot from a floopy to bypass grub and fix the problem from Gentoo drive.

I tried a few diffrent things...
Code:

# cd /boot/grub
# dd if=stage1 of=/dev/fd0 bs=512 count=1
1+0 records in
1+0 records out
# dd if=stage2 of=/dev/fd0 bs=512 seek=1
153+1 records in
153+1 records out
#

Thats what I should get...

This is what I get.

# cd /boot/grub
# dd if=stage1 of=/dev/fd0 bs=512 count=1
1+0 records in
1+0 records out
# dd if=stage2 of=/dev/fd0 bs=512 seek=1
dd: writing `/dev/fd0': Input/output error
72+0 records in
71+0 records out
#

As a ressult, when I load from floppy, it says read error on stage2...


Something else I tried:
Code:

it was something like this:

# install-grub /dev/hda5
bash: install-grub: command not found

I guess that doesnt work with gentoo...


Code:

#fdisk -l

Disk /dev/hda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device   Boot   Start     End      Blocks    Id   System
/dev/hda1              1     132     1060258+    5   Extended
/dev/hda2            133    1378    10008495    83   Linux
/dev/hda3           1379    5114    30009420    83   Linux
/dev/hda4           5115   30401   203117827+   83   Linux
/dev/hda5      *       1       7       56164+   83   Linux
/dev/hda6              8     132     1004031    82   Linux swap /solaris

Disk /dev/hdb: 60.0 GB, 6002248896 bytes
255 heads, 63 sectors/track, 7297 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device   Boot   Start     End      Blocks    Id   System
/dev/hd1       *       1    6941    55747408+    c   W95 FAT32 (LBA)
/dev/hd2            6941    7297     2865240     f   W95 Ext'd (LBA)
/dev/hd5            6941    7297     2865208+    f   W95 FAT32 (LBA)


So can some one help me out? Floppy or HDD I don't care which one, as long as I get this fixed.

Thanks!
_________________
-- www.firemelt.net --
01000010 01101111 01110111 00100000 01100010 01100101 01100110 01101111 01110010 01100101 00100000 01001101 01100101 00100001
Cheer up, the worst is yet to come...


Last edited by Bob Leny on Tue Sep 12, 2006 8:19 pm; edited 3 times in total
Back to top
View user's profile Send private message
JugglingSuns120
n00b
n00b


Joined: 16 Oct 2005
Posts: 15

PostPosted: Tue Sep 12, 2006 4:15 pm    Post subject: Some grub.conf trouble Reply with quote

I am slightly confused here. I am still in the process of booting linux off an external drive on my laptop. After a bit of a strugle I managed to get grub installed on the drive and then proceded to boot it. When I installed grub from the knoppix disk it installed to what grub recognized as (hd1,0) so I assumed thats where the splashimage was. I set my splashimage to this location and also set root to /dev/sda3. These were the only lines i modified from my old grub.conf file. When I boot I get an error from grub that it cannot mount the partition nor does it find the splashimage. Any ideas on this one? here is my grub.conf

default 0
timeout 15
splashimage=(hd1,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux
root (hd0,0)
kernel /boot/kernel-2.6.13-gentoo-r7 root=/dev/sda3

any ideas?

AJ
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Tue Sep 12, 2006 4:32 pm    Post subject: Reply with quote

Hi.
Bob Leny wrote:
I need some help here if at all possible. I installed grub on hdb,5 and stupid me, doesnt load from hdb, it loads from hda. So I switched out the hard drives. You can the issue... (If not, now grub is looking in hdb,5, which doesn't exist...)

You should post the output of fdisk -l and say what disk is set to boot on the BIOS.
However, from your description, have you tried to boot with the live-cd, mount the partitions, chroot and do the following?
Code:
# grub
grub> root (hd1,4)
grub> setup (hd0)
grub> exit
#

Does it work?
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Tue Sep 12, 2006 5:05 pm    Post subject: Reply with quote

Hi.
JugglingSuns120 wrote:
I am slightly confused here. I am still in the process of booting linux off an external drive on my laptop. ... When I installed grub from the knoppix disk it installed to what grub recognized as (hd1,0) so I assumed thats where the splashimage was. I set my splashimage to this location and also set root to /dev/sda3.
Code:
splashimage=(hd1,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux
root (hd0,0)
kernel /boot/kernel-2.6.13-gentoo-r7 root=/dev/sda3


You should post the output of ifconfig -a and explain how many disks and what type you have on your system. I assume you have one IDE and an external USB.
Your /boot partition is used for both the splashimage and root (hdX,Y). Thus, they should point to the same partition. If you have an external disk, which I assume is an USB disk, have you set your BIOS to boot from USB? Does your BIOS support that?
You seem to need to tweak your install to have the kernel and grub use the same name for the disks. Boot with the live-cd, mount your partitions and chroot. Edit your /boot/grub/device.map and use the following:
Code:
(hd0) /dev/sda
(hd1) /dev/hda

Then setup GRUB into your MBR with
Code:
# grub
grub> root (hd0,0)
grub> setup (hd0)
grub> quit
#

Finally, use the following grub.conf.
Code:
default 0
timeout 15
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux
root (hd0,0)
kernel /boot/kernel-2.6.13-gentoo-r7 root=/dev/sda3


[edit]JugglingSuns120, I'm sorry but I was unable to post this complete response eariler. The forums wouldn't accept it and since I was at work, I hadn't the time to solve it. I've updated it now that I'm back at home.[/edit]
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh


Last edited by jmbsvicetto on Wed Sep 13, 2006 1:08 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2, 3 ... , 11, 12, 13  Next
Page 12 of 13

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum