Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GDM Login half off the screen! [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
n3bul4
Apprentice
Apprentice


Joined: 04 Nov 2003
Posts: 173

PostPosted: Thu Mar 15, 2007 10:49 am    Post subject: GDM Login half off the screen! [SOLVED] Reply with quote

Hello,

I have a strange problem here.
I updated to gnome-2.16 and after doing
a revdep-rebuild everything worked fine again,
except the login of GDM which has a resolution of
3840x1200 and not 1920x1200 as expected.
After login the resolution is fine (1920x1200).
Only the resolution of the login is too big.


Here my xorg.conf:

Code:

Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        Option          "AIGLX" "true"
EndSection

Section "Files"
        RgbPath      "/usr/share/X11/rgb"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/misc"
        FontPath     "/usr/share/fonts/75dpi"
        FontPath     "/usr/share/fonts/100dpi"
        FontPath     "/usr/share/fonts/TTF"
        FontPath     "/usr/share/fonts/Type1"
EndSection

Section "Module"
        Load  "glx"
        Load  "extmod"
        Load  "xtrap"
        Load  "record"
        Load  "dbe"
        Load  "dri"
        Load  "freetype"
        Load  "type1"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "CoreKeyboard"
        Option      "XkbRules" "xorg"
        Option      "XkbLayout" "de"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "ReducedBlanking"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
        VendorName  "ATI Technologies Inc"
        BoardName   "Radeon Mobility X700 (PCIE)"
        Option      "VideoOverlay" "on"
        Option      "DesktopSetup" "horizontal"
        Option      "UseFastTLS" "2"
        Option      "EnablePrivateBackZ" "on"
        Option      "UseInternalAGPGART" "no"
        BusID       "PCI:1:0:0"
        Option      "XAANoOffscreenPixmaps" "true"
        Option      "DRI"     "true"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes   "1920x1200"
        EndSubSection
EndSection

Section "DRI"
        Group        "video"
        Mode         0660
EndSection

Section "Extensions"
        Option      "XVideo" "Enable"
        Option      "Composite" "Enable"
EndSection


best regards...


Last edited by n3bul4 on Thu Mar 15, 2007 2:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
n3bul4
Apprentice
Apprentice


Joined: 04 Nov 2003
Posts: 173

PostPosted: Thu Mar 15, 2007 1:42 pm    Post subject: Reply with quote

I solved this by installing the latest kernel from kernel.org and compiling
it with dri support for ati etc.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum