Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Desperate to upgrade gcc or glibc! Help needed on x86!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
TrillianPrefect
n00b
n00b


Joined: 27 Apr 2005
Posts: 10
Location: The Netherlands

PostPosted: Fri Sep 01, 2006 8:57 pm    Post subject: Desperate to upgrade gcc or glibc! Help needed on x86! Reply with quote

Hi, I recently tried to upgrade my system, but it just didnt work. When upgrading glibc, I run into this annoying error and I don't know how to get rid of it.

To begin with the beginning:
1) emerge --sync
2) emerge -uavND world
3) looking at the list and saying yes
4) sad face when it stops at glibc.
5) looked at the gcc upgrade guide

My make.conf:
Code:

# FEATURES="cvs"

#CONFIG_PROTECT="/usr/share/cursors/xorg-x11/default"

CHOST="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -O3 -pipe"
#CFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"
#-funroll-loops -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
#ACCEPT_KEYWORDS="~x86"
#USE="-nls"
USE="cups aac aalib acpi bash-completion bidi bluetooth cdparanoia cdr cjk cracklib dv dvd dvdr dvdread fbcon font-server fontconfig gimp glx kaspersky kdeenablefinal lame logitech-mouse mmx msn nvidia matroska opera pcmcia pnp reiserfs rhythmbox speedo sse svg svga svgz usb video_cards_nv video_cards_nvidia vim wifi wma wmf wmv xcomposite xinerama xvid -apm -oss real theora dts live xanim win32codecs -nls gtk+ objc nptl nptlonly"


PORTAGE_NICENESS=15
CLEAN_DELAY="0"
GENTOO_MIRRORS="ftp.snt.utwente.nl/pub/os/linux/gentoo/"
FETCHCOMMAND="/usr/bin/wget -t 1 -T 5 \${URI} -P \${DISTDIR}"
RESUMECOMMAND="/usr/bin/wget -c -t 1 -T 5 \${URI} -P \${DISTDIR}"
#PORTAGE_RSYNC_RETRIES="2"
#PORTAGE_RSYNC_EXTRA_OPTS="20"
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_SYSTEM="mail"
PORTAGE_ELOG_MAILURI="lx.ford@gmail.com Ford"
PORT_LOGDIR=/var/log/portage

(I also think I messed something up with the PORTAGE_ELOG_MAILURI, can anybody tell me what that might be?)

The error I get:
Code:

checking version of makeinfo... 4.8, ok
checking for sed... sed
checking version of sed... 4.1.4, ok
checking for autoconf... autoconf
checking whether autoconf works... yes
configure: error:
*** These critical programs are missing or too old: gcc
*** Check the INSTALL file for required versions.

!!! ERROR: sys-libs/glibc-2.4-r3 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  glibc-2.4-r3.ebuild, line 1179:   Called toolchain-glibc_src_compile
  glibc-2.4-r3.ebuild, line 251:   Called glibc_do_configure 'nptl'
  glibc-2.4-r3.ebuild, line 941:   Called die

!!! failed to configure glibc
!!! If you need support, post the topmost build error, and the call stack if relevant.


Where am I supposed to find this INSTALL file?
Things I tried:
* fix_libtool_files.sh
* revdep-rebuild
* run around in circles and asked my bf to help (he said I should 'fix' it myself)
* browse @forums.gentoo (found nothing)
* tried a ACCEPT_KEYWORDS="~x86" emerge -uD gcc (this did not work, got the exact same errormsg.)


Gcc upgrade guide:
When I do a emerge -uav gcc, it doesnt't give my anything to emerge.
Running 'gcc -v' gave me the following:
Code:

Reading specs from /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/specs
Configured with: /var/tmp/portage/gcc-3.3.6/work/gcc-3.3.6/configure --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/3.3.6 --includedir=/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/include --datadir=/usr/share/gcc-data/i686-pc-linux-gnu/3.3.6 --mandir=/usr/share/gcc-data/i686-pc-linux-gnu/3.3.6/man --infodir=/usr/share/gcc-data/i686-pc-linux-gnu/3.3.6/info --with-gxx-include-dir=/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/include/g++-v3 --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --disable-altivec --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --disable-libunwind-exceptions --disable-multilib --disable-libgcj --enable-languages=c,c++,f77 --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
Thread model: posix
gcc version 3.3.6 (Gentoo 3.3.6, ssp-3.3.6-1.0, pie-8.7.8)



I need help. :?
Back to top
View user's profile Send private message
Kensai
Guru
Guru


Joined: 09 Mar 2004
Posts: 568
Location: Puerto Rico

PostPosted: Fri Sep 01, 2006 9:05 pm    Post subject: Reply with quote

Did you tried: (After you updated your post I realize you haven't so do:)
Code:
# gcc-config i686-pc-linux-gnu-4.1.1
# source /etc/profile

And then:
Code:
emerge -uavtDN world

TrillianPrefect wrote:
Things I tried:
* run around in circles and asked my bf to help (he said I should 'fix' it myself)

I would have said the same :lol:
_________________
Gentoo: Gigabyte: nFORCE 2: nVIDIA GeForce 6600: AMD Athlon XP 3200+
Perspective of a Thinking Human Being
Back to top
View user's profile Send private message
spielc
Guru
Guru


Joined: 20 Apr 2004
Posts: 452

PostPosted: Fri Sep 01, 2006 9:24 pm    Post subject: Reply with quote

Okey your post is a lil confusing (no offense):

If i'm correct your using gcc 3.3.6 (from the output of gcc -v)

could you please do the following?

Code:

eselect compiler list
emerge --info


if you are really using gcc-3.3.6 you are really outdated (and newer glibc-versions are known to need newer gcc versions to compile)

Furthermore you need nptl and nptlonly in your use-flags if you want to compile glibc-2.4[/profile]
Back to top
View user's profile Send private message
TrillianPrefect
n00b
n00b


Joined: 27 Apr 2005
Posts: 10
Location: The Netherlands

PostPosted: Sat Sep 02, 2006 10:11 am    Post subject: Reply with quote

omg, I feel like such a dweeb. :oops: Kensai, you were right, the only thing I had to do was the gcc-config i686-pc-linus-gnu-4.1.1 :oops:
I should read the howto's better.


spielc, I've got those flags in my make.conf. And eselect compiler list tells me:
error: can't load the module compiler
exiting.

But that really doesn't matter now (I think) since my laptop just emerged the world succesfully.

Thanks. :)
Back to top
View user's profile Send private message
Kensai
Guru
Guru


Joined: 09 Mar 2004
Posts: 568
Location: Puerto Rico

PostPosted: Sat Sep 02, 2006 3:56 pm    Post subject: Reply with quote

We tend to forget but the gentoo documentaion and bugzilla are our best friends. :wink:
_________________
Gentoo: Gigabyte: nFORCE 2: nVIDIA GeForce 6600: AMD Athlon XP 3200+
Perspective of a Thinking Human Being
Back to top
View user's profile Send private message
Nick C
Guru
Guru


Joined: 18 Mar 2005
Posts: 526
Location: Portsmouth, England

PostPosted: Sat Sep 02, 2006 4:08 pm    Post subject: Reply with quote

if eselect compiler fails, good old gcc-config -l (thats lower case L) will list the installed versions of gcc, then just do gcc-config <number> to swap between versions, just remember to do an env-update && source /etc/profile after each swap.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved.
www.monkeydust.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum