Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TIP] usare Flash 7 con ALSA
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3680
Location: London, UK

PostPosted: Sun Aug 20, 2006 2:49 am    Post subject: [TIP] usare Flash 7 con ALSA Reply with quote

Preso da http://ian.gowen.ath.cx/2006/08/16/use-flash-7-on-linux-with-alsa/

La cosa è di un banale sconcertante: se siete stanchi di dover riavviare firefox per ascoltarvi l'audio di un flash dopo aver usato un player audio basta lanciare
Code:
aoss firefox
al posto di
Code:
firefox


se poi vogliamo fare gli sboròni:
Code:
echo ‘alias firefox=”aoss firefox”‘ >> ~/.bash_profile

_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
gutter
Moderator
Moderator


Joined: 13 Mar 2004
Posts: 7160
Location: Aarau, Aargau, Switzerland

PostPosted: Sun Aug 20, 2006 9:43 am    Post subject: Reply with quote

Ottimo tip :)
_________________
Registered as User #281564 and Machines #163761
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Sun Aug 20, 2006 10:33 am    Post subject: Re: [TIP] usare Flash 7 con ALSA Reply with quote

Peach wrote:
La cosa è di un banale sconcertante: se siete stanchi di dover riavviare firefox per ascoltarvi l'audio di un flash dopo aver usato un player audio


Non ho capito le condizioni in cui si verifica il bug. da me mpd e flash convivono senza problemi, sia che suonino prima, dopo ma anche insieme :roll:
_________________
Ciao da me!
Back to top
View user's profile Send private message
gutter
Moderator
Moderator


Joined: 13 Mar 2004
Posts: 7160
Location: Aarau, Aargau, Switzerland

PostPosted: Sun Aug 20, 2006 1:13 pm    Post subject: Reply with quote

Io riscontro lo stesso problema :( .

Sostanzialmente quello che accade è che se avvio firefox e poi mpd (o xmms, o mplayer, ecc) e provo a fare play di un video in flash dopo aver stoppato mpd, non riesco a sentire l'audio.

Che versione di alsa hai? e che tipo di configurazione?
_________________
Registered as User #281564 and Machines #163761
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3680
Location: London, UK

PostPosted: Sun Aug 20, 2006 1:13 pm    Post subject: Re: [TIP] usare Flash 7 con ALSA Reply with quote

randomaze wrote:
Non ho capito le condizioni in cui si verifica il bug. da me mpd e flash convivono senza problemi, sia che suonino prima, dopo ma anche insieme :roll:

non ho mai usato mpd (o mi sfugge l'acronimo): io sia con xmms, audacious e mplayer/xine se li avvio prima e poi apro il browser per - ad esempio - vedere qualche filmato su youtube, nn sento nulla, l'unica soluzione è stoppare il player e riavviare firefox. Un bel pacco.
Flash 7 usa OSS, questo alla fine è il problema (aggiornati alla Macromedia/Adobe a quanto pare!!).
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
fabius
Guru
Guru


Joined: 29 Nov 2004
Posts: 525

PostPosted: Sun Aug 20, 2006 9:31 pm    Post subject: Reply with quote

Confermo il problema: grazie del tip :D
Back to top
View user's profile Send private message
fabius
Guru
Guru


Joined: 29 Nov 2004
Posts: 525

PostPosted: Mon Sep 04, 2006 7:01 pm    Post subject: Reply with quote

Dovrebbe esserci un fix nell'ultima release di mozilla-launcher (http://bugs.gentoo.org/show_bug.cgi?id=146108)
Back to top
View user's profile Send private message
Luca89
Advocate
Advocate


Joined: 27 Apr 2005
Posts: 2107
Location: Agrigento (Italy)

PostPosted: Tue Sep 12, 2006 3:03 pm    Post subject: Reply with quote

Anche io ho avuto lo stesso problema e ho risolto in quel modo, volevo aggiungere che l'eseguibile "aoss" io non l'avevo già installato e per ottenerlo ho dovuto installare questo pacchetto:

Code:
* media-libs/alsa-oss
     Available versions:  1.0.10-r1 1.0.11 ~1.0.12
     Installed:           1.0.11
     Homepage:            http://www.alsa-project.org/
     Description:         Advanced Linux Sound Architecture OSS compatibility layer.

_________________
Running Fast!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum