Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The Gentoo Framebuffer, Bootsplash & Grubsplash How-To
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 25, 26, 27  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
muaddib7
n00b
n00b


Joined: 02 Sep 2005
Posts: 21
Location: Athens, Greece

PostPosted: Mon Sep 05, 2005 1:30 am    Post subject: Reply with quote

I want to add myself to the line of posters who have the correct resolution set up but no framebuffer image background.

My kernel is a gentoo 2.6.12-r9 with splashutils 1.1.9.9-r1 and genkernel 3.3.5. The initramfs has to support LVM which it correctly does. The splash init script, when loaded, shows the framebuffer background properly. My grub.conf is

Code:
title=Gentoo Linux (2.6.11-gentoo-r9)
        root (hd0,0)
        kernel /kernel-genkernel-x86-2.6.12-gentoo-r9 dolvm2 udev root=/dev/ram0 real_root=/dev/main/root video=vesafb:ypan,ywrap,mtrr,1024x768-16@76 spash=silent,fadein,theme:livecd-2005.1 quiet CONSOLE=/dev/tty1
        initrd /initramfs-genkernel-x86-2.6.12-gentoo-r9


I use the vesafb-tng driver. The only thing I am wondering now is the inclusion of the splashimage=(hd0,0)/grub/splash.xpm.gz line.

What I am looking at now is whether the splash 'init' line in the init script in the initramfs does not fire up properly.

Any ideas?
Back to top
View user's profile Send private message
96140
Retired Dev
Retired Dev


Joined: 23 Jan 2005
Posts: 1324

PostPosted: Mon Sep 05, 2005 3:25 am    Post subject: Reply with quote

Make sure you have agpgart and vesafb-tng compiled into the kernel, NOT compiled as modules.

Oh, and the "splash=<whatever>" should be part of the kernel line, not its own line. And it should be "splash" not "spash"; check your spelling!
Back to top
View user's profile Send private message
rane
Retired Dev
Retired Dev


Joined: 03 Mar 2004
Posts: 306
Location: Warsaw, Poland

PostPosted: Mon Sep 05, 2005 11:14 am    Post subject: Reply with quote

Hi,

I talked with few people in GDP and we're willing to republish this guide as part of official Gentoo documentation (it's so popular that it clearly deserves that), but before that i'd like to contact you about few details like your cc-sa license approval and possible fixes suggestions. Your mail seems not working, how can we get contacted?
Back to top
View user's profile Send private message
muaddib7
n00b
n00b


Joined: 02 Sep 2005
Posts: 21
Location: Athens, Greece

PostPosted: Mon Sep 05, 2005 12:55 pm    Post subject: Reply with quote

nightmorph YOU ARE A SAVER

The quote goes: "If it doesn't work, plug it in the outlet" :P

I feel so dumb I want to create a lexical analyzer for the grub.conf so that I don't do the same mistake again.

Thanks again.
Back to top
View user's profile Send private message
96140
Retired Dev
Retired Dev


Joined: 23 Jan 2005
Posts: 1324

PostPosted: Tue Sep 06, 2005 5:11 am    Post subject: Reply with quote

muaddib7 wrote:
nightmorph YOU ARE A SAVER

The quote goes: "If it doesn't work, plug it in the outlet" :P

I feel so dumb I want to create a lexical analyzer for the grub.conf so that I don't do the same mistake again.

Thanks again.

Heheh, you're welcome. :D
Back to top
View user's profile Send private message
martindv
Apprentice
Apprentice


Joined: 16 Jul 2005
Posts: 171
Location: Argentina

PostPosted: Thu Sep 22, 2005 1:47 am    Post subject: Reply with quote

any cue about this?

Code:

Gentoo src # ls
linux  linux-2.6.12-gentoo-r10  pc  redhat
Gentoo src # bootsplash_patch /usr/src/linux-2.6.12-gentoo-r10/
 * Patching the kernel (branch: 2.6) in /usr/src/linux-2.6.12-gentoo-r10/ ...
Sorry, this kernel version is not supported.
Gentoo src #


it seems i cant use bootsplash with my kernel
_________________
Gentoo Rulez

AMD Athlon XP 2800+ @2.08Ghz
Asus A7V8NX-E-Deluxe
Nvidia Nforce2 chipset
1GB Ram
ASUS GeForce N6600 256MB RAM
2 IDE HDDS @Primary/Secondary Master
1 120GB HDD @Sata Channel #0
Back to top
View user's profile Send private message
muaddib7
n00b
n00b


Joined: 02 Sep 2005
Posts: 21
Location: Athens, Greece

PostPosted: Thu Sep 22, 2005 11:41 am    Post subject: Reply with quote

this version of the kernel has the required patches in it already
Back to top
View user's profile Send private message
martindv
Apprentice
Apprentice


Joined: 16 Jul 2005
Posts: 171
Location: Argentina

PostPosted: Fri Sep 23, 2005 3:19 am    Post subject: Reply with quote

I dont have in my kernel

Code:
  Bootsplash configuration  --->
         [*] Bootup splash screen


I only have
Code:
 Support for the framebuffer splash


when i try to patch it an error appears
Code:

Gentoo linux # ebuild /var/db/pkg/media-gfx/bootsplash-0.6.1-r7/bootsplash-0.6.1-r7.ebuild config
 * This ebuild does not have a config function.
Gentoo linux #                                       


Any Idea?
_________________
Gentoo Rulez

AMD Athlon XP 2800+ @2.08Ghz
Asus A7V8NX-E-Deluxe
Nvidia Nforce2 chipset
1GB Ram
ASUS GeForce N6600 256MB RAM
2 IDE HDDS @Primary/Secondary Master
1 120GB HDD @Sata Channel #0
Back to top
View user's profile Send private message
dreamer_
n00b
n00b


Joined: 27 Aug 2003
Posts: 46

PostPosted: Sat Oct 01, 2005 11:08 am    Post subject: Reply with quote

same problem here with the 2.6.12-gentoo-sources-r6.
Back to top
View user's profile Send private message
tommy04
n00b
n00b


Joined: 09 Sep 2005
Posts: 16

PostPosted: Sat Oct 01, 2005 2:31 pm    Post subject: Reply with quote

Same here. Running gentoo-sources-2.6.12-r10.
Back to top
View user's profile Send private message
96140
Retired Dev
Retired Dev


Joined: 23 Jan 2005
Posts: 1324

PostPosted: Sun Oct 02, 2005 5:14 am    Post subject: Reply with quote

Maybe you could try re-syncing and re-emerging with FEATURES="-strict"?

Besides, why would you want bootsplash? gensplash is much easier to get working, IME.
Back to top
View user's profile Send private message
martindv
Apprentice
Apprentice


Joined: 16 Jul 2005
Posts: 171
Location: Argentina

PostPosted: Mon Oct 03, 2005 1:31 am    Post subject: Reply with quote

i emerged splashutils instead of bootsplash and i could do it.

try the tutorial at wiki

http://gentoo-wiki.com/HOWTO_fbsplash

it worked for me...

good luck ;)
_________________
Gentoo Rulez

AMD Athlon XP 2800+ @2.08Ghz
Asus A7V8NX-E-Deluxe
Nvidia Nforce2 chipset
1GB Ram
ASUS GeForce N6600 256MB RAM
2 IDE HDDS @Primary/Secondary Master
1 120GB HDD @Sata Channel #0
Back to top
View user's profile Send private message
h_strickland
n00b
n00b


Joined: 18 Dec 2005
Posts: 2

PostPosted: Sun Dec 18, 2005 5:21 am    Post subject: Gentoo Screen resolution Reply with quote

The problem i have is getting the screen reslution working correctly when the external monitor is not pluged in.

When i unplug my external monitor and log back into gentoo, the screen goes all funny and i can only see a quarter of the screen. and the rest is blacked out.

I am new to gentoo and i am really worried that it is a major problem.

can anybody help me please
Back to top
View user's profile Send private message
homry
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2005
Posts: 146
Location: Karlsruhe, Germany

PostPosted: Sat Jan 14, 2006 9:16 pm    Post subject: Reply with quote

martindv wrote:
i emerged splashutils instead of bootsplash and i could do it.

try the tutorial at wiki

http://gentoo-wiki.com/HOWTO_fbsplash

it worked for me...

good luck ;)


i did that too and followed the how-to for configuration. but at booting i get following message (before the kernel gets extracted, i think):
Code:
Error: filename must be either absolute pathname or blocklist

it is something with the initrd. my grub.conf looks like this:
Code:
#
default 0
#
timeout 4
#
splashimage=(hd0,0)/grub/splash.xpm.gz

title=Gentoo Linux 2.6.13-r5-framebuffer
#
root (hd0,0)
kernel (hd0,0) /kernel-2.6.13-r5-framebuffer root=/dev/hda3 gentoo=nodevfs devfs=nomount video=vesafb:1400x1050-16@60,mtrr,ywrap splash=vebrose,fadein,theme:emergence quiet CONSOLE=/dev/tty1
initrd /boot/fbsplash-emergence-1024x768


/edit: made 2 stupid mistakes. but now the framebuffer works flawlessly, using the HOW-TO
homry
_________________
IBM ThinkPad R51
Back to top
View user's profile Send private message
valkyrite
Apprentice
Apprentice


Joined: 19 Sep 2002
Posts: 241

PostPosted: Tue May 30, 2006 6:59 pm    Post subject: Reply with quote

Hey,

I just performed a new install of gentoo linux (on a Dell inspiron 9300 laptop). Everything is cool and working fine.
Framebuffer is working flawlessly (I do not want bootsplash). I still do not have X installed.

My monitor supports the resolution: 1440x900

I am getting a default resolution of 1024x768

I have the following settings:

File: grub.conf
Code:

kernel /boot/bzImage root=/dev/sda3 video=vesafb:mtrr:3,ywrap,1440x900-16@60


I have enabled vesafb-tng option in the kernel and had followed the HowTo.

I also have enabled the default mouse (CONFIG_INPUT_MOUSEDEV_SCREEN_X/Y) of 1440x900 (though this is not an issue).

What should I do to get the 1440x900 resolution in the framebuffer mode.

Thanks for the excellent (and updated) HowTo.
Back to top
View user's profile Send private message
bypass
n00b
n00b


Joined: 22 Jul 2006
Posts: 7

PostPosted: Sat Jul 22, 2006 7:16 pm    Post subject: Reply with quote

hi, first post here, i have the bootsplash working, but i can't get the vesa-tng mode to work, when i boot i use 1024x768-16@85 but it always boots at 60 hz... i have an asus 6600gt, does anyone has this card and a higher refresh rate mode working??
thanks! :D
Back to top
View user's profile Send private message
bd_italy
Apprentice
Apprentice


Joined: 19 Apr 2006
Posts: 184

PostPosted: Tue Oct 10, 2006 4:16 pm    Post subject: Reply with quote

hi,
i have also a very strange problem with a bootsplash...
i described the problem in this thread:
http://forums.gentoo.org/viewtopic-t-505485.html
can anybody please have a look at it and give me some help?

regards from italy
bd_italy
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5252

PostPosted: Fri Jul 18, 2008 3:47 pm    Post subject: Buh-bye bootsplash? Reply with quote

Um... on my fresh install of 2008, there is no "bootsplash" to emerge...
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5252

PostPosted: Fri Jul 18, 2008 3:55 pm    Post subject: Reply with quote

Code:

kernel=(hd0,0)/boot/bzImage root=/dev/hda3 video=vesafb:ywrap,mtrr vga=0x31A


If that doesn't work and you're asked to select a valid mode, pick one, remember the code for it, and replace "31A" with that code (for example, 318 in place of 31A worked for me).
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Double Click
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2004
Posts: 148

PostPosted: Mon Mar 19, 2012 9:56 am    Post subject: Reply with quote

Is this guide still valid or are there now other ways to deal with this? Sorry about the direct question but have been away from the Gentoo scene for several years.
_________________
- To do a certain kind of thing, you have to be a certain kind of person
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 25, 26, 27
Page 27 of 27

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum