Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Programmi non compatibili con --as-need
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
comio
Advocate
Advocate


Joined: 03 Jul 2003
Posts: 2160
Location: Milano (Taranto di Origine)

PostPosted: Sat Jun 24, 2006 4:37 pm    Post subject: Programmi non compatibili con --as-need Reply with quote

Ecco l'elenco dei programmi non compatibili con l'opzione LDFLAGS "--as-need":
Code:

dev-lang/php-4.* USE=gd
media-video/vlc-0.8.5-r3
gnome-base/orbit-0.5.17-r1
nome-base/gnome-libs-1.4.2
media-libs/gdk-pixbuf-0.22.0-r5
sys-libs/db-*
<x11-libs/gtk+-1.2.10-r11
media-plugins/xmms-sndfile-1.2
media-libs/imlib-1.9.14-r3
app-mobilephone/obexftp-0.21


Sono riportate le versioni specifiche man mano che riscontro errori. Questa lista sarebbe utile per costruire una black list.

Quando scoprite un programma non compatibile con --as-need, postate pure: sarà mia cura inserire il programma nella lista di sopra.

Segnalo inoltre questo link (grazie !equilibrium) [Tracker] LDFLAGS="-Wl,--as-needed" support dove trovate una lista dei pacchetti non compatibili con --as-needed sempre aggiornata.


ciao

luigi
_________________
RTFM!!!!

e

http://www.comio.it
:)


Last edited by comio on Thu Aug 31, 2006 5:05 pm; edited 12 times in total
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4477
Location: In giro

PostPosted: Sat Jun 24, 2006 5:40 pm    Post subject: Reply with quote

Se vuoi ti do mano editando il tuo post con le aggiunte (se mi capita di vederle prima di te :) ) :wink:
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
comio
Advocate
Advocate


Joined: 03 Jul 2003
Posts: 2160
Location: Milano (Taranto di Origine)

PostPosted: Sat Jun 24, 2006 5:40 pm    Post subject: Reply with quote

Cazzantonio wrote:
Se vuoi ti do mano editando il tuo post con le aggiunte (se mi capita di vederle prima di te :) ) :wink:


Certo!

luigi
_________________
RTFM!!!!

e

http://www.comio.it
:)
Back to top
View user's profile Send private message
gutter
Moderator
Moderator


Joined: 13 Mar 2004
Posts: 7160
Location: Aarau, Aargau, Switzerland

PostPosted: Sun Jun 25, 2006 4:19 pm    Post subject: Reply with quote

PHP-4 in combinazione con la use gd.
_________________
Registered as User #281564 and Machines #163761
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4520
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Jun 26, 2006 7:30 pm    Post subject: Reply with quote

Immagino che questo lo conosciate già.
In ogni caso, mi pare che il topic debba necessariamente contenere un simile riferimento.

Tra l'altro, lì (ultima modifica, 23 aprile) si invita a segnalare a bugzilla tutte le eventuali failures, segno che è ormai iniziata l'era del supporto a -as--needed .
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Dr.Dran
l33t
l33t


Joined: 08 Oct 2004
Posts: 766
Location: Imola - Italy

PostPosted: Fri Jun 30, 2006 4:36 pm    Post subject: Reply with quote

Il supporto è iniziato da un pezzo da circa un annetto Flameyes testa il gcc 4.x con tale flag eh eh eh fra l'atro c'è l'homepage qui. Ciauz :D
_________________
:: [Dr.Dran] Details ::
- Linux User # 286282
- IT FreeLance Consultant
- President of ImoLUG [Imola & Faenza Linux User Group]
Back to top
View user's profile Send private message
comio
Advocate
Advocate


Joined: 03 Jul 2003
Posts: 2160
Location: Milano (Taranto di Origine)

PostPosted: Sat Jul 08, 2006 10:39 am    Post subject: Re: Programmi non compatibili con --as-need Reply with quote

comio wrote:
Ecco l'elenco dei programmi non compatibili con l'opzione LDFLAGS "--as-need":
Code:

dev-lang/php-4.* USE=gd
media-video/vlc-0.8.5-r3
gnome-base/orbit-0.5.17-r1
nome-base/gnome-libs-1.4.2
media-libs/gdk-pixbuf-0.22.0-r5


Sono riportate le versioni specifiche man mano che riscontro errori. Questa lista sarebbe utile per costruire una black list.

Quando scoprite un programma non compatibile con --as-need, postate pure: sarà mia cura inserire il programma nella lista di sopra.

ciao

luigi

_________________
RTFM!!!!

e

http://www.comio.it
:)
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Sat Jul 08, 2006 3:36 pm    Post subject: Reply with quote

sys-lib/db*
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4520
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Jul 09, 2006 8:51 am    Post subject: Reply with quote

!equilibrium wrote:
sys-lib/db*

sys-libs/db*

Questo pacchetto era già segnalato nel post che ho citato sopra.
Altri lo sono nella discussione che segue.
Vedi, per esempio, pixbuf.

Non capisco se esiste un motivo specifico per mantenere questa lista.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
comio
Advocate
Advocate


Joined: 03 Jul 2003
Posts: 2160
Location: Milano (Taranto di Origine)

PostPosted: Sun Jul 09, 2006 2:07 pm    Post subject: Reply with quote

cloc3 wrote:
!equilibrium wrote:
sys-lib/db*

sys-libs/db*

Questo pacchetto era già segnalato nel post che ho citato sopra.
Altri lo sono nella discussione che segue.
Vedi, per esempio, pixbuf.

Non capisco se esiste un motivo specifico per mantenere questa lista.


e che fondamentalmente non c'ho nulla da fare... eheh

ciao
_________________
RTFM!!!!

e

http://www.comio.it
:)
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4520
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Jul 09, 2006 6:45 pm    Post subject: Reply with quote

comio wrote:


e che fondamentalmente non c'ho nulla da fare... eheh

ciao

:lol: :lol: :lol:
se le cose stanno così, almeno aggiungi la s alle libs... e chiedi di spostare il topic nel forum di discussione 8)
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
gutter
Moderator
Moderator


Joined: 13 Mar 2004
Posts: 7160
Location: Aarau, Aargau, Switzerland

PostPosted: Mon Jul 10, 2006 6:48 am    Post subject: Reply with quote

cloc3 wrote:
e chiedi di spostare il topic nel forum di discussione 8)


Credo che qui non stia male :wink:
_________________
Registered as User #281564 and Machines #163761
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4520
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Jul 10, 2006 10:37 am    Post subject: Reply with quote

gutter wrote:
cloc3 wrote:
e chiedi di spostare il topic nel forum di discussione 8)


Credo che qui non stia male :wink:

era solo uno scherzo...
mi pareva che anche comio avesse un tono manifestamente faceto.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
topper_harley
Guru
Guru


Joined: 05 Apr 2006
Posts: 363
Location: Treviso / Udine (Italy)

PostPosted: Fri Aug 25, 2006 1:43 pm    Post subject: Reply with quote

Credo che ci si possa mettere anche questo:

media-libs/imlib-1.9.14-r3

A dire il vero il bug #133820 propone una patch, ma, almeno nel mio caso, non funziona.
_________________
http://topperh.ath.cx
Jabber: topper_harley@jabber.org
ICQ: 224179391
MSN: Topper_Harley80@gmail.com
Last FM
Back to top
View user's profile Send private message
topper_harley
Guru
Guru


Joined: 05 Apr 2006
Posts: 363
Location: Treviso / Udine (Italy)

PostPosted: Wed Aug 30, 2006 9:54 am    Post subject: Reply with quote

Eccone un'altra:
Code:
app-mobilephone/obexftp-0.21

_________________
http://topperh.ath.cx
Jabber: topper_harley@jabber.org
ICQ: 224179391
MSN: Topper_Harley80@gmail.com
Last FM
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Thu Aug 31, 2006 2:40 pm    Post subject: Reply with quote

qui trovate una lista dei pacchetti non compatibili con --as-needed sempre aggiornata, senza quindi bisogno di farne un secondo censimento ;)
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
topper_harley
Guru
Guru


Joined: 05 Apr 2006
Posts: 363
Location: Treviso / Udine (Italy)

PostPosted: Thu Aug 31, 2006 4:18 pm    Post subject: Reply with quote

!equilibrium wrote:
qui trovate una lista dei pacchetti non compatibili con --as-needed sempre aggiornata, senza quindi bisogno di farne un secondo censimento ;)

Questo pacchetto non sembra essere in quella lista:
Code:
x11-terms/multi-gnome-terminal-1.6.2-r1


Ma capitano tutti a me?
_________________
http://topperh.ath.cx
Jabber: topper_harley@jabber.org
ICQ: 224179391
MSN: Topper_Harley80@gmail.com
Last FM
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Thu Aug 31, 2006 4:28 pm    Post subject: Reply with quote

topper_harley wrote:
Ma capitano tutti a me?


segnalalo nel thread su bugzilla :wink:
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
topper_harley
Guru
Guru


Joined: 05 Apr 2006
Posts: 363
Location: Treviso / Udine (Italy)

PostPosted: Thu Aug 31, 2006 4:56 pm    Post subject: Reply with quote

!equilibrium wrote:

segnalalo nel thread su bugzilla :wink:


Vista la mia totale niubbaggine in materia (non ho mai segnalato un bug!) qualcuno ha voglia di fare un test per vedere che non sia un problema solo mio?

L'errore che ottengo con --as-needed è questo:
Code:
checking for X11/SM/SMlib.h... yes
checking for XpmFreeXpmImage in -lXpm... yes
checking for gnome-config... (cached) /usr/bin/gnome-config
checking for xmlNewDoc in -lxml... yes
checking for gtk-config... (cached) /usr/bin/gtk-config
checking for GTK - version >= 1.2.5... yes
checking for gnome_window_icon_set_default_from_file in -lgnomeui... no
configure: error: gnome-libs 1.0.59 or higher is required.

!!! ERROR: x11-terms/multi-gnome-terminal-1.6.2-r1 failed.
Call stack:
  ebuild.sh, line 1543:   Called dyn_compile
  ebuild.sh, line 938:   Called src_compile
  multi-gnome-terminal-1.6.2-r1.ebuild, line 49:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.


_________________
http://topperh.ath.cx
Jabber: topper_harley@jabber.org
ICQ: 224179391
MSN: Topper_Harley80@gmail.com
Last FM
Back to top
View user's profile Send private message
drizztbsd
Retired Dev
Retired Dev


Joined: 21 Nov 2004
Posts: 278
Location: Cesano Maderno

PostPosted: Thu Aug 31, 2006 9:53 pm    Post subject: Reply with quote

Tutti i pacchetti che usano gtk.m4 non funzionano.
Ma basta mettere --disable-gtktest in econf e partono miracolosamente
_________________
Gentoo/Alt lead
Gentoo/*BSD and Gentoo/FreeBSD deputy lead
Paludis contributor
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum