Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kuvat korruptoituu osittain levyltä toiselle kopioitessa
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
Kidov
n00b
n00b


Joined: 20 Jul 2006
Posts: 55
Location: Finland

PostPosted: Sun Aug 13, 2006 11:44 am    Post subject: kuvat korruptoituu osittain levyltä toiselle kopioitessa Reply with quote

Yritän tässä siirtää graafisesti KDE:ssä konquerilla toiselta sata levyltä toiselle suunnilleen 160 gigaa tavaraa. Kaikki kyllä kopioituu, mutta ainakin JPEG kuville käy jotain outoa: Kuvan yläosa saattaa olla alareunassa ja alareuna ylhäällä; joissakin kuvissa jokin värisävy saattaa vallatta koko kuvan, jne...

Alkuun luulin, että ongelma voisi johtua siitä, että uusi levyni on reiserfs formaatissa. Alustin sen sitten käyttämään ext3 tiedostojärjestelmää, muttei se näköjään vaikuttanut mihinkään.

Vielä vertailtuani alkuperäisen kuvan ja rikkinäisen kopioidun kuvan tiedostokokoja, ei niissä näyttäisi olevan eroja. Yhtä monta bittiä kummassakin.

(MP3 ja divx tiedostot vaikttaisivat kopioituvan oikein - tai ainakin toimivat normaalisti.)

Tässä linkki muutamaan esimerkkiin:
www.personal.inet.fi/koti/halsopetter
(esimerkeissä tiedostokoko ei täsmää, koska ovat uudelleen pakattuja)

(en ole vielä koittanut kopiointia ilman KDE:n päällä oloa, enkä koitakaan ennen kuin ongelma on vähän seljinnyt)
(ongelma ei näyttäisi toistuvan, jos kopio vain kuvakansion kerrallaan - eikä kerralla koko levyn sisältöä.)
(Koko järjestelmä on stable haarassa ja päivittäin päivitetty.)
Back to top
View user's profile Send private message
tuuletin
n00b
n00b


Joined: 05 Feb 2006
Posts: 22

PostPosted: Sat Aug 19, 2006 2:50 pm    Post subject: Reply with quote

Kai olet ajanut emerge --sync ennen päivittämistä?

Kokeile komentotulkissa cp (KOPIOITAVIENKUVIEN KANSIO/*) (TÄNNE KOPIOIDAAN), korruptoituuko kuvat?
Back to top
View user's profile Send private message
Kidov
n00b
n00b


Joined: 20 Jul 2006
Posts: 55
Location: Finland

PostPosted: Sun Aug 20, 2006 9:05 am    Post subject: Reply with quote

kyllä, emerge --sync tuli tutuksi jo gentoon asennuksen yhteydessä...

Kokeilin kde:n konsolilla:
cp -ax /olddisk/* /newdisk/
koko levyä kloonata. Sama ongelma edelleen. Täytyy kokeille gentoon live cd:llä - jospa sillä homma toimisi.

Kokeilin nyt 2005 mallin Gentoon Lilve cd:llä, mutta ongelma säilyy. Mielenkiintoista, että ongelma vaikuttaisi koskevan vain kuvia. Mediatiedostot edelleen vaikuttaisivat toimivan aivan normaalisti.
Back to top
View user's profile Send private message
Obi-Lan
Apprentice
Apprentice


Joined: 21 Jan 2005
Posts: 230
Location: Riihimäki

PostPosted: Sun Aug 20, 2006 1:06 pm    Post subject: Reply with quote

Minkälainen kovalevysetuppi sulla on? Kaverilla oli joku nvidian piirisarjalla oleva emo ja pci väyläinen sata-ohjain kortti, tämä yhdistelmä korruptoi kovalevyn sisällön tunnissa riippumatta mitä käyttöjärjestelmää ajoi. Tämä oli ilmeisesti bugi emolevyn biosissa tjsp.
Back to top
View user's profile Send private message
Kidov
n00b
n00b


Joined: 20 Jul 2006
Posts: 55
Location: Finland

PostPosted: Sun Aug 20, 2006 4:39 pm    Post subject: Reply with quote

Abit NF7-S nvidia nforce 2 piirisarjalla.

Gentoo on asennettuna tavalliselle ide-levylle, (80gb) koska sata-piirisarjan ajurit eivät jostain syystä suostu toimimaan buutissa. Tämän lisäksi käytössäni on jo pitkään ollut 200gb sata-levy, eikä ongelmia silloin ilmennyt. Tosin kaikki kuvani olivat alusta alkaen tällä sata-levyllä.

Äskettäin kuitenkin ostin vielä yhden (320gb) sata-levyn lisää ja nyt ongelmat alkavatkin. Satalevyltä toiselle kopiointi ei näytä onnistuvan. En tiedä toimisiko sitten pata-levyltä. Mielenkiintoiseksi ongelman tekee, että ongelma vaikuttaisi koskevan vain kuvia.


Ja jos sillä on merkitystä, kaikki levyt ovat Seagate Barrucuda IV levyjä.
Back to top
View user's profile Send private message
Paapaa
l33t
l33t


Joined: 14 Aug 2005
Posts: 955
Location: Finland

PostPosted: Tue Aug 22, 2006 9:47 am    Post subject: Reply with quote

Hetkinen, onko Barracude IV:tä 320GB:n kokoisena? Vai onko uusin levy 7200.10? Mitä kertoo komento "dmesg" eli löytyykö aiheeseen liittyviä virheitä - ennen kopiointia ja sen jälkeen? Korrputoituuko kuvat yksitelleen kopioituna? Onko sinulla jokin seuraavista kiintolevyistä:

http://www.leenooks.com/Silicon+Image+311x+sata+controllers+and+some+Seagate+disks
Back to top
View user's profile Send private message
Kidov
n00b
n00b


Joined: 20 Jul 2006
Posts: 55
Location: Finland

PostPosted: Tue Aug 22, 2006 1:53 pm    Post subject: Reply with quote

Tosiaan, se uusin levy olikin Seagate Barracuda 7200.10 320GB Serial-ATA-II.

Ja sata piirisarja on Silicon Image, Inc. SiI 3112 [SATALink/SATARaid] Serial ATA Controller (rev 02)

Elikkä taitaapi sitten johtua tästä kokoonpanosta...

Kunhan ehdin kokeilla kopioimista uudestaan, katson mitä "dmesg" kertoo.
Back to top
View user's profile Send private message
micko
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2004
Posts: 117
Location: Finland / Turku

PostPosted: Tue Aug 22, 2006 3:01 pm    Post subject: Reply with quote

Onkohan muistit ehjät?
Back to top
View user's profile Send private message
Kidov
n00b
n00b


Joined: 20 Jul 2006
Posts: 55
Location: Finland

PostPosted: Tue Aug 22, 2006 4:17 pm    Post subject: Reply with quote

Testaan muistit ens yönä. Epäilisin kyllä, ettei niistä johdu, koska aikaisemmin ongelmia ei kuitenkaan ole ollut.

Edit:
Ajelin viime yön memtest86 ohjelmaa - virheittä.
Back to top
View user's profile Send private message
Obi-Lan
Apprentice
Apprentice


Joined: 21 Jan 2005
Posts: 230
Location: Riihimäki

PostPosted: Wed Aug 23, 2006 8:39 pm    Post subject: Reply with quote

Joo kaverilla oli kans nforce2 lankku ja pci-väyläinen sataohjain. Sillä tosin _kaikki_ data korruptoitui...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum