Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200608-18 ] Net::Server: Format string vulnerability
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Thu Aug 10, 2006 8:26 pm    Post subject: [ GLSA 200608-18 ] Net::Server: Format string vulnerability Reply with quote

Gentoo Linux Security Advisory

Title: Net::Server: Format string vulnerability (GLSA 200608-18)
Severity: normal
Exploitable: remote
Date: August 10, 2006
Bug(s): #142386
ID: 200608-18

Synopsis

A format string vulnerability has been reported in Net::Server which can be exploited to cause a Denial of Service.

Background

Net::Server is an extensible, generic Perl server engine. It is used by several Perl applications like Postgrey.

Affected Packages

Package: dev-perl/net-server
Vulnerable: < 0.88
Unaffected: >= 0.88
Architectures: All supported architectures


Description

The log function of Net::Server does not handle format string specifiers properly before they are sent to syslog.

Impact

By sending a specially crafted datastream to an application using Net::Server, an attacker could cause a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All Net::Server should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-perl/net-server-0.88"


References

CVE-2005-1127
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum