Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200608-07 ] libTIFF: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Sat Aug 05, 2006 12:26 am    Post subject: [ GLSA 200608-07 ] libTIFF: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: libTIFF: Multiple vulnerabilities (GLSA 200608-07)
Severity: normal
Exploitable: remote
Date: August 04, 2006
Bug(s): #142383
ID: 200608-07

Synopsis

libTIFF contains several vulnerabilities that could result in arbitrary code execution.

Background

libTIFF provides support for reading and manipulating TIFF images.

Affected Packages

Package: media-libs/tiff
Vulnerable: < 3.8.2-r2
Unaffected: >= 3.8.2-r2
Architectures: All supported architectures


Description

Tavis Ormandy of the Google Security Team discovered several heap and stack buffer overflows and other flaws in libTIFF. The affected parts include the TIFFFetchShortPair(), TIFFScanLineSize() and EstimateStripByteCounts() functions, and the PixarLog and NeXT RLE decoders.

Impact

A remote attacker could entice a user to open a specially crafted TIFF file, resulting in the possible execution of arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All libTIFF users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/tiff-3.8.2-r2"


References

CVE-2006-3459
CVE-2006-3460
CVE-2006-3461
CVE-2006-3462
CVE-2006-3463
CVE-2006-3464
CVE-2006-3465
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum