Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
AMD64 system slow/unresponsive during disk access...
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 21, 22, 23 ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
piwacet
Guru
Guru


Joined: 30 Dec 2004
Posts: 486

PostPosted: Thu Sep 06, 2007 5:18 am    Post subject: Reply with quote

Hmm, apologize, but could use a little help here:

Code:
Nautilus magenta # dd if=/dev/zero of=a bs=1024k count=4096
4096+0 records in
4096+0 records out
4294967296 bytes (4.3 GB) copied, 47.9211 s, 89.6 MB/s
Nautilus magenta # dd if=/dev/urandom of=b bs=512 count=2048
2048+0 records in
2048+0 records out
1048576 bytes (1.0 MB) copied, 0.219783 s, 4.8 MB/s
Nautilus magenta # dd if=/dev/urandom of=b bs=512 count=1 seek=9400k
1+0 records in
1+0 records out
512 bytes (512 B) copied, 0.00025862 s, 2.0 MB/s
Nautilus magenta # losetup /dev/loop7 b
Nautilus magenta # cryptsetup luksFormat /dev/loop7

WARNING!
========
This will overwrite data on /dev/loop7 irrevocably.

Are you sure? (Type uppercase yes): YES
Enter LUKS passphrase:
Verify passphrase:
Failed to setup dm-crypt key mapping.
Check kernel for support for the aes-cbc-essiv:sha256 cipher spec and verify that /dev/loop7 contains at least 133 sectors.
Failed to write to key storage.
Command failed.


Code:
Nautilus linux # cat .config | grep CBC
# CONFIG_CRYPTO_XCBC is not set
CONFIG_CRYPTO_CBC=y
CONFIG_CRYPTO_PCBC=m
Nautilus linux # cat .config | grep AES
CONFIG_CRYPTO_AES=m
CONFIG_CRYPTO_AES_X86_64=m
Nautilus linux # cat .config | grep SHA
# CONFIG_IDEPCI_SHARE_IRQ is not set
# CONFIG_SHAPER is not set
CONFIG_CRYPTO_SHA1=y
CONFIG_CRYPTO_SHA256=m
# CONFIG_CRYPTO_SHA512 is not set
Nautilus linux #
Back to top
View user's profile Send private message
likewhoa
l33t
l33t


Joined: 04 Oct 2006
Posts: 740
Location: Brooklyn, New York

PostPosted: Thu Sep 06, 2007 5:27 am    Post subject: Reply with quote

is the aes_x86_64,cbc & sha256 modules loaded? also make sure you have CONFIG_DM_CRYPT enabled.
Back to top
View user's profile Send private message
piwacet
Guru
Guru


Joined: 30 Dec 2004
Posts: 486

PostPosted: Thu Sep 06, 2007 6:01 am    Post subject: Reply with quote

Alright, got farther but now this:

Code:
Nautilus magenta # mkisofs -allow-leading-dots -joliet-long -iso-level 3 -l -J -r a | dd of=/dev/mapper/b bs=512
Warning: creating filesystem that does not conform to ISO-9660.
mkisofs: Value too large for defined data type. File a is too large - ignoring
Total translation table size: 0
Total rockridge attributes bytes: 185
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 21000
181 extents written (0 MB)
724+0 records in
724+0 records out
370688 bytes (371 kB) copied, 0.0153153 s, 24.2 MB/s
Back to top
View user's profile Send private message
likewhoa
l33t
l33t


Joined: 04 Oct 2006
Posts: 740
Location: Brooklyn, New York

PostPosted: Thu Sep 06, 2007 6:22 am    Post subject: Reply with quote

did you delete the loop device and start the commands over? if not do that..
use

Code:
cryptsetup luksClose b && losetup -d /dev/loop7
Back to top
View user's profile Send private message
piwacet
Guru
Guru


Joined: 30 Dec 2004
Posts: 486

PostPosted: Fri Sep 07, 2007 4:01 am    Post subject: Reply with quote

Hmmm, did all of the above (actually rebooted, deleted files a and b, and did that command) and started from scratch repeating instructions, same error:

Code:
Nautilus magenta # mkisofs -allow-leading-dots -joliet-long -iso-level 3 -l -J -r a | dd of=/dev/mapper/b bs=512
Warning: creating filesystem that does not conform to ISO-9660.
mkisofs: Value too large for defined data type. File a is too large - ignoring
Total translation table size: 0
Total rockridge attributes bytes: 185
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 21000
181 extents written (0 MB)
724+0 records in
724+0 records out
370688 bytes (371 kB) copied, 0.103037 s, 3.6 MB/s
Back to top
View user's profile Send private message
likewhoa
l33t
l33t


Joined: 04 Oct 2006
Posts: 740
Location: Brooklyn, New York

PostPosted: Fri Sep 07, 2007 6:11 am    Post subject: Reply with quote

what cdrtools version are you running?
Back to top
View user's profile Send private message
piwacet
Guru
Guru


Joined: 30 Dec 2004
Posts: 486

PostPosted: Fri Sep 07, 2007 8:41 am    Post subject: Reply with quote

Here it is:

Code:
Nautilus magenta # emerge -pv cdrtools

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] app-cdr/cdrtools-2.01.01_alpha25  USE="unicode" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Back to top
View user's profile Send private message
likewhoa
l33t
l33t


Joined: 04 Oct 2006
Posts: 740
Location: Brooklyn, New York

PostPosted: Fri Sep 07, 2007 9:46 pm    Post subject: Reply with quote

piwacet wrote:
Here it is:

Code:
Nautilus magenta # emerge -pv cdrtools

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] app-cdr/cdrtools-2.01.01_alpha25  USE="unicode" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


I'm using alpha34, can you try to reproduce with that version?
Back to top
View user's profile Send private message
likewhoa
l33t
l33t


Joined: 04 Oct 2006
Posts: 740
Location: Brooklyn, New York

PostPosted: Fri Sep 14, 2007 7:35 pm    Post subject: Reply with quote

UPDATE!!! on SCHEDULER!!

http://linux.slashdot.org/article.pl?sid=07/09/14/156234

2.6.23 here we come!!! :)
Back to top
View user's profile Send private message
trilexx
Apprentice
Apprentice


Joined: 19 Jul 2004
Posts: 217
Location: Austria

PostPosted: Sat Sep 15, 2007 4:07 pm    Post subject: Reply with quote

hey there,

I have this problem too. my system specs are:

AMD Turion X2 2 Ghz, 32 Bit/x86
1024 MB RAM
Seagate Momentus 7200.2 SATA II 160 GB disk, ext3
2.6.22-r6
CONFIG_IDE, not selected

whenever there is IO the system becomes sluggish. After booting the system is usable for some time until the the RAM is filled up and the system starts swapping. This is the case even when only browsing the web using firefox and having Evolution running to read mails. If I do a "emerge -pv world", it takes more than 10 seconds to open another terminal or 5 sec to get a new firefox tab. Starting firefox takes ages like > 20 seconds. This is my main machine, which I use to program and develop. It's a pain to program at the moment, as it takes ages to compile, debug etc...
I have no clue what to do about it as I'm running a 32 Bit environment and already tried most of the suggestions...

trilexx
_________________
if it lives, compile it :D
Back to top
View user's profile Send private message
darklegion
Guru
Guru


Joined: 14 Nov 2004
Posts: 466

PostPosted: Sun Sep 16, 2007 1:38 am    Post subject: Reply with quote

Checkout the bdi-v9 per device dirty throttling patch in this thread on the LKML : http://www.gossamer-threads.com/lists/linux/kernel/810835?search_string=dirty%20throttling%20v9;#810835
This version of the patch is a backport to 2.6.22 but there is also a later version that applies against a 2.6.23 kernel, if you want to try it.
You might need to fix a few rejects if you are using 2.6.22.5 or later.I know I had to fix a couple of lines to get it to apply against 2.6.22-kamikaze7 but it's just simple copy and paste, really.

This reduces the problem significantly on my system (although not completely).

EDIT: Here's another patch, which is for lowering dirty_ratio to less than 5%:
http://www.gossamer-threads.com/lists/linux/kernel/816895?search_string=small%20patch%20dirty%20throttling;#816895
I haven't applied it myself yet, but it may reduce the problem even more (could cause other problems, though) .After applying the patch, and booting up, do this:
Code:
 echo 2 > /proc/sys/vm/dirty_ratio

This will set dirty_ratio to 2%.
Back to top
View user's profile Send private message
neuron
Advocate
Advocate


Joined: 28 May 2002
Posts: 2371

PostPosted: Sun Sep 16, 2007 9:12 am    Post subject: Reply with quote

darklegion wrote:
Checkout the bdi-v9 per device dirty throttling patch in this thread on the LKML : http://www.gossamer-threads.com/lists/linux/kernel/810835?search_string=dirty%20throttling%20v9;#810835
This version of the patch is a backport to 2.6.22 but there is also a later version that applies against a 2.6.23 kernel, if you want to try it.
You might need to fix a few rejects if you are using 2.6.22.5 or later.I know I had to fix a couple of lines to get it to apply against 2.6.22-kamikaze7 but it's just simple copy and paste, really.

This reduces the problem significantly on my system (although not completely).


Dont know why.. but that patch doesn't apply at all for me. Hunk failed on damn near everything. And I just tried it against 2.6.22.5, so it should apply cleanly. Has anyone tried applying that patch against vanilla sources? I'm wondering if that site is filling in some whitespace or something, because I see no reason why that patch would fail so badly..

//edit, wasn't expecting windows line endings, should have thought of that one.


Last edited by neuron on Sun Sep 16, 2007 2:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
trilexx
Apprentice
Apprentice


Joined: 19 Jul 2004
Posts: 217
Location: Austria

PostPosted: Sun Sep 16, 2007 11:33 am    Post subject: Reply with quote

So... I found out that not setting
Code:
CONFIG_IDE
and using
Code:
pataatiixp
instead for my dvd drive actually solved my problem. I have no problems to sync and switch between workspaces or applications now. My notebook is now as responsive as my desktop computer :)
However, yesterday I posted that the problem still persists. It turned out that it has been beagle that ate all my RAM. Thats why my system at first has been responsive and usable until the beagled started to take over :) I could watch the daemon grabbing 600 MB of RAM and 500 MB of Virtual memory. The system did not respond anymore and I had to do a hard reset. So to summarize: Disabling CONFIG_IDE did it for me. Try it! But you better keep your hands off beagle.
_________________
if it lives, compile it :D
Back to top
View user's profile Send private message
koz
n00b
n00b


Joined: 06 Dec 2002
Posts: 27

PostPosted: Thu Sep 20, 2007 4:46 am    Post subject: Reply with quote

Quote:
So... I found out that not setting
Code:

CONFIG_IDE

and using
Code:

pataatiixp

instead for my dvd drive actually solved my problem. I have no problems to sync and switch between workspaces or applications now. My notebook is now as responsive as my desktop computer :)


I just upgraded to AMD Athalon x2 4400 with an ASUS M2A-VM and had horrible performance copying over files from my IDE drives to the SATA drive. I stumbled on this thread, and tried trilexx's advice. Disk copy speeds are much more reasonable (~20-30 MB/sec compared to 1-2 MB/sec copying from IDE to SATA). I'm using the Gentoo 2.6.22-r5 kernel on a 64 bit install.

Thanks for the tip!
Back to top
View user's profile Send private message
Konsti
l33t
l33t


Joined: 10 Dec 2002
Posts: 691

PostPosted: Fri Sep 28, 2007 7:58 am    Post subject: Reply with quote

Hi Folks!

I just wanted to ask, if there are any results on how to fix this problem are going to be evolved under the hood or in the afore mentioned kernel bug report mail threads, which links' I don't find anymore here. I always watched this thread as I had the strange feeling my AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ feels far to sluggish than I expected. It is not the case that it stalls completely but it remembers me to days not havin DMA disc access enabled. No I gave my girlfriend my old computer, an AMD Athlon(tm) 64 Processor 3000+ and after a couple of minutes she pointed out (not nowing if mine or the other PC _should_ be faster) that now her PC was much faster in desktop experience. What a mess :)
_________________
konsti@jabber.org
Back to top
View user's profile Send private message
Tortillamann
n00b
n00b


Joined: 21 Oct 2007
Posts: 2

PostPosted: Sun Oct 21, 2007 8:26 pm    Post subject: Reply with quote

Hello,
I had this problem on two systems:
AMD Athlon 1200 with ASUS-board, 1gig RAM
INTEL P4 1600 with RAMBUS 512MB RAM

It occured with different kernels, but first with an early 2.6 one. 2.4 kernels worked without any "lagging". I didn't care about it because I often change configuration and do much experimenting on both systems. I just thougt it is my fault because I didn't set up my system properly. Now I noticed this "bug" with completely new systems as well. I did some investigation and got this thread as result...
I tried different things, nothing helped. Then I upgraded to kernel 2.6.22-gentoo-r8 and my problems are gone! I assume it could also be a problem with the timer frequency-stuff (I chose 1000MHz now) and the "low latency desktop"-settings, but I didn't figure it out.
So, just try the new kernel version and give us as feedback about the results!

cheers
Tortillamann
Back to top
View user's profile Send private message
SnEptUne
l33t
l33t


Joined: 23 Aug 2004
Posts: 651

PostPosted: Mon Oct 22, 2007 2:13 am    Post subject: Reply with quote

Tortillamann wrote:
Hello,
I had this problem on two systems:
AMD Athlon 1200 with ASUS-board, 1gig RAM
INTEL P4 1600 with RAMBUS 512MB RAM

It occured with different kernels, but first with an early 2.6 one. 2.4 kernels worked without any "lagging". I didn't care about it because I often change configuration and do much experimenting on both systems. I just thougt it is my fault because I didn't set up my system properly. Now I noticed this "bug" with completely new systems as well. I did some investigation and got this thread as result...
I tried different things, nothing helped. Then I upgraded to kernel 2.6.22-gentoo-r8 and my problems are gone! I assume it could also be a problem with the timer frequency-stuff (I chose 1000MHz now) and the "low latency desktop"-settings, but I didn't figure it out.
So, just try the new kernel version and give us as feedback about the results!

cheers
Tortillamann

Isn't kernel 2.6.22 tickless?
_________________
"There will be more joy in heaven over the tear-bathed face of a repentant sinner than over the white robes of a hundred just men." (LM, 114)
Back to top
View user's profile Send private message
neuron
Advocate
Advocate


Joined: 28 May 2002
Posts: 2371

PostPosted: Mon Oct 22, 2007 4:22 am    Post subject: Reply with quote

SnEptUne wrote:
Tortillamann wrote:
Hello,
I had this problem on two systems:
AMD Athlon 1200 with ASUS-board, 1gig RAM
INTEL P4 1600 with RAMBUS 512MB RAM

It occured with different kernels, but first with an early 2.6 one. 2.4 kernels worked without any "lagging". I didn't care about it because I often change configuration and do much experimenting on both systems. I just thougt it is my fault because I didn't set up my system properly. Now I noticed this "bug" with completely new systems as well. I did some investigation and got this thread as result...
I tried different things, nothing helped. Then I upgraded to kernel 2.6.22-gentoo-r8 and my problems are gone! I assume it could also be a problem with the timer frequency-stuff (I chose 1000MHz now) and the "low latency desktop"-settings, but I didn't figure it out.
So, just try the new kernel version and give us as feedback about the results!

cheers
Tortillamann

Isn't kernel 2.6.22 tickless?


Not on 64bit
Back to top
View user's profile Send private message
Tortillamann
n00b
n00b


Joined: 21 Oct 2007
Posts: 2

PostPosted: Wed Oct 24, 2007 10:12 pm    Post subject: 32 bit system Reply with quote

Hello,
I'm not using 64bit systems. All my computers are 32bit.
What means "tickless"??? I don't have lagging and that's what I wanted :-)

cheers
Tortillamann
Back to top
View user's profile Send private message
3pm
n00b
n00b


Joined: 03 Nov 2004
Posts: 64

PostPosted: Fri Nov 02, 2007 6:01 pm    Post subject: Reply with quote

I can confirm. When upgraded to 2.6.22-r9 - problem is gone.
BUT. I want ,to use xen for which the latest is 2.6.20-r6. And it realy sucks.
By the way CentOS5 with 2.8.18 xen kernel performs well on the same hardware.
It seems to me say bye for Gentoo for xen or use Centos kernel, inird and modules what is weird.
Back to top
View user's profile Send private message
edf825
n00b
n00b


Joined: 09 Nov 2007
Posts: 3

PostPosted: Fri Nov 09, 2007 8:11 am    Post subject: Reply with quote

Hi, just another 'me too.' I have this problem on all three of my (completely different) boxen - a PIII, an Athlon XP, and a Via C3 - all IDE, same kernel 2.6.23 with preempt (I tried with preempt off, but that made no difference). On the Athlon box, I had 2.6.22-ck1 going without a hitch before, same exact config.
Back to top
View user's profile Send private message
likewhoa
l33t
l33t


Joined: 04 Oct 2006
Posts: 740
Location: Brooklyn, New York

PostPosted: Fri Nov 09, 2007 7:25 pm    Post subject: Reply with quote

try various io schedulers.
Back to top
View user's profile Send private message
edf825
n00b
n00b


Joined: 09 Nov 2007
Posts: 3

PostPosted: Sat Nov 10, 2007 4:17 am    Post subject: Reply with quote

The CFQ scheduler appears to have made it somewhat better, but it still lags quite a bit.
Back to top
View user's profile Send private message
edf825
n00b
n00b


Joined: 09 Nov 2007
Posts: 3

PostPosted: Wed Nov 14, 2007 3:53 am    Post subject: Reply with quote

Well, my Via system is fixed; I haven't tried my other ones yet.

I just went through my kernel, changing things to values that made more sense, mostly in the Processor Type and Features section. (e.g. Multi-core scheduler was enabled when I have only one proc/core)

Also, I found that the driver for my IDE chipset weren't actually in the kernel (Device Drivers => ATA/ATAPI/MFM/RLL support => Generic PCI bus-master DMA support => ...) so I enabled it. :oops:

I don't know which helped it, but now I get absolutely no noticeable lag on disk i/o. :D

Edit: Works great on all my boxen! Strip down them kernels like you've never stripped before! (and, uh, add a bit of weight where necessary too :wink:)
Back to top
View user's profile Send private message
JuNix
Apprentice
Apprentice


Joined: 05 Mar 2003
Posts: 204
Location: Sheffield

PostPosted: Mon Nov 19, 2007 3:04 pm    Post subject: Reply with quote

Hmmm! I took the plunge into 2.6.23 today. I didn't go with gentoo-sources, instead I chose to compile a custom kernel based on vanilla 2.6.23 with the tickless idle patch from http://www.kernel.org/pub/linux/kernel/people/tglx/hrtimers/ (because tickless idle is not available for AMD64 without this patch, yet)

I must say the new CFS CPU scheduler with the CFQ IO Scheduler is extremely responsive. I can't reproduce the previous problems at all.

Linux flatline 2.6.23-hrt3 #1 PREEMPT Sun Nov 18 16:51:18 GMT 2007 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux

:D
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Goto page Previous  1, 2, 3 ... 21, 22, 23 ... 36, 37, 38  Next
Page 22 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum