Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XFree anti-aliased font tips
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
sqldr
n00b
n00b


Joined: 13 Nov 2002
Posts: 1

PostPosted: Wed Nov 13, 2002 10:41 pm    Post subject: segmentation fault! Reply with quote

Hi,

I'm new to gentoo, and I'm baffled..

whenever I try to run "xterm -fa '<some font>'" I get a segfault. Never had this problem with debian.

I'm running xfree 4.2.1, I have the "RENDER", "type1", "freetype" modules installed, the apps all appear to be linked against Xft, I've got fonts (rather a large amount were installed, I must add..). I have "USE" in /etc/make.conf set with "X" and "truetype", but no.. I get this:

spacepigs3 fonts # xterm -fa "lucida console"
Segmentation fault

or, in gdb:

spacepigs3 fonts # gdb xterm
GNU gdb 5.2.1
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(no debugging symbols found)...
(gdb) run -fa 'lucida console'
Starting program: /usr/X11R6/bin/xterm -fa 'lucida console'
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x4004cf85 in FcPatternPosition () from /usr/lib/libfontconfig.so.1


any ideas?
Back to top
View user's profile Send private message
kerframil
l33t
l33t


Joined: 19 Apr 2002
Posts: 710
Location: London, UK

PostPosted: Wed Nov 20, 2002 6:49 pm    Post subject: Reply with quote

8O OMG, exactly the same thing happens for me. And this is on a brand new installation (did it yesterday). It's not as though I used any exotic compilation options either (-march=pentium3 -O2 -pipe).

Very well spotted indeed ... I'm going to file a bug. I'll edit this post and put a link in when it's done.
Back to top
View user's profile Send private message
ales
n00b
n00b


Joined: 20 Nov 2002
Posts: 19

PostPosted: Mon Nov 25, 2002 5:42 am    Post subject: Re: Tips for Mozilla AA fonts Reply with quote

davidblumberg wrote:
Today I took a look around in the unix.js file and found something that really works! .....

Do you see the 3 places where there is the number 17 written?
Anyway, insted of 17 the default was 10 and that's why Mozilla anti-aliased small fonts which I had disabled in Xftconfig but didn't understand why it didn't work in Mozilla.
So now Mozilla renders fonts great, whether small or big fonts!


Thanks for that info... since i don't have Xftconfig on my system (using PPC gentoo build).. antialiasing in mozilla was on for (what it seemed) all sizes... so changing the unix.js config to 17 did the trick... now small fonts that don't need antialiasing aren't are displayed without it, so they're much more legiable... thanks
ales
Back to top
View user's profile Send private message
loz
n00b
n00b


Joined: 16 Nov 2002
Posts: 13

PostPosted: Tue Nov 26, 2002 4:25 pm    Post subject: doing this has buggered my fonts in OO.o Reply with quote

OK. had lovely anti-aliased fonts in OO.o.

tried this hint to get AA fonts all over, especially in NS 7.0.

Now they're crappy jaggies. very annoying.

what's worse. I removed the extra lines from it and they still won't work..

How have my fonts been skrewd???

How on earth do I get them back. This hint ain't all it's cracked up to be 'cos none of the things you people are going on about are working..

My /etc/X11/XftConfig file is full of loads of rules as it is and adding has had no effect.

What am I doing wrong. It's not like I added anything to the XfConfig file from the original Gentoo install..
_________________
loz
Back to top
View user's profile Send private message
Thilo
n00b
n00b


Joined: 25 Oct 2002
Posts: 3

PostPosted: Sun Dec 08, 2002 10:06 am    Post subject: Reply with quote

Big thanks to you. I was never able to manage to find a REASONABLE howto on importing fonts. thumbs up!
Back to top
View user's profile Send private message
kerframil
l33t
l33t


Joined: 19 Apr 2002
Posts: 710
Location: London, UK

PostPosted: Mon Dec 16, 2002 12:11 pm    Post subject: News ... Reply with quote

Bumping for topic watchers ... please note the edit I made on the very first post.
Back to top
View user's profile Send private message
cpwins
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jul 2002
Posts: 130
Location: The Pandemonium Fortress

PostPosted: Fri Jan 03, 2003 11:21 pm    Post subject: Reply with quote

Oh my fonts are looking bad! I hope your guide will be finished soon kerframil. In the meantime, what would be a good place to find more information on how to increase font quality? There is a lot of writing on this on the forum and even a Linux HOWTO, but I'm not sure which documents are up-to-date and which no longer apply.

For example, in the default XftConfig file the 75 dpi, 100dpi and other "usual" types are no longer specified. Only Type1 and TTF/truetype are there. Why's that? Also, the old "FontPath" variable (or something like that) is now repalced with "dir". Are they equivalent?
Back to top
View user's profile Send private message
Ian Goldby
Guru
Guru


Joined: 18 May 2002
Posts: 539
Location: (Inactive member)

PostPosted: Sat Jan 04, 2003 12:12 pm    Post subject: Reply with quote

<unhelpful reply pointing out you didn't say which versions of the software you are using deleted. Apologies.>
Back to top
View user's profile Send private message
kerframil
l33t
l33t


Joined: 19 Apr 2002
Posts: 710
Location: London, UK

PostPosted: Sat Jan 04, 2003 5:34 pm    Post subject: Reply with quote

cpwins, XftConfig is of no relevance whatsoever with recent XFree86 builds. There is a new build called fontconfig which takes over the same role, and is related to xft support. Also, xft2 is coming our way and is even more exciting (it's currently experimental too).

I can tell you that the files you need to be looking at now are /etc/fonts/fonts.conf and ~/.fonts.conf. Generally you should try to leave the former along, and put your customisations in the latter. They are in XML format now, but this is a good move in my opinion.

Any fonts you put here will be available to xft compliant applications (including anything that uses Qt (KDE) or gtk-2 (gnome 2) libs). Older apps will use standard font support, and will only see fonts specified by FontPath in XF86Config.

Have a look at http://forums.gentoo.org/viewtopic.php?p=160706. That gives you a very basic idea of how to achieve what I've spoken about in this thread. And to see how fonts are imported, just look at /etc/fonts/fonts.conf for examples. I think you need to run fc-cache after changing things.
Back to top
View user's profile Send private message
Naan Yaar
Bodhisattva
Bodhisattva


Joined: 27 Jun 2002
Posts: 1549

PostPosted: Wed Jan 08, 2003 5:25 am    Post subject: KDE + xft2 + fontconfig konsole bug Reply with quote

On upgrading to the latest version of kde that links to xft2 and fontconfig (through qt), fonts in konsole are borked (t h e y l o o k l i k e t h i s). Bug report and a workaround recorded here.
Back to top
View user's profile Send private message
bps7j
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2002
Posts: 83
Location: Charlottesville, VA, USA

PostPosted: Thu Feb 06, 2003 9:23 pm    Post subject: Reply with quote

I had my fonts installed but none of the fonts served by xfs were showing up in X, by which I mean no TT fonts. I had to add "unix/:7100" to my font path list in /etc/X11/XF86Config so it would actually listen to the font server! Damn. This took me like 3 months to figure out, I kid you not. Here's the section of the file:
Code:

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath   "/usr/X11R6/lib/modules"
        FontPath     "/usr/X11R6/lib/X11/fonts/misc:unscaled"
        ..... more lines here .....
        FontPath     "unix/:7100"

EndSection

_________________
There are only 10 kinds of people:
those who understand binary and those who don't.
Back to top
View user's profile Send private message
cpwins
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jul 2002
Posts: 130
Location: The Pandemonium Fortress

PostPosted: Mon Feb 10, 2003 10:04 am    Post subject: Reply with quote

Isn't xfs obsolete with recent versions of xfree?
Back to top
View user's profile Send private message
kerframil
l33t
l33t


Joined: 19 Apr 2002
Posts: 710
Location: London, UK

PostPosted: Mon Feb 10, 2003 11:20 am    Post subject: Reply with quote

Quote:
Isn't xfs obsolete with recent versions of xfree?

In a word, yes :wink:
Back to top
View user's profile Send private message
uziel
n00b
n00b


Joined: 14 Feb 2003
Posts: 32

PostPosted: Fri Feb 14, 2003 9:28 am    Post subject: Re: XftConfig & Slight Hinting Reply with quote

kerframil wrote:
Quote:

As far as I can see, /etc/X11/XftConfig is not used at all
Oh but it is! Making changes to that file will alter the configuration accordingly. Otherwise the implication would be that it does nothing and that it's existence is pointless which seems rather unlikely and surely would have generated many topic replies to this end (and even more comments to the XFree86 team). Furthermore, the changes I made to my default setup were performed exactly as I stated and had the desired effect. At no point did I edit the XftConfig file under the X11 directory.


$ ls -l /usr/X11R6/lib/X11/XftConfig
lrwxrwxrwx 1 root root 29 2003-02-11 20:03 /usr/X11R6/lib/X11/XftConfig -> ../../../../etc/X11/XftConfig

It actually seems to be a symlink. :)
Back to top
View user's profile Send private message
cbreaker
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2003
Posts: 105
Location: Pawtucket, RI

PostPosted: Fri Feb 28, 2003 7:41 pm    Post subject: Reply with quote

I've emerged Xfree86 4.3.0, and now all my fonts are being anti-ailiased. I don't want small fonts to be anti-ailaised.

I have:

match
any size > 8
any size < 14
edit
antialias = false;

# Same again, but enforced for KDE (specifically Konqueror/KHTML)
match
any pixelsize > 8
any pixelsize < 14
edit
antialias = false;

in my /etc/X11/XftConfig, and it's also in /usr/X11R6/lib/X11/XftConfig. I don't have any other XftConfig files anywhere.

It was fine in Xfree 4.2.1. It's ugly having all fonts antiailaised, and I'd rather turn it off completely then have the fonts I look at 98% of the time all blurry looking.
Back to top
View user's profile Send private message
cbreaker
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2003
Posts: 105
Location: Pawtucket, RI

PostPosted: Sat Mar 01, 2003 5:41 am    Post subject: Reply with quote

It seems that I need to make use of /etc/fonts/font.conf (or local.conf in that same directory) to change anti-alias settings.

Unfortunately I don't really know what I would type to disable anti-alias on certian font sizes.

Creating local.conf and dumping:

<match target="font">
<edit name="antialias" mode="assign">
<bool>false</bool>
</edit>
</match>

into it turns off anti-alias for all fonts, which is acceptable for now.. I got that from http://www.xfree86.org/~dawes/4.3.0/fonts2.html#4 but it doesn't get into specifics on how to match on font size.

If anyone can help it would be greatly appreciated.
Back to top
View user's profile Send private message
cbreaker
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2003
Posts: 105
Location: Pawtucket, RI

PostPosted: Sat Mar 01, 2003 6:17 am    Post subject: Reply with quote

Okay so in the spirit of answering my own questions, I was able to put this into /etc/fonts/local.conf:

Code:

<match target="font">
    <test name="size" compare="more">
        <double>8</double>
    </test>
    <test name="size" compare="less">
        <double>14</double>
    </test>
    <edit name="antialias" mode="assign">
        <bool>false</bool>
    </edit>
</match>

<! for Konqueror but it doesn't seem to work>

<match target="font">
    <test name="pixelsize" compare="more">
        <double>8</double>
    </test>
    <test name="pixelsize" compare="less">
        <double>14</double>
    </test>
    <edit name="antialias" mode="assign">
        <bool>false</bool>
    </edit>
</match>


Unfortunately, Konqueror is still rendering all webpages with anti-alias turned on for all font sizes. What a pain.
Back to top
View user's profile Send private message
Steffen
Apprentice
Apprentice


Joined: 14 Jul 2002
Posts: 158

PostPosted: Sat Mar 01, 2003 1:04 pm    Post subject: Reply with quote

Put a .fonts.conf in your home directory with the following content:
Code:
<?xml version="1.0"?>
<match target="font" >
 <test compare="more" name="pixelsize" qual="any" >
  <double>8</double>
 </test>
 <test compare="less" name="pixelsize" qual="any" >
  <double>14</double>
 </test>
 <edit mode="assign" name="antialias" >
  <bool>false</bool>
 </edit>
 <match target="font" >
  <test compare="more" name="size" qual="any" >
   <double>8</double>
  </test>
  <test compare="less" name="size" qual="any" >
   <double>14</double>
  </test>
  <edit mode="assign" name="antialias" >
   <bool>false</bool>
  </edit>
 </match>
</match>

Additionally, in the KDE Control Panel I've enabled anti aliasing, but excluded font sizes 8 - 14 pt. At least for me, only big fonts in Konqueror are anti aliased this way! :)
Back to top
View user's profile Send private message
boglin
n00b
n00b


Joined: 07 Jun 2002
Posts: 67
Location: Kingston, ON

PostPosted: Sat Mar 01, 2003 4:32 pm    Post subject: Just a link: Reply with quote

I found this link to be a useful XFree-fonts howto:
http://www.xfce.org/Xft_and_Xfce_mini_Howto.html
Hope it helps someone. :)
Back to top
View user's profile Send private message
cyjoe
n00b
n00b


Joined: 09 Feb 2003
Posts: 35

PostPosted: Sun Mar 02, 2003 1:14 pm    Post subject: Reply with quote

I just upgraded to xfree 4.3.0 and found the fonts
Charter
Clean
Clearlyu
Fixed
Helvetica
Lucida
New Century Schoolbook

being invisible :|
Antialiasing still works fine for the other fonts (installing Xft 2.0.1 put a new XftConfig into the /etc/X11 directory but it is still just not used. Editing or renaming has no effect on the antialiasing)
Back to top
View user's profile Send private message
arashb
n00b
n00b


Joined: 14 Apr 2003
Posts: 31
Location: Iran

PostPosted: Tue Apr 15, 2003 12:06 pm    Post subject: Is the guid published? Reply with quote

I wonder if that promisse dguid published? We have an awefull lot of problems because of xft malfunctioning. Please inform give the guids url.
Thanx
Back to top
View user's profile Send private message
eauclair
n00b
n00b


Joined: 21 Mar 2003
Posts: 52

PostPosted: Thu Apr 17, 2003 1:54 pm    Post subject: Re: Tips for Mozilla AA fonts Reply with quote

Where is the unix.js file? I can't find it (yet). I can't find where phoenix is installed, either, I did an "emerge phoenix-bin" It runs, but I don't know where it is installed. :cry:

thx



ales wrote:
davidblumberg wrote:
Today I took a look around in the unix.js file and found something that really works! .....

Do you see the 3 places where there is the number 17 written?
Anyway, insted of 17 the default was 10 and that's why Mozilla anti-aliased small fonts which I had disabled in Xftconfig but didn't understand why it didn't work in Mozilla.
So now Mozilla renders fonts great, whether small or big fonts!


Thanks for that info... since i don't have Xftconfig on my system (using PPC gentoo build).. antialiasing in mozilla was on for (what it seemed) all sizes... so changing the unix.js config to 17 did the trick... now small fonts that don't need antialiasing aren't are displayed without it, so they're much more legiable... thanks
ales
Back to top
View user's profile Send private message
reesm
n00b
n00b


Joined: 02 Mar 2003
Posts: 29
Location: AB, Canada

PostPosted: Mon Jun 23, 2003 6:36 pm    Post subject: Reply with quote

Yeah, my fonts work better now on Xfree86 4.3.0. They look spiffy on my fixed frequency HP 2094 A monitor too! See my webpage at http://www.ee.ualberta.ca/~reesm for details on getting this to work.
Back to top
View user's profile Send private message
db7b5
n00b
n00b


Joined: 09 Sep 2002
Posts: 11

PostPosted: Mon Jul 07, 2003 10:11 pm    Post subject: No link to your doc reesm..... Reply with quote

reesm wrote:
Yeah, my fonts work better now on Xfree86 4.3.0. They look spiffy on my fixed frequency HP 2094 A monitor too! See my webpage at http://www.ee.ualberta.ca/~reesm for details on getting this to work.


I would like to view your configuration. It's not posted on your site however. Thanks,

Dan
Back to top
View user's profile Send private message
fbreuer
n00b
n00b


Joined: 04 Oct 2002
Posts: 47
Location: Berlin, Germany

PostPosted: Tue Jul 08, 2003 9:40 am    Post subject: Reply with quote

Does subpixel hinting only work with TrueType fonts? On my laptop the truetype fonts are rendered ok but the Type1 fonts have colorful borders. See also http://forums.gentoo.org/viewtopic.php?p=403146

I am using fontconfig 2.1, Xfree 4.30, and Xft 2.0.1.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 4 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum