Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200606-24 ] wv2: Integer overflow
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1577

PostPosted: Fri Jun 23, 2006 3:26 pm    Post subject: [ GLSA 200606-24 ] wv2: Integer overflow Reply with quote

Gentoo Linux Security Advisory

Title: wv2: Integer overflow (GLSA 200606-24)
Severity: normal
Exploitable: remote
Date: June 23, 2006
Bug(s): #136759
ID: 200606-24

Synopsis

An integer overflow could allow an attacker to execute arbitrary code.

Background

wv2 is a filter library for Microsoft Word files, used in many Office suites.

Affected Packages

Package: app-text/wv2
Vulnerable: < 0.2.3
Unaffected: >= 0.2.3
Architectures: All supported architectures


Description

A boundary checking error was found in wv2, which could lead to an integer overflow.

Impact

An attacker could execute arbitrary code with the rights of the user running the program that uses the library via a maliciously crafted Microsoft Word document.

Workaround

There is no known workaround at this time.

Resolution

All wv2 users should update to the latest stable version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/wv2-0.2.3"


References

CVE 2006-2197
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum