Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200606-23 ] KDM: Symlink vulnerability
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1563

PostPosted: Thu Jun 22, 2006 9:26 pm    Post subject: [ GLSA 200606-23 ] KDM: Symlink vulnerability Reply with quote

Gentoo Linux Security Advisory

Title: KDM: Symlink vulnerability (GLSA 200606-23)
Severity: normal
Exploitable: local
Date: June 22, 2006
Updated: June 24, 2006
Bug(s): #136201
ID: 200606-23

Synopsis

KDM is vulnerable to a symlink vulnerability that can lead to disclosure of information.

Background

KDE is a feature-rich graphical desktop environment for Linux and Unix-like Operating Systems. KDM is the KDE Display Manager and is part of the kdebase package.

Affected Packages

Package: kde-base/kdebase
Vulnerable: < 3.5.2-r2
Unaffected: >= 3.5.2-r2
Unaffected: >= 3.4.3-r2 < 3.4.4
Architectures: All supported architectures

Package: kde-base/kdm
Vulnerable: < 3.5.2-r1
Unaffected: >= 3.5.2-r1
Unaffected: >= 3.4.3-r2 < 3.4.4
Architectures: All supported architectures


Description

Ludwig Nussel discovered that KDM could be tricked into allowing users to read files that would otherwise not be readable.

Impact

A local attacker could exploit this issue to obtain potentially sensitive information that is usually not accessable to the local user such as shadow files or other user's files. The default Gentoo user running KDM is root and, as a result, the local attacker can read any file.

Workaround

There is no known workaround at this time.

Resolution

All kdebase users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose kde-base/kdebase
All KDE split ebuild users should upgrade to the latest KDM version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose kde-base/kdm


References

KDE Security Advisory: KDM symlink attack vulnerability
CVE-2006-2449


Last edited by GLSA on Sun Jun 25, 2006 4:17 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum