Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Via cle266 & xorg-7.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
Sputnick
n00b
n00b


Joined: 10 May 2004
Posts: 46

PostPosted: Tue Jun 13, 2006 10:00 pm    Post subject: Via cle266 & xorg-7.1 Reply with quote

Asensin xorg-7.1 ja nyt heittää tollasta erroria, mikä neuvoksi?

Code:
XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/freepia-env:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 7.1.0
Release Date: 22 May 2006
X Protocol Version 11, Revision 0, Release 7.1
Build Operating System: Linux 2.6.16-suspend2-r4 i686
Current Operating System: Linux freepia-env 2.6.16-suspend2-r8 #1 SMP Tue Jun 13 22:26:53 CEST 2006 i686
Build Date: 13 June 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 14 00:58:43 2006
(++) Using config file: "/root/xorg.conf.new"
dlopen: /usr/lib/xorg/modules/extensions/libglx.so: cannot handle TLS data
(EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so
(EE) Failed to load module "glx" (loader failed, 7)
(EE) Failed to load module "mouse" (module does not exist, 0)
(EE) Failed to load module "kbd" (module does not exist, 0)
(EE) No Input driver matching `mouse'
(EE) No Input driver matching `kbd'
No core keyboard
Back to top
View user's profile Send private message
Cougar81
n00b
n00b


Joined: 08 Nov 2002
Posts: 42
Location: Helsinki, Finland

PostPosted: Thu Jun 15, 2006 11:31 am    Post subject: Reply with quote

Kokeileppa laittaa /etc/make.conffiin seuraavat rivit:
Code:
INPUT_DEVICES="keyboard mouse evdev"
VIDEO_CARDS="mga"

Tuon mga:n tilalle laitat siis sen ajurin minkä oman koneesi näytönohjain tarvitsee.

Sitten vaan asennat xorg-server -paketin uusiksi:
Code:
emerge -1 xorg-server


PS. Kannattaa laittaa myös kerneliin ipv6 tuki päälle taikka sitten ottaa ipv6 USE-flag pois käytöstä, nuo ensimmäiset rivit Xorg.logissasi johtuvat siitä ettei ipv6 tukea ole käytössä.
Back to top
View user's profile Send private message
AnXa
Apprentice
Apprentice


Joined: 06 Apr 2004
Posts: 250
Location: Lahti, Finland

PostPosted: Fri Jun 16, 2006 6:19 pm    Post subject: Reply with quote

Vähän selvennykseksi:
(EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so
(EE) Failed to load module "glx" (loader failed, 7)
(EE) Failed to load module "mouse" (module does not exist, 0)
(EE) Failed to load module "kbd" (module does not exist, 0)
(EE) No Input driver matching `mouse'
(EE) No Input driver matching `kbd'

Sinulla on ehkä X11-Xorg serveri, mutta ei sen tarvitsemia moduuleita, kirjastoja, ajureita ym.

xgl, mouse, kbd ovat ainakin tuon mukaan puuttuvia ajureita. Lisäämällä make.conffiin syötelaiteet ja näytönohjaimesi ajurin ja kääntämällä sen jälkeen kyseiset ajurit sun pitäisi saada kaikki pelittämään. Tietysti voit lisätä tavarat ja kääntää x11sen uudestaan.

Suosittelen lisäämään näytönohjaimien mukaan vesa ajurin. esim. mulla on:
# X.Org 7.0 Ajurit
INPUT_DEVICES="keyboard mouse joystick"
VIDEO_CARDS="nv nvidia vesa v4l"

v4l on videon sisäänmenoon liittyvä video 4 linux ajuri. et tarvitse sitä luultavasti ellet omista webbi-kameraa.
_________________
The idea isn't about how do you see or hear it, it's about how do you experience it...
--//--
Asus K8V Deluxe, Athlon64 3500+, nVidia 7600 GT, 3Gb 400MHz DDR, IDE HD 160Gb, IDE HD 850Mb and SATA HD 250Gb
Back to top
View user's profile Send private message
Sputnick
n00b
n00b


Joined: 10 May 2004
Posts: 46

PostPosted: Sat Jun 17, 2006 3:32 pm    Post subject: Reply with quote

AnXa wrote:
Vähän selvennykseksi:
(EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so
(EE) Failed to load module "glx" (loader failed, 7)
(EE) Failed to load module "mouse" (module does not exist, 0)
(EE) Failed to load module "kbd" (module does not exist, 0)
(EE) No Input driver matching `mouse'
(EE) No Input driver matching `kbd'

Sinulla on ehkä X11-Xorg serveri, mutta ei sen tarvitsemia moduuleita, kirjastoja, ajureita ym.

xgl, mouse, kbd ovat ainakin tuon mukaan puuttuvia ajureita. Lisäämällä make.conffiin syötelaiteet ja näytönohjaimesi ajurin ja kääntämällä sen jälkeen kyseiset ajurit sun pitäisi saada kaikki pelittämään. Tietysti voit lisätä tavarat ja kääntää x11sen uudestaan.

Suosittelen lisäämään näytönohjaimien mukaan vesa ajurin. esim. mulla on:
# X.Org 7.0 Ajurit
INPUT_DEVICES="keyboard mouse joystick"
VIDEO_CARDS="nv nvidia vesa v4l"

v4l on videon sisäänmenoon liittyvä video 4 linux ajuri. et tarvitse sitä luultavasti ellet omista webbi-kameraa.


Mihin Jäi VIDEO_CARDS="via"?
Back to top
View user's profile Send private message
AnXa
Apprentice
Apprentice


Joined: 06 Apr 2004
Posts: 250
Location: Lahti, Finland

PostPosted: Sat Jun 17, 2006 7:45 pm    Post subject: Reply with quote

Sputnick wrote:
AnXa wrote:
Vähän selvennykseksi:

Suosittelen lisäämään näytönohjaimien mukaan vesa ajurin. esim. mulla on:
# X.Org 7.0 Ajurit
INPUT_DEVICES="keyboard mouse joystick"
VIDEO_CARDS="nv nvidia vesa v4l"

v4l on videon sisäänmenoon liittyvä video 4 linux ajuri. et tarvitse sitä luultavasti ellet omista webbi-kameraa.


Mihin J�i VIDEO_CARDS="via"?


Kannattaisi lukea kokonaan: :P
AnXa wrote:

esim. mulla on:
# X.Org 7.0 Ajurit
INPUT_DEVICES="keyboard mouse joystick"
VIDEO_CARDS="nv nvidia vesa v4l"


Aattelin, että oot sen verran fiksu ettei tartte lisätä sitä viaa sinne erikseen... ;)
..noh ei voi mitään. Näitä sattuu. :D
_________________
The idea isn't about how do you see or hear it, it's about how do you experience it...
--//--
Asus K8V Deluxe, Athlon64 3500+, nVidia 7600 GT, 3Gb 400MHz DDR, IDE HD 160Gb, IDE HD 850Mb and SATA HD 250Gb
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum