Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200606-13 ] MySQL: SQL Injection
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1539

PostPosted: Sun Jun 11, 2006 10:26 pm    Post subject: [ GLSA 200606-13 ] MySQL: SQL Injection Reply with quote

Gentoo Linux Security Advisory

Title: MySQL: SQL Injection (GLSA 200606-13)
Severity: normal
Exploitable: remote
Date: June 11, 2006
Updated: December 13, 2006
Bug(s): #135076
ID: 200606-13

Synopsis

MySQL is vulnerable to an SQL Injection flaw in the multi-byte encoding process.

Background

MySQL is a popular multi-threaded, multi-user SQL server.

Affected Packages

Package: dev-db/mysql
Vulnerable: < 5.0.22
Unaffected: >= 5.0.22
Unaffected: >= 4.1.20 < 4.1.21
Unaffected: >= 4.1.21 < 4.1.22
Unaffected: >= 4.1.22 < 4.1.23
Unaffected: < 4.1
Architectures: All supported architectures


Description

MySQL is vulnerable to an injection flaw in mysql_real_escape() when used with multi-byte characters.

Impact

Due to a flaw in the multi-byte character process, an attacker is still able to inject arbitary SQL statements into the MySQL server for execution.

Workaround

There are a few workarounds available: NO_BACKSLASH_ESCAPES mode as a workaround for a bug in mysql_real_escape_string(): SET sql_mode='NO_BACKSLASH_ESCAPES'; SET GLOBAL sql_mode='NO_BACKSLASH_ESCAPES'; and server command line options: --sql-mode=NO_BACKSLASH_ESCAPES.

Resolution

All MySQL users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/mysql-4.1.20"


References

CVE-2006-2753


Last edited by GLSA on Thu Dec 14, 2006 4:18 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum