Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ett extra blanksteg efter Å, Ä och Ö i konsollen.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
phibxr
n00b
n00b


Joined: 05 Sep 2004
Posts: 47

PostPosted: Fri Jun 09, 2006 3:55 pm    Post subject: Ett extra blanksteg efter Å, Ä och Ö i konsollen. Reply with quote

Det finns ett otal trådar om ÅÄÖ-problem, men jag har inte hittat något duplikat av detta (sen kanske det beror på bristfälligt letande, och då godtar jag mer än gärna en länk).

ÅÄÖ fungerar utmärkt i X, men i konsoll-läge får jag in ett extra blanksteg efter varje tecken. I exempelvis VIM visar sig detta som "å ä ö " när jag skriver "åäö", men i andra program, exempelvis IRSSI ser jag "åäö" men kan backa tillbaka med backspace över prompten (dvs, blankstegen finns där, men syns inte).

Någon lösning?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4831
Location: Gothenburg, Sweden

PostPosted: Sat Jun 10, 2006 9:39 pm    Post subject: Reply with quote

Kan tänka mig att det har med UTF-8 att göra. Backspace raderar en byte, medan åäö är två byte om du använder UTF-8.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
eroyf
Retired Dev
Retired Dev


Joined: 03 May 2004
Posts: 82

PostPosted: Sun Jun 18, 2006 9:55 pm    Post subject: Reply with quote

Du skal sørge for at bruge en terminal der supporter UTF-8. F.eks. uxterm (x11-terms/xterm. Husk at hav unicode i din USE variabel i /etc/make.conf.

I min .vimrc har jeg:
Code:
set fileformat=unix
set termencoding=utf-8


For at den skal forstå UTF-8 (Igen, dette kræver en UTF-8 enabled terminal).

I irssi har jeg sagt:
Code:
/set term_charset UTF-8


I konsollen kan det måske løses ved at sige "unicode_start"

Håber det hjalp :)

Hilsen
Alexander
Back to top
View user's profile Send private message
dajja
n00b
n00b


Joined: 11 May 2006
Posts: 15
Location: Sweden

PostPosted: Tue Jul 18, 2006 10:01 pm    Post subject: Reply with quote

Quote:
Du skal sørge for at bruge en terminal der supporter UTF-8. F.eks. uxterm (x11-terms/xterm. Husk at hav unicode i din USE variabel i /etc/make.conf.


Jag har samma problem, men jag vill inte köra xterm :? Finns det andra terminaler som har samma funktionalitet för unicode som xterm?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum