Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XML-Parser-2.34 Error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Sketchy
n00b
n00b


Joined: 22 Oct 2003
Posts: 25

PostPosted: Wed Mar 03, 2004 8:15 pm    Post subject: XML-Parser-2.34 Error Reply with quote

i had a look around but couldn't find anything to help me with this problem..

i ran emerge -U world and it updated a few packages and then started XML-Parser and gave me this error

Code:
Writing Makefile for XML::Parser::Expat
Writing Makefile for XML::Parser
make: Warning: File `/usr/lib/perl5/5.8.2/i686-linux/Config.pm' has modification time 3e+06 s in the future
Makefile out-of-date with respect to /usr/lib/perl5/5.8.2/i686-linux/Config.pm /usr/lib/perl5/5.8.2/i686-linux/CORE/config.h
Cleaning current config before rebuilding Makefile...
make -f Makefile.old clean > /dev/null 2>&1 || /bin/sh -c true
/usr/bin/perl Makefile.PL "PREFIX=/usr" "INSTALLDIRS=vendor" "DESTDIR=/var/tmp/portage/XML-Parser-2.34/image/"
Checking if your kit is complete...
Looks good
Writing Makefile for XML::Parser::Expat
Writing Makefile for XML::Parser
==> Your Makefile has been rebuilt. <==
==> Please rerun the make command.  <==
false
make: *** [Makefile] Error 1

!!! ERROR: dev-perl/XML-Parser-2.34 failed.
!!! Function perl-module_src_compile, Line 49, Exitcode 2
!!! compilation failed


i really can't think why this would happen. I tried unmerging and remerging XML-Parser but no luck...

anyhelp would be greatly appreciated...

benn
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Wed Mar 03, 2004 8:21 pm    Post subject: Reply with quote

make: Warning: File `/usr/lib/perl5/5.8.2/i686-linux/Config.pm' has modification time 3e+06 s in the future


check your system clock.
Thats why using ntpd is a good thing :)
_________________
linux: #232767
Back to top
View user's profile Send private message
Sketchy
n00b
n00b


Joined: 22 Oct 2003
Posts: 25

PostPosted: Wed Mar 03, 2004 8:36 pm    Post subject: Reply with quote

ahh, thankyou i actually had no idea what that meant but my friend helped me out when he'd read what you wrote..

benn
Back to top
View user's profile Send private message
jeller2
n00b
n00b


Joined: 18 Mar 2004
Posts: 3

PostPosted: Sun Apr 11, 2004 11:11 am    Post subject: Reply with quote

emerge perl new and then it will by go
Back to top
View user's profile Send private message
johannesp
n00b
n00b


Joined: 13 Jun 2005
Posts: 4
Location: germany north-west

PostPosted: Wed Dec 14, 2005 6:11 pm    Post subject: Reply with quote

i had the same problem. but why does it work, when installing perl?
thanks for your help!
Back to top
View user's profile Send private message
chico_marx
n00b
n00b


Joined: 30 Mar 2006
Posts: 5

PostPosted: Wed Apr 05, 2006 12:59 am    Post subject: Reply with quote

I have the same problem, but i don't get the warning "make: Warning: File `/usr/lib/perl5/5.8.2/i686-linux/Config.pm' has modification time 3e+06 s in the future ".

I did not understand the solution. I tryed re-merging perl, but it did not work, perl-cleaner didn't work either. I guess it's an issue with a glibc upgrade, but I'm not sure. I did fix_libtool_files.sh , source /etc/profile and revdep-rebuild.
Back to top
View user's profile Send private message
Anardil
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jun 2004
Posts: 90

PostPosted: Thu Jul 13, 2006 8:02 am    Post subject: Reply with quote

Another solution to this would also be to reset the date of all file belonging to the perl-package manually.
Remerging the perl package takes longer but does effectifely the same, provided that your system clock is set correctly.

This solves the problem as the configure script of the XML-Parser ebuild no longer suggests the config files and headers
of the perl package to be created in the future and thus no longer crashes when building the new make-file.

I had the same problem and remerging the perl-package solved it for me too.

BTW ne1 got an idee how to change all the files of an installed package (e.g. the date ;-))
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum