Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Help me with microphone on laptop's Intel soundcard
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
TemplarKnight
Guru
Guru


Joined: 14 Jun 2005
Posts: 311
Location: Greece/patras/

PostPosted: Tue Aug 24, 2010 11:27 am    Post subject: [Solved] Help me with microphone on laptop's Intel soundcard Reply with quote

Hello,

I've been trying in vain to get the internal mic working on my new Dell Latitude E5510 laptop.
Sound works fine, soundcard is detected as IDT 92HD81B1X5, relevant codec is selected in the kernel config.
Also external mic when connected to the jack works like a whisper.

Here is some info:

Code:
~ # lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation Ibex Peak High Definition Audio (rev 05)


Code:
~ # lspci -k
...
00:1b.0 Audio device: Intel Corporation Ibex Peak High Definition Audio (rev 05)
        Subsystem: Dell Device 0428
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
...


Code:
~ # lsmod|grep snd
snd_pcm_oss            32617  0
snd_mixer_oss          12662  1 snd_pcm_oss
snd_seq_dummy           1510  0
snd_seq_oss            24005  0
snd_seq_midi_event      5700  1 snd_seq_oss
snd_seq                44789  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          5449  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_hda_codec_idt      52944  1
snd_hda_intel          21243  5
snd_hda_codec          60216  2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep               5562  1 snd_hda_codec
snd_pcm                70073  4 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              17683  3 snd_seq,snd_pcm
snd                    53055  19 snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_seq,snd_seq_device,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc          6981  2 snd_hda_intel,snd_pcm


Code:
~ # cat /proc/asound/Intel/code* | grep Codec
Codec: IDT 92HD81B1X5
Codec: Intel ID 2804


Code:
linux # grep -i SND .config|grep =
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_HRTIMER=m
CONFIG_SND_SEQ_HRTIMER_DEFAULT=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_SUPPORT_OLD_API=y
CONFIG_SND_VERBOSE_PROCFS=y
CONFIG_SND_VMASTER=y
CONFIG_SND_DMA_SGBUF=y
CONFIG_SND_DRIVERS=y
CONFIG_SND_PCI=y
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_BEEP_MODE=2
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_PCMCIA=y


In alsamixer, I get the following for -ALL- selected:
http://students.ceid.upatras.gr/~tsogkas/alsamixer.jpeg

I've tried various ways of loading the alsa-related modules via /etc/modprobe.d/alsa.conf. Currently I have
Code:
options snd-hda-intel model=ref


If I leave it to auto, it complains that it can't find the exact chip or something and it will guess for probing. This works the same: sound is fine, NO mic though :x

When trying to record via gnome-sound-recorder, all I get is static when 'Digital' is not at vol=0. When this 0, I get nothing recorded, no matter the recording input I choose.

I'm out of ideas with this, any thoughts?


Last edited by TemplarKnight on Wed Aug 25, 2010 9:55 am; edited 1 time in total
Back to top
View user's profile Send private message
GES
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 107
Location: Budapest, Hungary

PostPosted: Tue Aug 24, 2010 12:50 pm    Post subject: Reply with quote

I can try it out by myself the following models:
STAC92HD71B*
============
dell-m4-1 Dell desktops
dell-m4-2 Dell desktops
dell-m4-3 Dell desktops
STAC92HD73*
===========
dell-m6-amic Dell desktops/laptops with analog mics
dell-m6-dmic Dell desktops/laptops with digital mics
dell-m6 Dell desktops/laptops with both type of mics
dell-eq Dell desktops/laptops
STAC92HD83*
===========
dell-s14 Dell laptop
Back to top
View user's profile Send private message
TemplarKnight
Guru
Guru


Joined: 14 Jun 2005
Posts: 311
Location: Greece/patras/

PostPosted: Tue Aug 24, 2010 1:31 pm    Post subject: Reply with quote

I've tried all of them, still no go.

Mic doesn't record or play anything. Under Windows mic works as expected :cry:

Any more ideas?

------------------UPDATE:

ok, options snd-hda-intel model=dell-s14 in /etc/modprobe.d/alsa.conf seems to have done the trick.

Internal mic now works :D

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum