Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
atkbd.c: Unknown key pressed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
callendorph
n00b
n00b


Joined: 21 Feb 2006
Posts: 3

PostPosted: Tue Feb 21, 2006 8:01 pm    Post subject: atkbd.c: Unknown key pressed Reply with quote

Hello,

I am working on installing Gentoo AMD64. I am not new to linux, but I am having some problems with my microsoft keyboard :-P

Microsoft Wireless Desktop Elite

I get the following message after booting from the CD :

kernel: atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
kernel: atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.
kernel: atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
kernel: atkbd.c: Use 'setkeycodes e001 <keycode>' to make it known.

I am not pressing any keys at this point. Also when I start typing, the console shows what I am typing and gives these message more often.

For most of the install I just used the following command

setkeycodes e059 112

which sets that scancode to something that won't get in my way too much. However, when i try to passwd and reset my root password, it won't lock my password because there are these extra 112 keys being interspersed in my typing.

I have tried reducing the keyboard scan rate, I have tried changing the keycode to something different with no success. I have run showkey and it will show me that I am typing keys and then randomly when I am typing introduce 112 keys.

Does anyone have any other ideas? I am mostly interested in a way that I can just assign this scancode to do nothing. I just want it to not register these two scancodes at all.

Thanks,
Carl
Back to top
View user's profile Send private message
dadodrake
n00b
n00b


Joined: 19 Mar 2005
Posts: 55
Location: Slovakia

PostPosted: Thu Apr 06, 2006 9:58 pm    Post subject: Reply with quote

I have the same problem with Microsoft Wireless Multimedia Keyboard
Back to top
View user's profile Send private message
Deathwing00
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4078
Location: Barcelona, Spain

PostPosted: Fri Apr 07, 2006 2:46 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Kernel & Hardware. Hardware specific problem.
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2214
Location: Netherlands

PostPosted: Fri Apr 07, 2006 2:58 pm    Post subject: Reply with quote

Have you tried a keyboard that is wire connected?
It might be RF interference.
Back to top
View user's profile Send private message
niick
Tux's lil' helper
Tux's lil' helper


Joined: 09 Mar 2006
Posts: 88

PostPosted: Fri May 19, 2006 12:41 am    Post subject: Reply with quote

Hello,

I use a Microsoft Wireless Multimedia Keyboard as well, so far I've been unable to sort this out.

I have read that these codes (e001 and e059) are the keyboard reporting its status i.e. battery life and signal level.
In Windows the Intellitype software can deal with this, but unfortunatly this is not supported in linux :(

I have tried assigning them via setkeycodes but nothing seems to work.
Back to top
View user's profile Send private message
garlik42
n00b
n00b


Joined: 17 Dec 2002
Posts: 57
Location: Connecticut USA by the water ...

PostPosted: Mon Aug 28, 2006 1:53 pm    Post subject: Reply with quote

I have seen this particular error in a couple of different forums for more than one linux.
I tracked it down in /usr/src/linux/drivers/input/keyboard/atkbd.c
The functions that are producing the message look like this:

Code:

                                printk(KERN_DEBUG "atkbd.c: Unknown key %s "
                                       "(%s set %d, code %#x on %s).\n",
                                       atkbd->release ? "released" : "pressed",
                                       atkbd->translated ? "translated" : "raw",
                                       atkbd->set, code, serio->phys);
                                printk(KERN_DEBUG "atkbd.c: Use 'setkeycodes %s%02x <keycode>' "
                                       "to make it known.\n",
                                       code & 0x80 ? "e0" : "", code & 0x7f);

First I tried setting KERN_DEBUG to KERN_WARNING, but then my dmesg log filled up with all the messages, so I ended up commenting the lines out. Since I have NEVER gotten this type of message before, and I am not using any of the special keys this works for me. Here is the diff to the atkbd.c file (pretty trivial)

Code:

366a367
>                       /*
374a376
>                                      */


I am using kernel gentoo-sources 2.6.17-r5 but I think this fix will work with older kernels as the file doesn't seem to change much.
This is a hack, and is not a fix. But what the hey ....
_________________
#9252 xbox*2 PIII933dual Xeon3.4dual P4-3 426hemi
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum