Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PS/2 mouse
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
CalicoJck
Guest





PostPosted: Fri Apr 19, 2002 3:02 am    Post subject: PS/2 mouse Reply with quote

I'm having some trouble with my Logitech Mouseman Wheel. I have it configured correctly in X, and it works, but only after I start clicking the buttons and moving it all around. I'll try to do a "cat /dev/psaux", and I have the same problem. It tells me that it can't find the mouse. Once it is found, it works until I reboot, but I was wondering if there is a way to do this without user intervention. I've never seemed to have this problem before, so my guess is that it's not a hardware thing. Can anyone help me out?
Back to top
tod
Developer
Developer


Joined: 17 Apr 2002
Posts: 136
Location: Ozarks, USA

PostPosted: Fri Apr 19, 2002 7:11 pm    Post subject: Reply with quote

Hi!

This is just a guess, but it might be related to devfs. /dev/psaux should be a symlink to /dev/misc/psaux. You might check /etc/devfs.conf and make sure all the legacy dev symlinks are getting set up correctly.

hth

tod
Back to top
View user's profile Send private message
niyogi
Apprentice
Apprentice


Joined: 10 Apr 2002
Posts: 199
Location: Austin, TX

PostPosted: Fri Apr 19, 2002 9:01 pm    Post subject: Reply with quote

i can't get the wheel to work on my logitech... i believe i put in the ZAxisMapping 4 5 option but perhaps it's just because i haven't restarted x. then again, i did do "CTRL+ALT+BACKSPACE"

-S
Back to top
View user's profile Send private message
+BroNNoS+
n00b
n00b


Joined: 17 Apr 2002
Posts: 46
Location: Groningen, The Netherlands

PostPosted: Sat Apr 20, 2002 12:32 am    Post subject: Reply with quote

This should be enough:

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Back to top
View user's profile Send private message
Anti
n00b
n00b


Joined: 18 Apr 2002
Posts: 45

PostPosted: Sat Apr 20, 2002 12:48 am    Post subject: Reply with quote

Well, I remembered using just that configuration last time I installed Gentoo.
Have the same config now, but the wheel refuses to work, despite the fact that there's no change in hardware in any way.
_________________
stuff is good.
Back to top
View user's profile Send private message
fghellar
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 856
Location: Porto Alegre, BR

PostPosted: Sat Apr 20, 2002 12:57 am    Post subject: Reply with quote

+BroNNoS+ wrote:
This should be enough:

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"

Try adding
Option "Buttons" "5"
before ZAxisMapping
_________________
| www.gentoo.org | www.tldp.org | www.google.com |
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum