Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[wifi] pas de connexion (resolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
toufou
Guru
Guru


Joined: 07 Jun 2004
Posts: 326

PostPosted: Tue May 02, 2006 3:50 pm    Post subject: [wifi] pas de connexion (resolu) Reply with quote

salut à tous

me revoilà avec mon pb de wifi sur mon ibook
je vais être le plus complet possible.

Je suis sur le noyau 2.6.17-rc3 qui supporte la carte airport en théorie. Configuré en dur.

au démarrage de la machine, voilà ce que j'ai:
/var/log/messages:

Code:
May  2 15:44:39 Mathieu-ibook #0: PowerMac Snapper (Dev 38) Sub-frame 0
May  2 15:44:39 Mathieu-ibook NET: Registered protocol family 2
May  2 15:44:39 Mathieu-ibook IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
May  2 15:44:39 Mathieu-ibook TCP established hash table entries: 131072 (order: 7, 524288 bytes)
May  2 15:44:39 Mathieu-ibook TCP bind hash table entries: 65536 (order: 6, 262144 bytes)
May  2 15:44:39 Mathieu-ibook TCP: Hash tables configured (established 131072 bind 65536)
May  2 15:44:39 Mathieu-ibook TCP reno registered
May  2 15:44:39 Mathieu-ibook TCP bic registered
May  2 15:44:39 Mathieu-ibook NET: Registered protocol family 1
May  2 15:44:39 Mathieu-ibook NET: Registered protocol family 17
May  2 15:44:39 Mathieu-ibook ieee80211: 802.11 data/management/control stack, git-1.1.7
May  2 15:44:39 Mathieu-ibook ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
May  2 15:44:39 Mathieu-ibook ieee80211_crypt: registered algorithm 'NULL'
May  2 15:44:39 Mathieu-ibook ieee80211_crypt: registered algorithm 'WEP'
May  2 15:44:39 Mathieu-ibook initcall at 0xc0051940: software_resume+0x0/0x154(): returned with error code -2


pour /var/log/dmesg
Code:

NET: Registered protocol family 24
bcm43xx driver
PCI: Enabling device 0001:10:12.0 (0004 -> 0006)
bcm43xx: Chip ID 0x4306, rev 0x3
bcm43xx: Number of cores: 5
bcm43xx: Core 0: ID 0x800, rev 0x4, vendor 0x4243, enabled
bcm43xx: Core 1: ID 0x812, rev 0x5, vendor 0x4243, disabled
bcm43xx: Core 2: ID 0x80d, rev 0x2, vendor 0x4243, enabled
bcm43xx: Core 3: ID 0x807, rev 0x2, vendor 0x4243, disabled
bcm43xx: Core 4: ID 0x804, rev 0x9, vendor 0x4243, enabled
bcm43xx: PHY connected
bcm43xx: Detected PHY: Version: 2, Type 2, Revision 2
bcm43xx: Detected Radio: ID: 2205017f (Manuf: 17f Ver: 2050 Rev: 2)
bcm43xx: Radio turned off
bcm43xx: Radio turned off

NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 7, 524288 bytes)
TCP bind hash table entries: 65536 (order: 6, 262144 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
ieee80211: 802.11 data/management/control stack, git-1.1.7
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
ieee80211_crypt: registered algorithm 'NULL'
ieee80211_crypt: registered algorithm 'WEP'
initcall at 0xc0051940: software_resume+0x0/0x154(): returned with error code -2


iwconfig me donne:

Code:
lo        no wireless extensions.

eth0      IEEE 802.11b/g  ESSID:"linksys"  Nickname:"Broadcom 4306"
          Mode:Managed  Frequency=2.462 GHz  Access Point: Invalid
          Bit Rate=11 Mb/s   Tx-Power=15 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


ifconfig eth0 ne pose aucun pb
voilà la réponse de la machine (/var/log/messages)
Code:
apres manipulations:

May  2 15:49:56 Mathieu-ibook bcm43xx: PHY connected
May  2 15:49:57 Mathieu-ibook bcm43xx: Radio turned on
May  2 15:49:57 Mathieu-ibook bcm43xx: Chip initialized
May  2 15:49:57 Mathieu-ibook bcm43xx: DMA initialized
May  2 15:49:57 Mathieu-ibook bcm43xx: 80211 cores initialized
May  2 15:49:57 Mathieu-ibook bcm43xx: Keys cleared
May  2 15:52:01 Mathieu-ibook SoftMAC: Open Authentication completed with 00:16:b6:4f:4c:b1


iwlist eth0 scan renvoie
Code:
eth0      Scan completed :
          Cell 01 - Address: 00:16:B6:4F:4C:B1
                    ESSID:"linksys"
                    Protocol:IEEE 802.11g
                    Mode:Master
                    Channel:11
                    Encryption key:off
                    Bit Rates:54 Mb/s
                    Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 24 36 48 54
                    Quality=100/100  Signal level=-151 dBm
                    Extra: Last beacon: 19ms ago


bref, tout ça est très encourageant.

mais un dhcpcd eth0 ne répond pas

apres dhcp, il y a dans mes messages:
Code:

May  2 16:01:57 Mathieu-ibook dhcpcd[8684]: timed out waiting for a valid DHCP server response
May  2 16:01:57 Mathieu-ibook bcm43xx: Radio turned off
May  2 16:01:57 Mathieu-ibook bcm43xx: DMA 0x0200 (RX) max used slots: 1/64
May  2 16:01:57 Mathieu-ibook bcm43xx: DMA 0x0260 (TX) max used slots: 0/512
May  2 16:01:57 Mathieu-ibook bcm43xx: DMA 0x0240 (TX) max used slots: 0/512
May  2 16:01:57 Mathieu-ibook bcm43xx: DMA 0x0220 (TX) max used slots: 2/512
May  2 16:01:57 Mathieu-ibook bcm43xx: DMA 0x0200 (TX) max used slots: 0/512


si je le fais à la main, pas de pb pour assigner l'adresse IP mais pour la passerelle j'obtiens:

Code:
route add gateway 192.168.1.1
gateway: Host name lookup failure


bref, ça coince quelque part. Pourtant, le wifi semble bien pris en compte. Le scan détecte bien mon réseau (non protégé qui plus est)

je suis sûr que c'est une petite merdouille quelque part, lmais je n'arriuve pas à trouver laquelle.

Pour finir, le réseau filaire ne pose, lui aucun pb. Et d'autres portables avec wifi sous linux se connectent très bien aussi.


Last edited by toufou on Fri May 12, 2006 2:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1551
Location: Madinina

PostPosted: Tue May 02, 2006 4:10 pm    Post subject: Reply with quote

Salut,

Ton fichier /etc/conf.d/net , svp ?

Que donne :
Code:
/etc/init.d/net.eth0  restart


Man iwconfig te donne beaucoup d'infos.




@ +
_________________
Get Up and Go !
Back to top
View user's profile Send private message
toufou
Guru
Guru


Joined: 07 Jun 2004
Posts: 326

PostPosted: Tue May 02, 2006 4:33 pm    Post subject: Reply with quote

alors, mon /etc/conf.d/net
Code:
# in /etc/conf.d/net (this file :]!).
config_eth0=( "dhcp" )
#dhcp_eth0="nodns nontp nonis"


pour iwconfig, j'ai pas mal cherché, trouvé comment configurer le canal, l'id, voire le rate mais pour ma question, nada.
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1551
Location: Madinina

PostPosted: Tue May 02, 2006 5:09 pm    Post subject: Reply with quote

Salut,


Je n'ai pas de soluce , la commande route, te donne quoi ?
J'utilise le wifi et normalement avec juste dhcp, tu devrais être connecté...

Essais :
Code:
routes_ESSID=( "default via 192.168.1.1" )



@ +
_________________
Get Up and Go !
Back to top
View user's profile Send private message
toufou
Guru
Guru


Joined: 07 Jun 2004
Posts: 326

PostPosted: Tue May 02, 2006 5:57 pm    Post subject: Reply with quote

route donne:

Code:
# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0   *               255.255.255.0   U     0      0        0 eth1
loopback        localhost       255.0.0.0       UG    0      0        0 lo
default         sme-serveur.zon 0.0.0.0         UG    0      0        0 eth1


eth1 étant la connexion filaire que j'utilise en ce moment pour répondre

la ligne que tu me donnes, je dois la rajouter au fichier ? je redémarre le service ensuite ou ce n'est pas nécessaire ?
l'un de vous sait il s'il y a une commande qui me permettrait de garder une trace plus précise de ce que fais la machine en tentant de se connecter pour voir là où ça coince ?
Back to top
View user's profile Send private message
toufou
Guru
Guru


Joined: 07 Jun 2004
Posts: 326

PostPosted: Fri May 12, 2006 2:25 pm    Post subject: Reply with quote

bon, ça fonctionne

le pb venait de mon point d'accès configué en G only
je l'ai mis en mixte et, ça passe. merci à tous
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum