Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge vte fails [** Solved **]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
m0rd0
n00b
n00b


Joined: 15 Feb 2005
Posts: 40
Location: Bristol, UK

PostPosted: Thu May 11, 2006 8:06 am    Post subject: emerge vte fails [** Solved **] Reply with quote

Hi,

I've searched the forums to try to resolve this problem but haven't actually found any advice other than someone compiling the package manually...which is something i'd like to avoid if possible. In my quest to upgrade to Gnome 2.14 I've hit a snag with the vte-0.12.0 package.

Code:
checking for freetype-config... /usr/bin/freetype-config
checking for FreeType - version >= 6.1.0... no
*** The FreeType test program failed to run.  If your system uses
*** shared libraries and they are installed outside the normal
*** system library path, make sure the variable LD_LIBRARY_PATH
*** (or whatever is appropiate for your system) is correctly set.
configure: error: You must have freetype 2.0.2 or later to build vte.


I've hit google and trawled the gentoo forums, and I'm running the latest version of freetype, but haven't found a way to fix this as yet. I'm at work so I figured i'd post this and see if I get a quick answer before I have to spend my evening learning about freetype :roll:

- m0rd0


Last edited by m0rd0 on Wed May 17, 2006 10:16 am; edited 2 times in total
Back to top
View user's profile Send private message
m0rd0
n00b
n00b


Joined: 15 Feb 2005
Posts: 40
Location: Bristol, UK

PostPosted: Sat May 13, 2006 10:48 am    Post subject: No one? Reply with quote

No able to offer any advice at all?
Back to top
View user's profile Send private message
Krieg
n00b
n00b


Joined: 24 Feb 2004
Posts: 36

PostPosted: Tue May 16, 2006 10:10 am    Post subject: Reply with quote

# emerge unmerge mesa-glu
Back to top
View user's profile Send private message
m0rd0
n00b
n00b


Joined: 15 Feb 2005
Posts: 40
Location: Bristol, UK

PostPosted: Tue May 16, 2006 10:36 am    Post subject: Reply with quote

Krieg wrote:
# emerge unmerge mesa-glu


Thanks for replying :D

I don't have any of the mesa packages installed. Any other suggestions?
Back to top
View user's profile Send private message
Krieg
n00b
n00b


Joined: 24 Feb 2004
Posts: 36

PostPosted: Tue May 16, 2006 12:25 pm    Post subject: Reply with quote

I found out which program was crashing (complaining about wrong shared libraries) looking at the installation log. In my case: /var/tmp/portage/vte-0.12.0/work/vte-0.12.0/config.log

I found out (with equery) the wrong library belonged to mesa-glu and that that package does not exist anymore and that library is now provided directly by xorg-x11.
Back to top
View user's profile Send private message
nonos
n00b
n00b


Joined: 09 Mar 2003
Posts: 3
Location: Switzerland

PostPosted: Tue May 16, 2006 9:31 pm    Post subject: Reply with quote

I don't have mesa-glu too.

But... in my case the library that cause problem is libGl.so.1. (Thanks Krieg for the config.log info :) )

To solve the problem I've unmerged mesa files displayed by the command 'equery b libGL.so.1' and glu.
Code:
# equery b libGL.so.1
[ Searching for file(s) libGL.so.1 in *... ]
    - media-libs/mesa-6.4.2-r2 (...)
    - media-video/nvidia-glx-1.0.8756 (...)

# emerge -Ca mesa glu


Then, before re-emerging vte, be sure that you can launch this command:
Code:
# eselect opengl


If you've error message: (topic: http://forums.gentoo.org/viewtopic-t-434257.html)
Code:

# emerge -uav sed
# ln -s /bin/sed /usr/bin/sed


Finally, emerge vte and enjoy ;)
Code:

# emerge -uav vte


Best Regards
Back to top
View user's profile Send private message
m0rd0
n00b
n00b


Joined: 15 Feb 2005
Posts: 40
Location: Bristol, UK

PostPosted: Tue May 16, 2006 10:25 pm    Post subject: Sweet! Reply with quote

nonos: That's the fix dude.

I managed to work out it was libGL.so.1, again thanks Krieg's posting and some free time at work, but didn't really get any further than seeing the failure point. You've just saved my a lot of time.

Thanks for the help guys.
- m0rd0
Back to top
View user's profile Send private message
rapik
n00b
n00b


Joined: 04 Sep 2006
Posts: 4

PostPosted: Mon Sep 04, 2006 2:40 am    Post subject: Thankz... Reply with quote

Yep.....did work...very TKZ...see U
Back to top
View user's profile Send private message
laoshi
n00b
n00b


Joined: 23 Jul 2003
Posts: 44

PostPosted: Thu Nov 23, 2006 1:43 pm    Post subject: Reply with quote

Not for me :( to 100%

When i then want to install vte, mesa+glu will be insalled again aswell.
So i added -opengl to my use flags, although i'd like to have opengl support of course :/
Back to top
View user's profile Send private message
ShodoPan
n00b
n00b


Joined: 20 Dec 2006
Posts: 14

PostPosted: Wed Dec 20, 2006 8:53 am    Post subject: Reply with quote

You guys are heroes. If only I had found this post five hours earlier >.<
Back to top
View user's profile Send private message
mose
Guru
Guru


Joined: 04 Jun 2005
Posts: 313
Location: Piacenza

PostPosted: Sat Dec 30, 2006 1:07 am    Post subject: Reply with quote

It seems that it isn't solved for me...
I get this error compiling vte
Code:

checking for VTE... yes
checking for freetype-config... /usr/bin/freetype-config
checking for FreeType - version >= 6.1.0... no
*** The FreeType test program failed to run.  If your system uses
*** shared libraries and they are installed outside the normal
*** system library path, make sure the variable LD_LIBRARY_PATH
*** (or whatever is appropiate for your system) is correctly set.
configure: error: You must have freetype 2.0.2 or later to build vte.

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/vte-0.14.1/work/vte-0.14.1/config.log

!!! ERROR: x11-libs/vte-0.14.1 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  ebuild.sh, line 1255:   Called gnome2_src_compile
  gnome2.eclass, line 70:   Called gnome2_src_configure
  gnome2.eclass, line 66:   Called econf '--disable-debugging' '--enable-python' '--with-glX' '--with-xft2' '--with-pangox' '--disable-gtk-doc'
  ebuild.sh, line 540:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.

The ideas suggested didn't work for me!
I can't emerge vte... so I can't go on in compiling gnome 8O
Back to top
View user's profile Send private message
chaosape
n00b
n00b


Joined: 10 Oct 2006
Posts: 2

PostPosted: Thu Mar 01, 2007 4:49 am    Post subject: Quick Fix Reply with quote

I fixed the problem by adding:
x11-libs/vte* -opengl
to /etc/portage/package.use

--- scratch that

somehow during the emerge world the nvidia install got f'd. I reinstalled the nvidia drivers and things went smoothly.
Back to top
View user's profile Send private message
Argetlam
n00b
n00b


Joined: 09 Jan 2007
Posts: 14

PostPosted: Wed Mar 07, 2007 3:21 pm    Post subject: Reply with quote

I am getting this error now. I tried the above with removing the 'glu' and 'mesa' and it puts them back in. I see the way to do it with adding the '-opengl' USE flag. Is there a way to fix this without added that? Or if I just add that flag to just 'vte' will it affect OpenGL for the whole system or just certain things?

I don't have nvidia. It's a Laptop and I have the Intel i810 chipset graphics.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum