Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200605-08 ] PHP: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1569

PostPosted: Mon May 08, 2006 7:26 pm    Post subject: [ GLSA 200605-08 ] PHP: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: PHP: Multiple vulnerabilities (GLSA 200605-08)
Severity: high
Exploitable: remote
Date: May 08, 2006
Updated: May 15, 2007
Bug(s): #127939, #128883, #131135, #133524
ID: 200605-08

Synopsis

PHP is affected by multiple issues, including a buffer overflow in wordwrap() which may lead to execution of arbitrary code.

Background

PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.

Affected Packages

Package: dev-lang/php
Vulnerable: < 5.1.4
Unaffected: >= 5.1.4
Unaffected: >= 4.4.2-r2 < 4.4.3
Unaffected: >= 4.4.3-r1 < 4.4.4
Unaffected: >= 4.4.4-r4 < 4.4.5
Unaffected: >= 4.4.6 < 4.4.7
Unaffected: >= 4.4.7
Architectures: arm hppa ppc s390 sh sparc x86 x86-fbsd

Package: dev-lang/php
Vulnerable: < 5.1.4-r4
Unaffected: >= 5.1.4-r4
Unaffected: >= 4.4.2-r6 < 4.4.3
Unaffected: >= 4.4.3-r1 < 4.4.4
Unaffected: >= 4.4.4-r4 < 4.4.5
Unaffected: >= 4.4.6 < 4.4.7
Unaffected: >= 4.4.7
Architectures: alpha amd64 ia64 ppc64


Description

Several vulnerabilities were discovered on PHP4 and PHP5 by Infigo, Tonu Samuel and Maksymilian Arciemowicz. These included a buffer overflow in the wordwrap() function, restriction bypasses in the copy() and tempname() functions, a cross-site scripting issue in the phpinfo() function, a potential crash in the substr_compare() function and a memory leak in the non-binary-safe html_entity_decode() function.

Impact

Remote attackers might be able to exploit these issues in PHP applications making use of the affected functions, potentially resulting in the execution of arbitrary code, Denial of Service, execution of scripted contents in the context of the affected site, security bypass or information leak.

Workaround

There is no known workaround at this point.

Resolution

All PHP users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose dev-lang/php


References

CVE-2006-0996
CVE-2006-1490
CVE-2006-1990
CVE-2006-1991


Last edited by GLSA on Wed May 16, 2007 4:18 am; edited 8 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum