Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200605-06 ] Mozilla Firefox: Potential remote code execution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Sat May 06, 2006 6:26 pm    Post subject: [ GLSA 200605-06 ] Mozilla Firefox: Potential remote code ex Reply with quote

Gentoo Linux Security Advisory

Title: Mozilla Firefox: Potential remote code execution (GLSA 200605-06)
Severity: normal
Exploitable: remote
Date: May 06, 2006
Bug(s): #131138
ID: 200605-06

Synopsis


The Mozilla Firefox 1.5 line is vulnerable to a buffer overflow in the
JavaScript extension which may in theory lead to remote execution of
arbitrary code.


Background


Mozilla Firefox is the next-generation web browser from the
Mozilla project.


Affected Packages

Package: www-client/mozilla-firefox
Vulnerable: < 1.5.0.3
Unaffected: >= 1.5.0.3
Unaffected: < 1.5
Architectures: All supported architectures

Package: www-client/mozilla-firefox-bin
Vulnerable: < 1.5.0.3
Unaffected: >= 1.5.0.3
Unaffected: < 1.5
Architectures: All supported architectures


Description


Martijn Wargers and Nick Mott discovered a vulnerability when
rendering malformed JavaScript content. The Mozilla Firefox 1.0 line is
not affected.


Impact


If JavaScript is enabled, by tricking a user into visiting a
malicious web page which would send a specially crafted HTML script
that contains references to deleted objects with the "designMode"
property enabled, an attacker can crash the web browser and in theory
manage to execute arbitrary code with the rights of the user running
the browser.


Workaround


There is no known workaround at this time.


Resolution


All Mozilla Firefox 1.5 users should upgrade to the latest
version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-1.5.0.3"

All Mozilla Firefox 1.5 binary users should upgrade to the
latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-bin-1.5.0.3"


References

CVE-2006-1993


Last edited by GLSA on Sun Dec 18, 2011 4:21 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum