Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
K3B emerge problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Mizutsuki
n00b
n00b


Joined: 02 Feb 2006
Posts: 36

PostPosted: Mon Apr 24, 2006 9:49 pm    Post subject: K3B emerge problem Reply with quote

Code:
lib64 -L/usr/qt/3/lib64 -L/usr/lib64    -L/usr/kde/3.4/lib64 -version-info 2:1:0 -no-undefined k3bdevice.lo k3bdevice_mmc.lo k3bscsicommand.lo k3btrack.lo k3btoc.lo k3bdevicemanager.lo k3bmsf.lo k3bdiskinfo.lo k3bdeviceglobals.lo k3bcrc.lo k3bcdtext.lo k3bhalconnection.lo -lkio   -L/usr/lib64 -lhal -L/usr/lib64 -ldbus-1 -L/usr/lib -ldbus-qt-1 -lm -L/usr/kde/3.4/lib64 -L/usr/qt/3/lib64 -L/usr/lib64    -L/usr/kde/3.4/lib64
grep: /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/libstdc++.la: No such file or directory
/bin/sed: can't read /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/libstdc++.la: No such file or directory
libtool: link: `/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/libstdc++.la' is not a valid libtool archive
make[2]: *** [libk3bdevice.la] Error 1
make[2]: Leaving directory `/var/tmp/portage/k3b-0.12.14/work/k3b-0.12.14/libk3bdevice'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/k3b-0.12.14/work/k3b-0.12.14'
make: *** [all] Error 2

!!! ERROR: app-cdr/k3b-0.12.14 failed.
!!! Function kde_src_compile, Line 226, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.


That's what the end of the emerge looks like. I had some similar looking problems earlier with Amarok, and arts before that. I solved those by unmerging the packages. I need K3B, though. I tried installing libstdc++, but that didn't change anything. Any ideas?

Thank you,
Stephen Cilley
Back to top
View user's profile Send private message
seren
Guru
Guru


Joined: 27 Aug 2005
Posts: 448
Location: Wisconsin

PostPosted: Tue Apr 25, 2006 3:44 am    Post subject: Reply with quote

paste emerge --info
Back to top
View user's profile Send private message
brazzmonkey
Guru
Guru


Joined: 16 Jan 2005
Posts: 372
Location: between azerty keyboard and chair

PostPosted: Tue Apr 25, 2006 7:42 am    Post subject: Reply with quote

first i had this problem.
i retried to emerge it, but now i get an error when portage untars k3b-i18n. i downloaded it again, but same thing happens. i'm stocked here.

*edit* i had a filesystem error... everything's fine now


Last edited by brazzmonkey on Tue Apr 25, 2006 7:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
JeliJami
Veteran
Veteran


Joined: 17 Jan 2006
Posts: 1086
Location: Belgium

PostPosted: Tue Apr 25, 2006 8:54 am    Post subject: Reply with quote

http://forums.gentoo.org/viewtopic-t-318790.html
http://forums.gentoo.org/viewtopic.php?t=279020
http://forums.gentoo.org/viewtopic-t-279136.html
_________________
Unanswered Post Initiative | Search | FAQ
Former username: davjel
Back to top
View user's profile Send private message
step
Apprentice
Apprentice


Joined: 16 May 2002
Posts: 198

PostPosted: Fri Apr 28, 2006 7:18 pm    Post subject: Reply with quote

similar problem here with app-cdr/k3b-0.12.14

Code:
...k3bdvdformattingjob.cpp:(.text+0x1886): undefined reference to `K3bDevice::DiskInfo::empty() const'
k3bdvdformattingjob.cpp:(.text+0x206d): undefined reference to `K3bDevice::mediaTypeString(int, bool)'
k3bdvdformattingjob.cpp:(.text+0x2384): undefined reference to `K3bDevice::mediaTypeString(int, bool)'
jobs/.libs/libjobs.a(k3bblankingjob.o): In function `K3bBlankingJob::slotStartErasing()':
k3bblankingjob.cpp:(.text+0x445): undefined reference to `K3bDevice::Device::devicename() const'
jobs/.libs/libjobs.a(k3bblankingjob.o): In function `K3bBlankingJob::start()':
k3bblankingjob.cpp:(.text+0x76b): undefined reference to `K3bDevice::Device::mountDevice() const'
k3bblankingjob.cpp:(.text+0x7fc): undefined reference to `K3bDevice::Device::mountPoint() const'
jobs/.libs/libjobs.a(k3bclonetocreader.o): In function `K3bCloneTocReader::readFile()':
k3bclonetocreader.cpp:(.text+0x23d): undefined reference to `K3bDevice::from2Byte(unsigned char*)'
collect2: ld returned 1 exit status
libtool: install: error: relink `libk3b.la' with the above command before installing it
make[3]: *** [install-libLTLIBRARIES] Error 1
make[3]: Leaving directory `/var/tmp/portage/k3b-0.12.14/work/k3b-0.12.14/libk3b'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/var/tmp/portage/k3b-0.12.14/work/k3b-0.12.14/libk3b'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/k3b-0.12.14/work/k3b-0.12.14/libk3b'
make: *** [install-recursive] Error 1

!!! ERROR: app-cdr/k3b-0.12.14 failed.
!!! Function kde_src_install, Line 251, Exitcode 2
!!! died running make install, kde_src_install:make
!!! If you need support, post the topmost build error, NOT this status message.


update 29.04.2006 10:10:

looks like:
Code:

$ gcc -dumpversion
3.4.5

$ fix_libtool_files.sh 3.4.5


will fix the problem.
Back to top
View user's profile Send private message
Mizutsuki
n00b
n00b


Joined: 02 Feb 2006
Posts: 36

PostPosted: Sun Apr 30, 2006 10:49 pm    Post subject: Reply with quote

No compination of fix_libtool_files.sh and any number that resembles any gcc version works, any other thoughts?
Stephen Cilley
Back to top
View user's profile Send private message
Mizutsuki
n00b
n00b


Joined: 02 Feb 2006
Posts: 36

PostPosted: Mon May 01, 2006 3:20 pm    Post subject: Reply with quote

seren wrote:
paste emerge --info


$ emerge --info
Portage 2.0.54 (default-linux/amd64/2005.1, gcc-3.4.5, glibc-2.3.5-r3, 2.6.15-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.15-gentoo-r1 x86_64 Intel(R) Pentium(R) 4 CPU 3.20GHz
Gentoo Base System version 1.6.14
dev-lang/python: 2.3.5, 2.4.2
dev-util/ccache: [Not Present]
dev-util/confcache: [Not Present]
sys-apps/sandbox: 1.2.12
sys-devel/autoconf: 2.13, 2.59-r7
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils: 2.16.1
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=nocona"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=nocona"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://cudlug.cudenver.edu/gentoo/ ftp://gentoo.mirrors.pair.com/ http://mirror.usu.edu/mirrors/gentoo/"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="amd64 X aac acpi alsa asf audiofile avi berkdb bitmap-fonts bzip2 cdr cli crypt cups curl dri dts dvd dvdr dvdread eds emboss encode esd exif expat fam ffmpeg firefox foomaticdb fortran gif glut gmp gnome gpm gstreamer gtk gtk2 gtkhtml hal howl idn ieee1394 imagemagick imlib ipv6 isdnlog java jpeg kde lcms lm_sensors lzw lzw-tiff mad matroska mikmod mng motif mp3 mpeg ncurses nfs nls nvidia ogg openal opengl pam pcre pdflib perl png pppd python qt quicktime readline reflection sdl session spell spl ssl tcpd tiff truetype truetype-fonts type1-fonts udev usb vorbis wifi xine xml xml2 xmms xorg xpm xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset: ASFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
simon pants
n00b
n00b


Joined: 30 Apr 2004
Posts: 47

PostPosted: Wed May 03, 2006 10:42 pm    Post subject: Reply with quote

Sorry dude. Did you solve this one? I have the same problem and no posted solution works for me. Including those in this thread...

..cheers, Simon
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum