Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[BOOT] kernel panic au boot [résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Baby-Herman
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2005
Posts: 87

PostPosted: Fri Apr 14, 2006 7:59 pm    Post subject: [BOOT] kernel panic au boot [résolu] Reply with quote

j'ai ce message au boot (au redémarage de mon install)

VFS: cannot open root device "sda7" or unknow-block (0,0)
please append a correct "root=" boot option
Kernel panic_not syncing :VFS: unable to mount root fs on unknow-block (0,0)


je vous donne mon partitionnement:

Code:
The number of cylinders for this disk is set to 20023.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/sda: 164.6 GB, 164696555520 bytes
255 heads, 63 sectors/track, 20023 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        2040    16386268+   7  HPFS/NTFS
/dev/sda2            2041       10355    66790237+   7  HPFS/NTFS
/dev/sda3           10356       11630    10241437+   7  HPFS/NTFS
/dev/sda4           11631       13211    12699382+   5  Extended
/dev/sda5           11631       11631        8001   83  Linux
/dev/sda6           11632       11754      987966   82  Linux swap / Solaris
/dev/sda7           11755       13211    11703321   83  Linux

Command (m for help):


mon grub.conf

Code:
default 0
timeout 30

title=Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1

title=Gentoo Linux
root (hd0,4)
kernel /kernel1 root=/dev/sda7 vga=0x31B


je fourni aussi mon fichier .config du kernel
http://bhfrancois.free.fr/kernel.config

:oops: le problème c'est que je ne trouve pas du tout d'ou viens ce problème.

J'ai une machine à base d'amd 64 (1 core) avec un carte mère nf4 (gigabyte GA-K8NF-9)
merci de votre aide

EDIT: je précise que le nom du kernel dans /boot/ (sda5) est bien kernel1 (c'est pas tres accadémique mais j'ai toujours la flemme de taper des noms à ralonges :lol:)


Last edited by Baby-Herman on Mon Apr 17, 2006 9:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 898
Location: France

PostPosted: Fri Apr 14, 2006 9:34 pm    Post subject: Reply with quote

Quel est le sytème de fichiers de sda7 ?
Back to top
View user's profile Send private message
Baby-Herman
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2005
Posts: 87

PostPosted: Fri Apr 14, 2006 10:08 pm    Post subject: Reply with quote

ext3 ;)
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3755
Location: Lyon, France

PostPosted: Fri Apr 14, 2006 10:21 pm    Post subject: Reply with quote

Je pense qu'il te manque ceci dans ton noyau :
Code:
 <*>   SCSI disk support

_________________
Google+ | Twitter
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 898
Location: France

PostPosted: Fri Apr 14, 2006 10:31 pm    Post subject: Reply with quote

tu as ces trois modules en dur ?
sata_nv
libata
scsi_mod
Back to top
View user's profile Send private message
Baby-Herman
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2005
Posts: 87

PostPosted: Sat Apr 15, 2006 10:54 am    Post subject: Reply with quote

salut, j'ai ça:

SCSI device support
SCSI logging facility

SCSI lowlevel drivers --->
SERIAL ATA support
NVIDIA SATA support


je ne trouve pas libata
Back to top
View user's profile Send private message
Baby-Herman
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2005
Posts: 87

PostPosted: Sat Apr 15, 2006 2:59 pm    Post subject: Reply with quote

help
Back to top
View user's profile Send private message
Baby-Herman
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2005
Posts: 87

PostPosted: Mon Apr 17, 2006 11:37 am    Post subject: Reply with quote

up (toujours pas trouvé)
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3755
Location: Lyon, France

PostPosted: Mon Apr 17, 2006 11:54 am    Post subject: Reply with quote

T'as rajouté "SCSI disk support" aussi, comme je l'ai dis avant ?
_________________
Google+ | Twitter
Back to top
View user's profile Send private message
Baby-Herman
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2005
Posts: 87

PostPosted: Mon Apr 17, 2006 5:59 pm    Post subject: Reply with quote

c'est pas ça "SCSI device support" ?
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3755
Location: Lyon, France

PostPosted: Mon Apr 17, 2006 6:19 pm    Post subject: Reply with quote

En clair, ma config pour le sata sur mon laptop (à savoir que mon dvd est sur sata aussi, donc ne t'occupe pas du cdrom ici) :
Code:
--- SCSI device support
[*]   legacy /proc/scsi/ support
---   SCSI support type (disk, tape, CD-ROM)
<*>   SCSI disk support
< >   SCSI tape support
< >   SCSI OnStream SC-x0 tape support
<*>   SCSI CDROM support
[ ]     Enable vendor-specific extensions (for SCSI CDROM)
<*>   SCSI generic support
< >   SCSI media changer support
---   Some SCSI devices (e.g. CD jukebox) support multiple LUNs
[ ]   Probe all LUNs on each SCSI device
[ ]   Verbose SCSI error reporting (kernel size +=12K)
      SCSI low-level drivers  --->
        <*> Serial ATA (SATA) support
          <*>   AHCI SATA support
          <*>   Intel PIIX/ICH SATA support

Côté support SATA, laisse comme t'as mis, et regarde pour le reste si ça règle ton pb ...
_________________
Google+ | Twitter
Back to top
View user's profile Send private message
Baby-Herman
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2005
Posts: 87

PostPosted: Mon Apr 17, 2006 9:56 pm    Post subject: Reply with quote

en effet c'était bien ça :
<*> SCSI disk support

je me demande comment je l'avais pas vu

merci :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum