Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Opera and 'libjvm.so', 'libawt.so' errors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
MickKi
Veteran
Veteran


Joined: 08 Feb 2004
Posts: 1104
Location: 51:45:20N, 0:40:44W

PostPosted: Sun Jul 24, 2005 6:41 pm    Post subject: Opera and 'libjvm.so', 'libawt.so' errors Reply with quote

For a couple of days now I keep getting these errors on the console from which I start X, when I launch Opera (tried both 8.00 and 8.01 versions):
Code:
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.

Any idea what this is and what has brought it about?
_________________
Regards,
Mick
Back to top
View user's profile Send private message
Chaosite
Guru
Guru


Joined: 13 Dec 2003
Posts: 540
Location: Right over here.

PostPosted: Sun Jul 24, 2005 10:37 pm    Post subject: Reply with quote

Upgraded java recently?
Back to top
View user's profile Send private message
MickKi
Veteran
Veteran


Joined: 08 Feb 2004
Posts: 1104
Location: 51:45:20N, 0:40:44W

PostPosted: Mon Jul 25, 2005 12:30 pm    Post subject: Reply with quote

Chaosite wrote:
Upgraded java recently?
Nope, I don't have Java on my machine . . . :?
_________________
Regards,
Mick
Back to top
View user's profile Send private message
MickKi
Veteran
Veteran


Joined: 08 Feb 2004
Posts: 1104
Location: 51:45:20N, 0:40:44W

PostPosted: Wed Jul 27, 2005 2:31 pm    Post subject: Reply with quote

Update: I am also getting this error on a second box of mine . . . different hardware and some different apps, but the same error appears. This box also has no java installed. Opera is very unstable on this second box . . . it crashes more often than the first box I wrote about above. :(

Any more ideas on these libjvm.so and libawt.so errors?
_________________
Regards,
Mick
Back to top
View user's profile Send private message
GizzmoAsus
n00b
n00b


Joined: 23 May 2004
Posts: 46
Location: (Blackburn / Lougborough) UK

PostPosted: Sat Jul 30, 2005 11:02 am    Post subject: Reply with quote

Hi, I'm also having this problem. The only thing I have changed recently is the following:
Code:

emerge world -uDav
sys-devel/libperl-5.8.6-r1 [5.8.5]
dev-lang/perl-5.8.6-r5 [5.8.5-r5]
app-admin/perl-cleaner-1.01
sys-apps/utempter-0.5.5.6 [0.5.5.5-r1]
dev-libs/libol-0.3.16 [0.3.15]
app-admin/syslog-ng-1.6.8 [1.6.7]
app-emulation/emul-linux-x86-baselibs-2.2 [2.1.1]
kde-base/kmailcvt-3.4.1-r1

Not to sure but I think it has something to do with the libol update although I probably am wrong. Am working on a sloution and will post my results shortly.
_________________
[see my website as it develops]
Back to top
View user's profile Send private message
Joffer
Guru
Guru


Joined: 10 Sep 2002
Posts: 585
Location: Arendal, Norway

PostPosted: Wed Aug 03, 2005 12:51 am    Post subject: Reply with quote

On my system I get this when I start Opera:
Code:
$ opera
cat: /home/joffer/.qt/qtrc: No such file or directory
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.


A check on my system says:
Code:
# equery belongs libawt.so
[ Searching for file(s) libawt.so in *... ]
dev-java/sun-jdk-1.5.0.04 (/opt/sun-jdk-1.5.0.04/jre/lib/amd64/libawt.so)


Are you guys on a AMD64 system too? I am. I've got a thread here: http://forums.gentoo.org/viewtopic-t-365918-highlight-.html

I had trouble just to start Opera, but not it's these error messages that irritates me. Opera starts just fine, but I don't have java support. Perhaps it's because of these errors.. "opera:about" also complains "No Java Runtime Environment installed" :(
_________________
As of April 2006 - Athlon64 X2 4200+ 1GB RAM - amd64-2006.0 profiled system with portage 2.1_preX, ck-sources-2.6.16, glibc-2.4-r1 (overlay w/-Bdirect&-hashvals), binutils-2.16.91.0.6 (overlay), gcc-4.1, Xorg 7
Back to top
View user's profile Send private message
wol
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jun 2002
Posts: 107

PostPosted: Mon Aug 08, 2005 9:40 am    Post subject: Similar error message, different library Reply with quote

I'm getting a similar error message but in a completely different context.

ERROR: ld.so: object 'libGL.so' from LD_PRELOAD cannot be preloaded: ignored.

Strangely enough, it is occuring loading a console or if I su to another user. Does not seem to have any adverse affect other than be annoying.
_________________
Intellectual dishonesty is a mortal sin.
Back to top
View user's profile Send private message
mikeliuk
n00b
n00b


Joined: 15 Dec 2004
Posts: 17
Location: United Kingdom

PostPosted: Sat Aug 12, 2006 4:42 pm    Post subject: Reply with quote

Posting for completeness. Saw
Quote:
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.

for Opera 9.01 on ~amd64. Looking on "www.opera.com", it seems most likely that we are provided with a 32-bit binary package so, for AMD64, we want to emerge "emul-linux-x86-java" and point Opera to "/opt/java32/lib/i386/".

Opera:about will then show "Java Runtime Environment installed".
_________________
mic_L Blackburn UK
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum