Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200603-22 ] PHP: Format string and XSS vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Wed Mar 22, 2006 11:26 pm    Post subject: [ GLSA 200603-22 ] PHP: Format string and XSS vulnerabilitie Reply with quote

Gentoo Linux Security Advisory

Title: PHP: Format string and XSS vulnerabilities (GLSA 200603-22)
Severity: normal
Exploitable: remote
Date: March 22, 2006
Bug(s): #125878
ID: 200603-22

Synopsis

Multiple vulnerabilities in PHP allow remote attackers to inject arbitrary HTTP headers, perform cross site scripting or in some cases execute arbitrary code.

Background

PHP is a general-purpose scripting language widely used to develop web-based applications. It can run on a web server with the mod_php module or the CGI version and also stand-alone in a CLI.

Affected Packages

Package: dev-lang/php
Vulnerable: < 4.4.2
Vulnerable: >= 5.1.1 < 5.1.2
Vulnerable: >= 5.0.5 < 5.0.6
Vulnerable: >= 5.0.4 < 5.0.5
Unaffected: >= 5.1.2
Architectures: All supported architectures


Description

Stefan Esser of the Hardened PHP project has reported a few vulnerabilities found in PHP:
  • Input passed to the session ID in the session extension isn't properly sanitised before being returned to the user via a "Set-Cookie" HTTP header, which can contain arbitrary injected data.
  • A format string error while processing error messages using the mysqli extension in version 5.1 and above.


Impact

By sending a specially crafted request, a remote attacker can exploit this vulnerability to inject arbitrary HTTP headers, which will be included in the response sent to the user. The format string vulnerability may be exploited to execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All PHP 5.x users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-5.1.2"
All PHP 4.x users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-4.4.2"


References

CVE-2006-0207
CVE-2006-0208
Hardened-PHP Advisory 01/2006
Hardened-PHP Advisory 02/2006


Last edited by GLSA on Sun May 07, 2006 5:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum