Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200603-18 ] Pngcrush: Buffer overflow
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Tue Mar 21, 2006 2:26 pm    Post subject: [ GLSA 200603-18 ] Pngcrush: Buffer overflow Reply with quote

Gentoo Linux Security Advisory

Title: Pngcrush: Buffer overflow (GLSA 200603-18)
Severity: normal
Exploitable: remote
Date: March 21, 2006
Bug(s): #123286
ID: 200603-18

Synopsis


Pngcrush is vulnerable to a buffer overflow which could potentially lead to
the execution of arbitrary code.


Background


Pngcrush is an optimizer for PNG files.


Affected Packages

Package: media-gfx/pngcrush
Vulnerable: < 1.6.2
Unaffected: >= 1.6.2
Architectures: All supported architectures


Description


Carsten Lohrke of Gentoo Linux reported that Pngcrush contains a
vulnerable version of zlib (GLSA 200507-19).


Impact


By creating a specially crafted data stream, attackers can
overwrite data structures for applications that use Pngcrush, resulting
in a Denial of Service and potentially arbitrary code execution.


Workaround


There is no known workaround at this time.


Resolution


All Pngcrush users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=media-gfx/pngcrush-1.6.2"


References

GLSA 200507-19
CVE-2005-1849


Last edited by GLSA on Sat May 17, 2014 4:22 am; edited 4 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum