Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge fontconfig-2.4.2 fails [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
emil
n00b
n00b


Joined: 10 Feb 2003
Posts: 44
Location: Ireland

PostPosted: Fri Nov 16, 2007 1:13 pm    Post subject: emerge fontconfig-2.4.2 fails [solved] Reply with quote

When doing an
Code:

emerge --update --deep --newuse world

lately, I ran into some problems relating to expat. There is a very informative thread about that problem, and the recommended solution is to do:
Code:

emerge fontconfig
emerge pango
emerge gtk+

However, when trying just that it fails already when emerging fontconfig, with loads of docbookrelated errors:
Code:

docbook2man ../fc-cache/fc-cache.sgml
Using catalogs: /etc/sgml/sgml-docbook-4.1.cat
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl#print
Working on: /var/tmp/portage/media-libs/fontconfig-2.4.2/work/fontconfig-2.4.2/fc-cache/../fc-cache/fc-cache.sgml
nsgmls:/usr/share/sgml/docbook/sgml-dtd-4.1/dbcent.mod:53:65:W: cannot generate system identifier for public text "ISO 8879:1986//ENTITIES Added Math Symbols: Arrow Relations//EN"
nsgmls:/usr/share/sgml/docbook/sgml-dtd-4.1/dbcent.mod:54:8:E: reference to entity "ISOamsa" for which no system identifier could be generated
nsgmls:/usr/share/sgml/docbook/sgml-dtd-4.1/dbcent.mod:52:0: entity was defined here
nsgm
[... lots of like lines ...]
docbook2man ../fc-cache/fc-cache.sgml
Using catalogs: /etc/sgml/sgml-docbook-4.1.cat
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl#print
Working on: /var/tmp/portage/media-libs/fontconfig-2.4.2/work/fontconfig-2.4.2/fc-cache/../fc-cache/fc-cache.sgml
nsgmls:/usr/share/sgml/docbook/sgml-dtd-4.1/dbcent.mod:53:65:W: cannot generate system identifier for public text "ISO 8879:1986//ENTITIES Added Math Symbols: Arrow Relations//EN"
nsgmls:/usr/share/sgml/docbook/sgml-dtd-4.1/dbcent.mod:54:8:E: reference to entity "ISOamsa" for which no system identifier could be generated
nsgmls:/usr/share/sgml/docbook/sgml-dtd-4.1/dbcent.mod:52:0: entity was defined here
nsgm
[... again, lots of those ...]

[ ... more similar errors ...]

jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.79/html/../common/../common/dbl1sr.dsl:2:66:W: cannot generate system identifier for public text "ISO 8879:1986//ENTITIES Added Latin 2//EN"
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.79/html/../common/../common/dbl1sr.dsl:3:5:E: reference to entity "lat2" for which no system identifier could be generated
jade:/usr/share/sgml/docbook/dsssl-stylesheets-1.79/html/../common/../common/dbl1sr.dsl:2:0: entity was defined here
make[2]: *** [fontconfig-user.txt] Error 8
make[2]: Leaving directory `/var/tmp/portage/media-libs/fontconfig-2.4.2/work/fontconfig-2.4.2/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/fontconfig-2.4.2/work/fontconfig-2.4.2'
make: *** [all] Error 2
*
*ERROR: media-libs/fontconfig-2.4.2 failed.
* Call stack:
*                 ebuild.sh, line 1701:  Called dyn_compile
*                 ebuild.sh, line 1039:  Called qa_call 'src_compile'
*                 ebuild.sh, line   44:  Called src_compile
*   fontconfig-2.4.2.ebuild, line   50:  Called die
* The specific snippet of code:
*      emake -j1 || die
*  The die message:
*   (no error message)
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/log/portage/media-libs:fontconfig-2.4.2:20071116-124345.log'.
*

My guess is that I could avoid this by disabling the USE flags xml and/or doc, but is there a better fix? Suggestions most welcome

Emil


Last edited by emil on Mon Nov 19, 2007 3:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 818
Location: Vancouver, BC

PostPosted: Sat Nov 17, 2007 1:49 am    Post subject: Reply with quote

When updating expat, you should also [re-]emerge gettext and XML-Parser. I suspect the latter may solve your problem.
Back to top
View user's profile Send private message
emil
n00b
n00b


Joined: 10 Feb 2003
Posts: 44
Location: Ireland

PostPosted: Mon Nov 19, 2007 3:41 pm    Post subject: Reply with quote

Thanks for your suggestion; it did not work, but some more searching on the forum showed similar problems and the suggested fix - clean out all sgml related packages completely and reinstall - worked. :D

Now - how do I change the subject of the thread to include a "solved" ?
Back to top
View user's profile Send private message
emil
n00b
n00b


Joined: 10 Feb 2003
Posts: 44
Location: Ireland

PostPosted: Mon Nov 19, 2007 3:43 pm    Post subject: Reply with quote

emil wrote:
Now - how do I change the subject of the thread to include a "solved" ?


Found it out.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum