Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
apache emerge failed (what's the best way to fix this?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
bigV
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2002
Posts: 102
Location: Southampton, UK

PostPosted: Tue Apr 05, 2005 9:24 pm    Post subject: apache emerge failed (what's the best way to fix this?) Reply with quote

I am trying to emerge nagios-core which fails on the installation of net-www/apache-1.3.33-r2.
A brief breakdown ...
Quote:
>>> emerge (1 of 7) net-www/apache-1.3.33-r2 to /
>>> md5 src_uri ;-) apache_1.3.33.tar.gz
>>> md5 src_uri ;-) mod_ssl-2.8.22-1.3.33.tar.gz
>>> md5 src_uri ;-) gentoo-apache-1.3.33-r2-20050320.tar.bz2
etc etc
* 7 patches to apply ...
* Applying 00_all_gentoo_base.patch ... [ ok ]
* Applying 00_all_gentoo_path2perl.patch ... [ ok ]
* Applying 01_all_db4_detect.patch ... [ ok ]
* Applying 02_all_gentoo_apachectl.patch ... [ ok ]
* Applying 03_amd64_regex.patch ... [ ok ]
* Applying 06_all_mod_rewrite_ampescape.patch ... [ ok ]
* Applying 07_all_mod_dir_incremental.patch ... [ ok ]
* Applying 31_all_gentoo_suexec_pam.patch ... [ ok ]
* Replacing obsolete head/tail with POSIX compliant ones
* - fixed src/Configure
* - fixed src/helpers/getuid.sh
* - fixed src/helpers/buildinfo.sh
* - fixed src/helpers/fmn.sh
* Applying eapi.patch ... [ ok ]
>>> Source unpacked.
* DATADIR is set to: /var/www/localhost
* /var/tmp/portage/apache-1.3.33-r2/work/gentoo-apache-1.3.33-r2/conf/apache-builtin-mods options:
etc etc
Configuring for Apache, Version 1.3.33
+ using installation path layout: Gentoo (config.layout)
Creating Makefile
Creating Configuration.apaci in src
+ enabling mod_so for DSO support
Creating Makefile in src
+ configured for Linux platform
+ setting C pre-processor to gcc -E
+ using "tr [a-z] [A-Z]" to uppercase
+ checking for system header files
+ using custom target name: apache
+ adding selected modules
o rewrite_module uses ConfigStart/End
disabling DBM support for mod_rewrite
(perhaps you need to add -ldbm, -lndbm or -lgdbm to EXTRA_LIBS)
o dbm_auth_module uses ConfigStart/End
o db_auth_module uses ConfigStart/End
Error: None of Berkeley-DB 1.x, 2.x or 3.x libraries found.
Either disable mod_auth_db or provide us with the paths
to the Berkeley-DB include and library files.
(Hint: INCLUDES, LDFLAGS, LIBS)
===> src
make[1]: Entering directory `/var/tmp/portage/apache-1.3.33-r2/work/apache_1.3.33'
make[2]: Entering directory `/var/tmp/portage/apache-1.3.33-r2/work/apache_1.3.33/src'
make[2]: *** No rule to make target `all'. Stop.
make[2]: Leaving directory `/var/tmp/portage/apache-1.3.33-r2/work/apache_1.3.33/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/var/tmp/portage/apache-1.3.33-r2/work/apache_1.3.33'
make: *** [build] Error 2


I have installed Berkely DB ....
Code:
sys-libs/db
      Latest version available: 4.2.52_p2
      Latest version installed: 4.2.52_p2
      Size of downloaded files: 3,980 kB
      Homepage:    http://www.sleepycat.com/
      Description: Berkeley DB
      License:     DB

So how do I go about fixing this so I can install Nagios

Thanks

bigV
_________________
perl -e "print qq^bIG VeRN ! ^^qq^#'#Yv#=<D+ ^"
Back to top
View user's profile Send private message
Shazam
Apprentice
Apprentice


Joined: 23 Nov 2004
Posts: 191
Location: Germany

PostPosted: Wed Apr 06, 2005 9:48 am    Post subject: Reply with quote

well, maybe try and emerge apache2 ? or is nagios-core (i don't know it) for apache-1.3 ?
Back to top
View user's profile Send private message
bigV
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2002
Posts: 102
Location: Southampton, UK

PostPosted: Wed Apr 06, 2005 9:53 am    Post subject: Reply with quote

nagios ( I can only assume ) uses apache 1.3
_________________
perl -e "print qq^bIG VeRN ! ^^qq^#'#Yv#=<D+ ^"
Back to top
View user's profile Send private message
tagore
Tux's lil' helper
Tux's lil' helper


Joined: 24 Oct 2002
Posts: 77
Location: Uruguay

PostPosted: Fri May 26, 2006 3:05 pm    Post subject: Reply with quote

i'have same error, any solution?
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sat May 27, 2006 1:01 am    Post subject: Reply with quote

Moved from Desktop Environments to Portage & Programming.
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4726
Location: Angra do Heroísmo (PT)

PostPosted: Sat May 27, 2006 1:12 am    Post subject: Reply with quote

Hi.

Actually, by looking at the nagios-core ebuild, I've noticed that nagios doesn't require apache-1.3 or apache at all.
If you want to use apache2, you need to add to your use flags apache2.
Code:
# USE="apache" emerge -pv nagios

If you don't want to use apache at all, add to your use flags noweb.
Code:
# USE="noweb" emerge -pv nagios

As always, the correct way is to add a line to /etc/portage/package.use with your desired use flags.
Code:
net-analyzer/nagios noweb

_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
tagore
Tux's lil' helper
Tux's lil' helper


Joined: 24 Oct 2002
Posts: 77
Location: Uruguay

PostPosted: Sat May 27, 2006 2:26 pm    Post subject: Reply with quote

I'need apache 1.3 installed, but i'have the same error , no way to install apache 2, some people have the same error, but no no solution ... any advise?
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4726
Location: Angra do Heroísmo (PT)

PostPosted: Sat May 27, 2006 3:03 pm    Post subject: Reply with quote

I've just noticed the following on the first post:
Code:
Error: None of Berkeley-DB 1.x, 2.x or 3.x libraries found.
Either disable mod_auth_db or provide us with the paths

As bigV has shown, he has db-4.2.52_p2 installed. I don't know if apache-1.3.33 supports db-4.
I was looking at https://bugs.gentoo.org and found this. Can you post the output of the following
Code:
# qlist -Iv sys-libs/db

_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum