Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[localisation] Problème de clavier sous KDE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
luteola
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2006
Posts: 118
Location: Bruxelles

PostPosted: Sat Mar 04, 2006 3:57 pm    Post subject: [localisation] Problème de clavier sous KDE Reply with quote

salut à tous,

Je suis un petit nouveau sur ce forum. N'hésitez pas à m'expliquer si je déroge aux régles établies ici.

Je viens de reinstaller une gentoo pour pouvoir m'amuser un peu sous XGL. Pour le moment, j'ai un pépin. Hors de X, mon clavier est nickel (be-latin1 pour être précis). Par contre, dans KDE, il me met en qwerty l'animal... D'hab, dans kcontrol,il faut aller dans Régionalisation > Disposition du clavier. Sous Gentoo-KDe 3.5.1, ca a disparu. Mon /etc/make.conf semble correcte ainsi que tout les autres. J'ai suivi le tuto sur la location de gentoo et ca ne résoud pas mon problème.

Une idée ?

Autre chose, je n'ai pas de fichier /etc/X11/xorg.conf. Seulement un /etc/X11/xorg.conf.example. Et pourtant j'arrive sous KDE... Comment c'est possible ça ? Je suis en ~x86 et je crois avoir installé le xorg modulaire. Mais sans vraiment en être sûr. Je suis pas encore très à l'aise sous Gentoo...

Merci beaucoup pour vos réponses !!

a+
_________________
www.guidelinux.org
________________________________________
Gentoo amd64 2007.0
Asus A8N32-SLI
AMD Athlon 4000+, 2Go DDR400
NVIDIA 7900GTX
Soundblaster Audigy 4
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Sat Mar 04, 2006 7:36 pm    Post subject: Reply with quote

luteola wrote:
Je suis un petit nouveau sur ce forum. N'hésitez pas à m'expliquer si je déroge aux régles établies ici.

Bienvenue sur le forum !
Pour les règles, c'est tout bon jusqu'ici ! :)
Quote:
Pour le moment, j'ai un pépin. Hors de X, mon clavier est nickel (be-latin1 pour être précis). Par contre, dans KDE, il me met en qwerty l'animal...

emerge kxkb kde-i18n ;)

Quote:
Autre chose, je n'ai pas de fichier /etc/X11/xorg.conf. Seulement un /etc/X11/xorg.conf.example. Et pourtant j'arrive sous KDE... Comment c'est possible ça ?

Ton xorg utilise probablement un fichier alternatif :
man xorg.conf wrote:
Xorg uses a configuration file called xorg.conf for its initial setup.
This configuration file is searched for in the following places when the
server is started as a normal user:

/etc/X11/<cmdline>
/usr/etc/X11/<cmdline>
/etc/X11/$XORGCONFIG
/usr/etc/X11/$XORGCONFIG
/etc/X11/xorg.conf-4
/etc/X11/xorg.conf
/etc/xorg.conf
/usr/etc/X11/xorg.conf.<hostname>
/usr/etc/X11/xorg.conf-4
/usr/etc/X11/xorg.conf
/usr/lib/X11/xorg.conf.<hostname>
/usr/lib/X11/xorg.conf-4
/usr/lib/X11/xorg.conf

Pour voir quel fichier est utilisé, examine le fichier de log :
Code:
bigben ~ # grep -i "Using config file" /var/log/Xorg.0.log
(==) Using config file: "/etc/X11/xorg.conf"
Back to top
View user's profile Send private message
luteola
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2006
Posts: 118
Location: Bruxelles

PostPosted: Sat Mar 04, 2006 8:51 pm    Post subject: Reply with quote

salut

le "emerge kxkb" c'est un coup de génie merci. KDE m'obéit à present :-)

Par contre:

Code:
localhost noordman # grep -i "Using config file" /var/log/Xorg.0.log
localhost noordman #


Une idée pour ca ? J'aimerais savoir où il se trouve vu que j'aurais surement à le modifier. Bon, sinon, je viens d'installer le xorg modulaire. Je continue vers XGL :p

merci !

a+
_________________
www.guidelinux.org
________________________________________
Gentoo amd64 2007.0
Asus A8N32-SLI
AMD Athlon 4000+, 2Go DDR400
NVIDIA 7900GTX
Soundblaster Audigy 4
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Sat Mar 04, 2006 10:34 pm    Post subject: Reply with quote

luteola wrote:
Code:
localhost noordman # grep -i "Using config file" /var/log/Xorg.0.log
localhost noordman #

Bizarre ça ! :?
Pourrais-tu poster les 30 premières lignes de /var/log/Xorg.0.log ?
Back to top
View user's profile Send private message
luteola
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2006
Posts: 118
Location: Bruxelles

PostPosted: Sat Mar 04, 2006 11:08 pm    Post subject: Reply with quote

re,

voila :

Quote:

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.15-1-586tsc i686
Current Operating System: Linux localhost 2.6.15-gentoo-r1 #2 SMP PREEMPT Sat Mar 4 23:29:00 CET 2006 i686
Build Date: 04 March 2006
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar 4 23:30:48 2006
(EE) Unable to locate/open config file
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.2
X.Org Video Driver: 0.8
X.Org XInput driver : 0.5
X.Org Server Extension : 0.2
X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.8
(++) using VT number 7


Je sais pas si c'est lié, mais je suis en train de me battre à installer XGL. Je bloque sur l'installation de la librairie Cario. C'est surement pas lié, mais ca m'énèrve bien :-)

merci pour ton aide en tout cas

a+
_________________
www.guidelinux.org
________________________________________
Gentoo amd64 2007.0
Asus A8N32-SLI
AMD Athlon 4000+, 2Go DDR400
NVIDIA 7900GTX
Soundblaster Audigy 4
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 898
Location: France

PostPosted: Sun Mar 05, 2006 12:00 am    Post subject: Reply with quote

Tu devrais faire un xorgconfig, répondre aux questions, et la tu aura un fichier deja a moitier fini.

Ton log indique que tu n'as aucun fichier de config pour X. Le fait que tu start X est juste un gros coup de chance
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum