Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200603-01 ] WordPress: SQL injection vulnerability
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Sat Mar 04, 2006 4:26 pm    Post subject: [ GLSA 200603-01 ] WordPress: SQL injection vulnerability Reply with quote

Gentoo Linux Security Advisory

Title: WordPress: SQL injection vulnerability (GLSA 200603-01)
Severity: normal
Exploitable: remote
Date: March 04, 2006
Bug(s): #121661
ID: 200603-01

Synopsis

WordPress is vulnerable to an SQL injection vulnerability.

Background

WordPress is a PHP and MySQL based content management and publishing system.

Affected Packages

Package: www-apps/wordpress
Vulnerable: <= 1.5.2
Unaffected: >= 2.0.1
Architectures: All supported architectures


Description

Patrik Karlsson reported that WordPress 1.5.2 makes use of an insufficiently filtered User Agent string in SQL queries related to comments posting. This vulnerability was already fixed in the 2.0-series of WordPress.

Impact

An attacker could send a comment with a malicious User Agent parameter, resulting in SQL injection and potentially in the subversion of the WordPress database. This vulnerability wouldn't affect WordPress sites which do not allow comments or which require that comments go through a moderator.

Workaround

Disable or moderate comments on your WordPress blogs.

Resolution

All WordPress users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/wordpress-2.0.1"


References

CVE-2006-1012


Last edited by GLSA on Sun Jan 27, 2008 4:18 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum