Joined: 12 May 2004
|Posted: Sat Mar 04, 2006 4:26 pm Post subject: [ GLSA 200603-01 ] WordPress: SQL injection vulnerability
|Gentoo Linux Security Advisory
Title: WordPress: SQL injection vulnerability (GLSA 200603-01)
Date: March 04, 2006
WordPress is vulnerable to an SQL injection vulnerability.
WordPress is a PHP and MySQL based content management and publishing system.
Vulnerable: <= 1.5.2
Unaffected: >= 2.0.1
Architectures: All supported architectures
Patrik Karlsson reported that WordPress 1.5.2 makes use of an insufficiently filtered User Agent string in SQL queries related to comments posting. This vulnerability was already fixed in the 2.0-series of WordPress.
An attacker could send a comment with a malicious User Agent parameter, resulting in SQL injection and potentially in the subversion of the WordPress database. This vulnerability wouldn't affect WordPress sites which do not allow comments or which require that comments go through a moderator.
Disable or moderate comments on your WordPress blogs.
All WordPress users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/wordpress-2.0.1"
Last edited by GLSA on Sun Jan 27, 2008 4:18 am; edited 3 times in total