Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO - Installing MaxDB 7.6 from sources [unmaintained]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
mundi
n00b
n00b


Joined: 27 Jun 2003
Posts: 57

PostPosted: Fri Aug 19, 2005 5:07 pm    Post subject: HOWTO - Installing MaxDB 7.6 from sources [unmaintained] Reply with quote

Hi Everyone !
last updated 06.01.2006

The aim of this howto ist to help people install MaxDB on gentoo systems from sources.
This is a very long running process (about 10h) and it can not be done totaly automatic.
The ebuilds that i provide need interaction at a given point where they will tell you what to do.

This is meant as an alternative to installing the binary version.
It is meant to be used by people who don't mind spending their time in endles compilation sessions

If you do not know why you should use MaxDB read John L. Singleton's "Musings on MaxDB, Five Reasons Why MaxDB Will Replace Your Current Database"
(http://www.johnsingleton.com/maxdb/2004/06/five-reasons-why-maxdb-will-replace.html).

The following points should help you to install maxdb.
I.) Before you start:
THESE EBUILDS DO NOT SUPPORT UPDATES.
If you have a running MaxDB instance on your system then:
    - BACKUP YOUR DATA
    - move the directory /opt/sdb to something like /opt/sdb.off
    - move the directory /usr/spool/sql to something like /usr/spool/sql.off
    - move the file /etc/opt/sdb to something like /etc/opt/sdb.off

II.) portage principle
1.) ebuilds that are not allready in the portage tree should be copied to a so called portage overlay directory.
if you do not allready have on, do the following:
Code:
- create a overlay directory. (normaly /usr/local/portage)
- add the overlay directory to you /etc/make.conf by adding a line like PORTDIR_OVERLAY=/usr/local/portage

2.) creating directories in the overlay directory
you should create directories for the ebuilds in the overlay directory:
Code:
- create a directory /usr/local/portage/dev-db/maxdb-devtools-src for the devtools.
- create a directory /usr/local/portage/dev-db/maxdb-src for the db-system

III.) Get the ebuilds
the ebuild you will need can be found in the bug system (bugs.gentoo.org).
    -> bug 42286 for the devtools
    -> bug 42465 for the db-system

1. Download the ebuilds into the directories:
Code:
- download maxdb-devtools-src-562049-r1.ebuild from bug 42286 and put it to /usr/local/portage/dev-db/maxdb-devtools-src
- create a /usr/local/portage/dev-db/maxdb-devtools-src/files directory for the patches
- download maxdb-devtools-src-562049.patch from bug 42286 and put it to /usr/local/portage/dev-db/maxdb-devtools-src/files
- download maxdb-src-7.6.0.16-r1.ebuild from bug 42465 and put it to /usr/local/portage/dev-db/maxdb-src
- create a /usr/local/portage/dev-db/maxdb-src/files directory for the patches
- download maxdb-source-7_6_0_16_ini.patch from bug 42465 and put it to /usr/local/portage/dev-db/maxdb-src/files
- download maxdb-source-7_6_0_16-r1_all.patch from bug 42465 and put it to /usr/local/portage/dev-db/maxdb-src/files

IV) Installation

1. Keywords
Both ebuils are masked with the keyword ~x86 (as they should be because they are not included in the official portage tree).
Add them to the /etc/portage/package.keywords by doing a:
Code:
- execute "echo dev-db/maxdb-devtools-src ~x86 >> /etc/portage/package.keywords"
- execute "echo dev-db/maxdb-src ~x86 >> /etc/portage/package.keywords"

2. install the devtools
Code:
- go to the /usr/local/portage/dev-db/maxdb-devtools-src directory

create the digest:
Code:
- execute "ebuild maxdb-devtools-src-562049-r1.ebuild digest"

emerge the devtools:
Code:
- execute "emerge maxdb-devtools-src"


You can ignore the warning and error at the end off the make process about the global SapDB registry it will be created by the ebuild later.

If this worked you should have your devtools in /opt/sdb/devtools.

3. Install the db system
FIRST (AGAIN): if you allready have a maxdb installation (or SAPDb) SAVE YOUR DATA !!!!
Code:
- go to the /usr/local/portage/dev-db/maxdb-src directory

create the digest:
Code:
- execute "ebuild maxdb-src-7.6.0.16-r1.ebuild digest"

emerge the db-system:
Code:
- execute "emerge maxdb-src"


- go to bed or to the next bar (you have got about 5 to 10 hours time now) :wink:
- at the end of the installation the ebuild will give some informations - follow them[/code]
When everthing works fine you got it.
V) Post Installation
1. Database Installation
If you dont know how to create a database instance
either
- see http://dev.mysql.com/doc/maxdb/install.html#install for manual installation
or
- start your MaxDB web-administartion server with something like the following script
Code:
export LD_LIBRARY_PATH="/opt/sdb/programs/lib:${LD_LIBRARY_PATH}"
export PATH="${PATH}:/opt/sdb/programs/bin"
cd /opt/sdb/programs/pgm
# start the webserver
./wahttp &
# start the db-server
/opt/sdb/programs/bin/x_server -Y start

- access the dbm-admin page with your web-browser at http://localhost:9999/webdbm
- click on "New Database" and follow the pages.

2. Information
Another very good source of information is http://sapdb.2scale.net the MaxDb Wiki Page

3. (And by god not least) THANX
Thanks to everybody who helped and still helps me to create and test this ebuilds.
Special thanks to:
*) Daniel Dittmar from SAP Labs Berlin - he is the guy who knows.
*) All the helpfull guys at the MaxDb mailing list (http://lists.mysql.com/maxdb)
*) Urs Joss, Dros, oldie, domlogic, cchee and the other guys from the forum who must have spent days testing the ebuils (big thanx guys)

If you have any problems or need help in what ever way fell free to contact me directly (hmun@thinkthinkdo.com) or even better post a forum message.

Last remark:
English is not my native language. So if there are typos or grammar erros please provide feedback.

Have fun - looking forward to your feedback - Mundi


Last edited by mundi on Sun Dec 17, 2006 5:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
linuxbum
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2003
Posts: 131
Location: USA

PostPosted: Sat Feb 04, 2006 3:06 pm    Post subject: Reply with quote

mundi;Traceback (most recent call last):
Well I'm trying to build maxdb here is the error I get

Code:

>>> Source unpacked.
python: can't open file '//usr/local/MAXDB/devtools/bin/newMaxdbSrc.py': [Errno 2] No such file or directory
 * Building target: all
/usr/local/portage/dev-db/maxdb-src/maxdb-src-7.6.0.16-r1.ebuild: line 123: devmaxdb: No such file or directory
/usr/local/portage/dev-db/maxdb-src/maxdb-src-7.6.0.16-r1.ebuild: line 124: imf: command not found



I have MAXDBROOT set to /usr/local/MAXDB where is installed the DEV TOOLS to.
The file is Located in
/usr/local/MAXDB/devtools/sys/src/Python/bin/newMaxdbSrc.py

I created a symbolic link and it errors out looking for another lib.
Code:

File "//usr/local/MAXDB/devtools/bin/newMaxdbSrc.py", line 215, in ?
    import optlib
ImportError: No module named optlib


So it looks like the DEV-tools/bin will continue to fail.

Bryan
Back to top
View user's profile Send private message
mundi
n00b
n00b


Joined: 27 Jun 2003
Posts: 57

PostPosted: Sat Feb 04, 2006 3:20 pm    Post subject: Reply with quote

linuxbum wrote:
mundi;Traceback (most recent call last):
Well I'm trying to build maxdb here is the error I get

...I have MAXDBROOT set to /usr/local/MAXDB where is installed the DEV TOOLS to.

Hi !
It seems that the ebuild for devtools did not really install to /usr/local/MAXDB.
I actually never tryed to set MAXDBROOT to a different location.

I would suggest that you let the ebuild install the devtools to the original location /opt/sdb while i will have a look at the ebuild.

regards mundi
Back to top
View user's profile Send private message
linuxbum
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2003
Posts: 131
Location: USA

PostPosted: Mon Feb 06, 2006 4:44 pm    Post subject: Reply with quote

Mundi
The "ed" command is used and was not installed.
So therewas a buried ERROR message in the emerge output that stated ed command not found.
Might add this to pre-req. listing in documentaion.
This time devtools is taking much longer to compile.
Will let you know if it installs this time.

It is compiling now after DEVTOOLS finished and I restart maxdb-src emerge.

So make a note that the ED command is used in your eubild.


Bryan
Back to top
View user's profile Send private message
mundi
n00b
n00b


Joined: 27 Jun 2003
Posts: 57

PostPosted: Mon Feb 06, 2006 8:03 pm    Post subject: Reply with quote

linuxbum wrote:
Mundi
The "ed" command is used and was not installed.
So therewas a buried ERROR message in the emerge output that stated ed command not found.
Might add this to pre-req. listing in documentaion.
Bryan

Thanks Bryan !
I added ED to the depend list of the ebuild for the next version (r3).
I will release this version together with the next maxdb version.
regards Mundi
Back to top
View user's profile Send private message
linuxbum
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2003
Posts: 131
Location: USA

PostPosted: Tue Feb 07, 2006 5:53 am    Post subject: Reply with quote

mundi

Here is the latest complie error for maxdb-src
I am lost on this one :)
:wink:
Code:

app/syncman/example/Readme_SyncManExample.txt
app/syncman/example/doc/SyncManExample.pdf
!tar -tzf  $INSTROOT/app/syncman/syncman.tgz > $WRK/fast/install/packages/syncma
n/syncman.lst
!echo app/syncman/syncman.zip >> $WRK/fast/install/packages/syncman/syncman.lst
!echo app/syncman/syncman_caller.py >> $WRK/fast/install/packages/syncman/syncma
n.lst
!echo bin/msgserver >> $WRK/fast/install/packages/syncman/syncman.lst
!echo bin/syncservice >> $WRK/fast/install/packages/syncman/syncman.lst
!echo bin/syncmangui >> $WRK/fast/install/packages/syncman/syncman.lst
!echo bin/syncmanacc >> $WRK/fast/install/packages/syncman/syncman.lst
!echo bin/syncmanjconf >> $WRK/fast/install/packages/syncman/syncman.lst
!echo app/syncman/example/createexampletables >> $WRK/fast/install/packages/sync
man/syncman.lst
!echo app/syncman/example/createexampledatabases >> $WRK/fast/install/packages/s
yncman/syncman.lst
'all.mac' not made because of dependency errors
06-02-06 22:48:43 end    of    all.mac   fast

!!! ERROR: dev-db/maxdb-src-7.6.0.16-r1 failed.
!!! Function src_compile, Line 124, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.



UPDATE #! Mundi here is the first ERROR reported in Compiles.
Code:


SQLDBC_Types-sdk.h     
ERROR: missing source    '/var/tmp/portage/maxdb-src-7.6.0.16-r1/work/V76_00_16/MaxDB_ORG/usr/lib/libSQLDBC.a'
ERROR: missing source    '/var/tmp/portage/maxdb-src-7.6.0.16-r1/work/V76_00_16/MaxDB_ORG/usr/lib/libSQLDBC_C.a'
ERROR: missing source    '/var/tmp/portage/maxdb-src-7.6.0.16-r1/work/V76_00_16/MaxDB_ORG/usr/lib/libSQLDBC.so'
'SQLDBC.mac' not made because of dependency errors

Second error:
error of command "cd $WRK/obj/SAPDB/Interfaces/Perl/DBD && $TOOLSHELL Makefile.PL && make dist" ignored
ERROR: missing source    '/var/tmp/portage/maxdb-src-7.6.0.16-r1/work/V76_00_16/MaxDB_ORG/sys/wrk/obj/SAPDB/Interfaces/Perl/DBD/DBD-MaxDB-7.6.00.16.tar.gz'

Third reportted :
cannot utime 'vls14_parse.o': 2, No such file or directory
ERROR: error while touching vls14_parse.o




'default.mac' not made because of dependency errors
Back to top
View user's profile Send private message
tschenturs
n00b
n00b


Joined: 17 Nov 2004
Posts: 12

PostPosted: Fri May 05, 2006 9:49 am    Post subject: Compile on current Gentoo system - issue with sys-devel/flex Reply with quote

Hi all

I had some problems recompiling the current ebuilds on a up-to-date gentoo box (x86 but quite some packages in ~x86).


Code:

Portage 2.1_pre10-r2 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r3, 2.6.16-gentoo-r6 i686)
=================================================================
System uname: 2.6.16-gentoo-r6 i686 Intel(R) Pentium(R) M processor 2.00GHz
Gentoo Base System version 1.12.0_pre19
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [disabled]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5


Eventually I managed to identify the single cause of failure ;-):

Masking >=sys-devel/flex-2.5.33 and thus downgrading to flex-2.5.4a-r6 made it.

HTH, Urs
Back to top
View user's profile Send private message
grassu
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2004
Posts: 91
Location: Berlin

PostPosted: Tue Aug 22, 2006 11:13 am    Post subject: Reply with quote

Hi,

I'm trying to emerge maxdb-src with the ebuild. Devtools has been emerged successful.
First the maxdb-src ebuild couldn't fetch the source-package. After changing the SRC_URI to SRC_URI="http://downloads.mysql.com/archives/maxdb/7.6.00.16/maxdb-source-7_6_00_16.tgz" it worked.

But now I get a lot of dependency errors while compiling and it stops there:

Code:

Error while executing "c++ -DREL30 -DLINUX -DX86_64 -DSAG -DSDB_RELEASE\
_070600 -I/var/tmp/portage/maxdb-src-7.6.0.16-r1/work/V76_00_16/MaxDB_OR\
G/usr/incl -I/var/tmp/portage/maxdb-src-7.6.0.16-r1/work/V76_00_16/MaxDB\
_ORG/sys/wrk/incl -I/var/tmp/portage/maxdb-src-7.6.0.16-r1/work/V76_00_1\
6/MaxDB_ORG/sys/wrk/incl/SAPDB -DSYSV -D_SVID -I/usr/include/ncurses -w \
-Wall -DBIT64 -fPIC -DHAS_NPTL -DMsg_List=SAPDBErr_MessageList -DOMS_IMP\
LEMENTATION -fno-strict-aliasing -DSAPDB_FAST -D_REENTRANT -O -I/opt/sdb\
/devtools/incl -O3 -pipe -march=k8 -fomit-frame-pointer -c sphsapdb.cpp"\

message: Inappropriate ioctl for device
 at /opt/sdb/devtools/bin/compc.pl line 413
COMMAND error 25
sphsapdb.lst fast  ascii
'sphsapdb.dld' not made because of dependency errors
'allbw.mac' not made because of dependency errors
websql.war fast  binary
README.txt fast  ascii
README.txt fast  ascii
data_sources.xml fast  ascii
webdavcontext.xml fast  ascii
WebDAVDB_ds.xml fast  ascii
webdavServletMaxDB_1.0.ear fast  binary
webdavServletMaxDB_1.0.war fast  binary
webdavServletMaxDB_1.0.xml fast  ascii
syncman.zip fast  binary
syncman.tgz fast  binary
syncman_caller.py fast  ascii
msgserver fast  ascii
syncservice fast  ascii
syncmangui fast  ascii
syncmanacc fast  ascii
syncmanjconf fast  ascii
createexampletables fast  ascii
createexampledatabases fast  ascii
!mkdir -p $WRK/fast/install/packages/syncman
!cd $INSTROOT && tar -xvzf app/syncman/syncman.tgz
app/syncman/doc/RunningTheMessageServer.pdf
app/syncman/doc/SynchronizationManager.pdf
app/syncman/MSGSERVER.xml
app/syncman/lib/jndi.properties
app/syncman/lib/msgserver.jar
app/syncman/lib/syncmanacc.jar
app/syncman/lib/syncmangui.jar
app/syncman/lib/syncservice.jar
app/syncman/example/lib/syncmanexample.jar
app/syncman/example/Readme_SyncManExample.txt
app/syncman/example/doc/SyncManExample.pdf
!tar -tzf  $INSTROOT/app/syncman/syncman.tgz > $WRK/fast/install/packages/syncman/syn                                                                            cman.lst
!echo app/syncman/syncman.zip >> $WRK/fast/install/packages/syncman/syncman.lst
!echo app/syncman/syncman_caller.py >> $WRK/fast/install/packages/syncman/syncman.lst
!echo bin/msgserver >> $WRK/fast/install/packages/syncman/syncman.lst
!echo bin/syncservice >> $WRK/fast/install/packages/syncman/syncman.lst
!echo bin/syncmangui >> $WRK/fast/install/packages/syncman/syncman.lst
!echo bin/syncmanacc >> $WRK/fast/install/packages/syncman/syncman.lst
!echo bin/syncmanjconf >> $WRK/fast/install/packages/syncman/syncman.lst
!echo app/syncman/example/createexampletables >> $WRK/fast/install/packages/syncman/s                                                                            yncman.lst
!echo app/syncman/example/createexampledatabases >> $WRK/fast/install/packages/syncma                                                                            n/syncman.lst
'all.mac' not made because of dependency errors
22-08-06 11:21:03 end    of    all.mac   fast

!!! ERROR: dev-db/maxdb-src-7.6.0.16-r1 failed.
Call stack:
  ebuild.sh, line 1543:   Called dyn_compile
  ebuild.sh, line 938:   Called src_compile
  maxdb-src-7.6.0.16-r1.ebuild, line 125:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant                                                                            .

!!! This ebuild is from an overlay: '/usr/local/portage'


I also downgraded flex to flex-2.5.4a-r6 as mentioned from tschenturs. The error still remains.

Any suggestions?

Thanks,
grassu
Back to top
View user's profile Send private message
dracozny
Tux's lil' helper
Tux's lil' helper


Joined: 04 May 2004
Posts: 86

PostPosted: Sat Dec 16, 2006 7:06 am    Post subject: Reply with quote

ok i followed everything up to this point and am not sure whats going on
so i tried a bunch of variations just incase I coppied a typo

Code:
maxdb-devtools-src # emerge maxdb-devtools
Calculating dependencies
emerge: there are no ebuilds to satisfy "maxdb-devtools".

draco4 maxdb-devtools-src # emerge maxdb-devtools-src
Calculating dependencies
emerge: there are no ebuilds to satisfy "maxdb-devtools-src".

draco4 maxdb-devtools-src # emerge maxdb-src
Calculating dependencies
emerge: there are no ebuilds to satisfy "maxdb-src".


even did a search for max and got nothing

*edit*
after going to the mysql site I discovered that the links in the ebuilds are no longer valid*

edit2
fixed the linking issue which downloaded the files but i get the same result with emerge not finding it

edit3
found the ebuild with emerge not sure what happend, did emerge search max and found it so i did
Code:
emerge dev-db/maxdb-devtools-src

after finding it in the search and now it is installing yet
Code:
emerge maxdb-devtools-src

results in no build found

edit 4*
ok i give when is the next ebuild, after hacking this thing for the last 6 hours I am feeling completely unproductive
i installed ed I had to go with another src as the original is no longer availble, i deleted the patch ref as they were no longer applicable in latest release from mysql, so far i have the problem with optlib being referenced and its not in /opt/sdb/devtools/bin the bin is actually in /opt/sdb/devtools/sys/src/Python. so this leaves me in a quandry of searching and hacking till my fingers fall off.

by the way
http://www.johnsingleton.com/maxdb/2004/06/five-reasons-why-maxdb-will-replace.html this domain is for sale, so you may need to update your links
_________________
“I do not think there is any thrill that can go through the human heart like that felt by the inventor as he sees some creation of the brain unfolding to success... Such emotions make a man forget food, sleep, friends, love, everything.”
-Nikola Tesla-
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum